Subject: [tsvwg] Request for feedback on 3GPP investigation on dynamic Port handling

From: Magnus Westerlund <[email-masked]>
Date: Wed, 9 Dec 2020 08:27:57 +0000

TSVWG,

As this is the WG that has defined the Transport Port number registration rules
(RFC6335), I think you can both have interest and maybe help provide feedback. 

3GPP CT4 WG is working towards defining a solution for how to handle service
discovery of 3GPP network internal services. This is currently in the first
stage where they are investigating options that will lead up to an choice for a
solution to specify. 

So the current draft of their technical report can be retrived here (MS Word):
https://www.3gpp.org/ftp/Specs/latest-drafts/29835-021.zip

So I am happy to gather together the feedback we have. I plan to do this in time
for their meeting starting the 25th of January. You may also send it directly to
CT4 mailing list: [email-masked]

Cheers

Magnus

---

From: Joseph Touch <[email-masked]>
Date: Wed, 9 Dec 2020 17:03:15 -0800

> On Dec 9, 2020, at 12:27 AM, Magnus Westerlund <magnus.westerlund=[email-masked]> wrote:
> 
> TSVWG,
> 
> (RFC6335),

Also RFC7605, which applies here as well.

> I think you can both have interest and maybe help provide feedback. 

FWIW, the experts team has already had extensive discussions with 3GPP and previous transport ADs on this issue.

To my knowledge, 3GPP is not applying via IETF process.

> https://www.3gpp.org/ftp/Specs/latest-drafts/29835-021.zip

I’d just note that much of the information in that doc is not accurate. At a minimum, it would be useful for others here to note that 3GPP is not the only party who has requested either a “block” of ports or an ongoing stream of requests. In all previous cases, the experts team has recommended - as here - that the applicant figure out how to run their services on one port. Although any individual request may appear to be inconsequential give the current rate of assignments, if we set a precedent here, we have to afford others the same opportunity.

Joe (in case others don’t know, I’ve been participating on that review team since 2007)