Subject: [tsvwg] Fwd: New Version Notification for draft-heist-tsvwg-ecn-deployment-observations-01.txt

From: Pete Heist <[email-masked]>
Date: Sat, 20 Feb 2021 14:37:40 +0100

-------- Forwarded Message --------
> A new version of I-D, draft-heist-tsvwg-ecn-deployment-observations-
> 01.txt
> has been successfully submitted by Peter G. Heist and posted to the
> IETF repository.
> 
> Name:           draft-heist-tsvwg-ecn-deployment-observations
> Revision:       01
> Title:          Explicit Congestion Notification (ECN) Deployment
> Observations
> Document date:  2021-02-20
> Group:          Individual Submission
> Pages:          27
> URL:           
> https://www.ietf.org/archive/id/draft-heist-tsvwg-ecn-deployment-observations-01.txt
> Status:        
> https://datatracker.ietf.org/doc/draft-heist-tsvwg-ecn-deployment-observations/
> Html:          
> https://www.ietf.org/archive/id/draft-heist-tsvwg-ecn-deployment-observations-01.html
> Htmlized:      
> https://tools.ietf.org/html/draft-heist-tsvwg-ecn-deployment-observations-01
> Diff:          
> https://www.ietf.org/rfcdiff?url2=draft-heist-tsvwg-ecn-deployment-observations-01
> 
> Abstract:
>    This note presents data gathered at an Internet Service Provider's
>    gateway on the observed deployment and usage of ECN.  Relevant IP
>    counter and flow tracking data was collected and analyzed for TCP
> and
>    other protocols.

* Added ECT(0) to TCP table (thanks Bob) and re-ordered its columns.

* Added the fact that Not-ECT by IP isn't collected to the Limitations
section.

* Added a sentence in Affiliation to note that I wrote the script for
the fq_codel instances used in the two backhaul subnets.

I'd also add that from the limited parts of this network I've seen so
far, congestion seems to occur only occasionally, during peak loads,
but it is still a data point.

---

From: Pete Heist <[email-masked]>
Date: Fri, 26 Feb 2021 12:28:21 +0100

After the draft window opens again, we'll post a new version that
better identifies possible AQM activity, removing what we think are
some false positives. I've made a provisional version available:

https://www.heistp.net/downloads/ecn-deployment-observations/draft-heist-tsvwg-ecn-deployment-observations.html

Quick Summary:
The proportion of TCP ECN negotiating member IPs that saw possible AQM
marking has decreased to 71/382 (18.6%), a reduction taken mostly from
IPs that saw AQM activity from unknown sources, now 33/382 (8.6%).

Explanation:
We found that a number of the TCP ECN results show unexpected CE/ECE
ratios suggesting something other than congestion and AQM activity. The
analysis program has been updated to attempt to filter these out, and
the results have been corrected. A "Flags" column has been added to the
table in Section 5.2 to make it easier to read.

We've also added some language around the limitations in AQM
identification, basically that there may be false positives and false
negatives, and that we can't know if we've identified all AQMs on the
utilized paths.

Pete