Subject: [tsvwg] Milestones changed for tsvwg WG

From: IETF Secretariat <[email-masked]>
Date: Mon, 08 Mar 2021 11:31:07 -0800

Changed milestone "Submit 'Guidelines for Adding Congestion Notification to
Protocols that Encapsulate IP' as a BCP RFC", set due date to June 2021 from
November 2020.

Changed milestone "Submit 'Propagating Explicit Congestion Notification
Across IP Tunnel Headers Separated by a Shim' as a Proposed Standard RFC",
set due date to June 2021 from November 2020.

Changed milestone "Submit " Transport Options for UDP" as a Proposed Standard
RFC", set due date to June 2021 from February 2021.

Changed milestone "Submit "Stream Control Transmission Protocol" aka
RFC4960.bis as a Proposed Standard RFC", set due date to September 2021 from
December 2020.

Changed milestone "Submit "A Non-Queue-Building Per-Hop Behavior (NQB PHB)
for Differentiated Services" as a Proposed Standard RFC", set due date to
September 2021 from February 2021.

Changed milestone "Submit "Low Latency, Low Loss, Scalable Throughput (L4S)
Internet Service: Architecture" as an Informational RFC", set due date to
October 2021 from October 2020.

URL: https://datatracker.ietf.org/wg/tsvwg/about/

---

From: "Black, David" <[email-masked]>
Date: Mon, 8 Mar 2021 21:06:29 +0000

This is the update to the WG milestones as discussed in the meeting.  There are three groups of drafts wrt the milestones:

	1. Before next IETF meeting (June milestones): The two ECN encapsulation drafts and the UDP options draft
	2. Around next IETF meeting or not too long thereafter (September milestones, allowing for not much to happen in August): SCTP.bis and NQB PHB.
	3. Before IETF meeting after next (October milestones): L4S drafts.

Thanks, --David

-----Original Message-----
From: tsvwg <[email-masked]> On Behalf Of IETF Secretariat
Sent: Monday, March 8, 2021 2:31 PM
To: [email-masked]
Subject: [tsvwg] Milestones changed for tsvwg WG

[EXTERNAL EMAIL] 

Changed milestone "Submit 'Guidelines for Adding Congestion Notification to Protocols that Encapsulate IP' as a BCP RFC", set due date to June 2021 from November 2020.

Changed milestone "Submit 'Propagating Explicit Congestion Notification Across IP Tunnel Headers Separated by a Shim' as a Proposed Standard RFC", set due date to June 2021 from November 2020.

Changed milestone "Submit " Transport Options for UDP" as a Proposed Standard RFC", set due date to June 2021 from February 2021.

Changed milestone "Submit "Stream Control Transmission Protocol" aka RFC4960.bis as a Proposed Standard RFC", set due date to September 2021 from December 2020.

Changed milestone "Submit "A Non-Queue-Building Per-Hop Behavior (NQB PHB) for Differentiated Services" as a Proposed Standard RFC", set due date to September 2021 from February 2021.

Changed milestone "Submit "Low Latency, Low Loss, Scalable Throughput (L4S) Internet Service: Architecture" as an Informational RFC", set due date to October 2021 from October 2020.

---

From: Bob Briscoe <[email-masked]>
Date: Mon, 8 Mar 2021 22:21:49 +0000

David,

I'm afraid I missed the beginning of the meeting (a dumb error on my 
part with time zone). Sorry about that.

Yes, I think we're either there, or almost there on the encap drafts. If 
we do have agreement, we could possibly go straight after this meeting - 
sooner than June anyway.

Can we review the L4S milestones at the closing part of the L4S session 
on Wed? It seems a bit back-to-front to decide the milestones before the 
progress has been reported.

Bob

-- 
________________________________________________________________
Bob Briscoe                               http://bobbriscoe.net/

---

From: "Black, David" <[email-masked]>
Date: Tue, 9 Mar 2021 14:37:12 +0000

Hi Bob,

The only change that was made to the L4S draft milestones was to move the architecture draft milestone from this past October (clearly missed) to join the other drafts, whose milestones are currently set to this coming October.  We can certainly discuss L4S progress/timing tomorrow.

Thanks, --David

-----Original Message-----
From: Bob Briscoe <[email-masked]> 
Sent: Monday, March 8, 2021 5:22 PM
To: Black, David; [email-masked]
Subject: Re: [tsvwg] FW: Milestones changed for tsvwg WG

[EXTERNAL EMAIL] 

David,

I'm afraid I missed the beginning of the meeting (a dumb error on my part with time zone). Sorry about that.

Yes, I think we're either there, or almost there on the encap drafts. If we do have agreement, we could possibly go straight after this meeting - sooner than June anyway.

Can we review the L4S milestones at the closing part of the L4S session on Wed? It seems a bit back-to-front to decide the milestones before the progress has been reported.

Bob

---

From: Bob Briscoe <[email-masked]>
Date: Wed, 10 Mar 2021 23:25:10 +0000

David,

On 09/03/2021 14:37, Black, David wrote:
> Hi Bob,
>
> The only change that was made to the L4S draft milestones was to move the architecture draft

[BB] Yes, I've been reminded by my colleagues that the other two drafts' 
milestones were already Oct 2021.

> milestone from this past October (clearly missed) to join the other drafts, whose milestones are currently set to this coming October.  We can certainly discuss L4S progress/timing tomorrow.

We didn't miss last October's milestone for l4s-arch. -07 was ready to 
go on 27 Oct '20, and the draft is still ready to go. This is what I 
mean about "bring me a rock" We were asked to get l4s-arch ready to go 
through before the others (on the basis it would be held back from RFC, 
but still worth getting the process started). We met the milestone, and 
now the milestone has moved by a whole year.

I did a rev to l4s-arch on 15 Nov 20, with some minor editorial fiddling 
with where references to drafts first appeared. But nothing technical, 
and I explained that it's now written so it is agnostic to what happens 
about l4sops / Classic ECN AQM.

Bob