Subject: [tsvwg] Correction to IETF 110 minutes on DTLS over SCTP

From: Magnus Westerlund <[email-masked]>
Date: Tue, 23 Mar 2021 11:48:42 +0000

Hi,

I would like to propose a correction to the IETF 110 minutes regarding this:

4.2 Magnus Westerlund: RFC6083.bis - Individual Draft

draft-westerlund-tsvwg-dtls-over-sctp-bis

3GPP have asked to resolve some issues with sending >16KB DTLS segments over

SCTP. There's also a desire to update the spec in RFC6083.

I would propose to change:

3GPP have asked to resolve some issues with sending >16KB DTLS segments over

SCTP.

To:

3GPP have asked to resolve some issues with sending >16KB DTLS protected
user messages over 

SCTP which is not supported by RFC 6083.

Reason for this change is that DTLS record size is currently limited to
2^14-1 bytes and RFC 6083 specifies that only a single DTLS record per user
message. And what is really needed is something that allows transmission of
larger user messages that are protected by DTLS.

I would also propose to change:

There's also a desire to update the spec in RFC6083.

To:

There's also a desire to update the security algorithms and requirements in
RFC6083.

Cheers

Magnus Westerlund

---

From: Gorry Fairhurst <[email-masked]>
Date: Tue, 23 Mar 2021 12:04:02 +0000

These changes look good to me.
We will make sure the notes reflect this,
Gorry

On 23/03/2021 11:48, Magnus Westerlund wrote:
> 3GPP have asked to resolve some issues with sending >16KB DTLS 
> protected user messages over
>
> Reason for this change is that DTLS record size is currently limited 
> to 2^14-1 bytes and RFC 6083 specifies that only a single DTLS record 
> per user message. And what is really needed is something that allows 
> transmission of larger user messages that are protected by DTLS.
>
> There's also a desire to update the security algorithms and 
> requirements in RFC6083.
>
> Cheers
>
> Magnus Westerlund
>