Subject: [tsvwg] Classifying on ECT(1) (was: Adoption call for draft-white-tsvwg-l4sops - to conclude 24th March 2021)

From: "Tilmans, Olivier (Nokia - BE/Antwerp)" <[email-masked]>
Date: Tue, 23 Mar 2021 10:06:06 +0000

Hi,

 > Sec. 4 (Operator of a Network) of the draft presumes that deployed
 > equipment is capable to classifying packets specifically on ECT(1).
 > Have the authors confirmed that this feature is available on commonly
 > deployed operator gear (e.g., IOS-XR, JUNOS)?

FPM on IOS/flexible-match firewall filters on Junos enable you to
classify  based on arbitrary bit masks, and use classification results
as usual, e.g., map to qos-groups/CoS/VRF/...

The associated deployment complexity/feasibility will of course vary
on a config by config basis, i.e., your NOC is likely your best source
of answers.

Best,
Olivier

---

From: Steven Blake <[email-masked]>
Date: Tue, 23 Mar 2021 20:07:10 -0400

On Tue, 2021-03-23 at 10:06 +0000, Tilmans, Olivier (Nokia -
> on a config by config basis, i.e., your NOC is likely your best

Thanks. Are you sure FPM is supported on IOS-XR? I'm not finding any
evidence of that. I'm not finding any evidence that it is supported on
Juniper PTX boxes, either, and the story for MX boxes seems confusing.

Since this is critical to enabling operators (not participating in an
experiment) to protect themselves from L4S traffic, it would be
worthwhile to confirm this capability is widely available on deployed
gear. Perhaps the draft could include some configuration information in
an appendix?

Regards,

// Steve

---

From: <[email-masked]>
Date: Wed, 24 Mar 2021 06:56:13 +0000

Hi Steve,

I'd suggest to concentrate on routers present at interconnection / IP-layer (if an operator doesn't participate in an L4S experiment and you assume presence of L4S traffic, peering and transit interconnections likely act as sources, I assume). Juniper PTX is designed as a Label Switch Router. It can be deployed on IP layer too, but as far as I recall, its capabilities are limited as compared to Juniper MX.

Regards, Ruediger

-----Ursprüngliche Nachricht-----
Von: tsvwg <[email-masked]> Im Auftrag von Steven Blake
Gesendet: Mittwoch, 24. März 2021 01:07
An: Tilmans, Olivier (Nokia - BE/Antwerp) <[email-masked]>
Cc: [email-masked]
Betreff: Re: [tsvwg] Classifying on ECT(1) (was: Adoption call for draft-white-tsvwg-l4sops - to conclude 24th March 2021)

BE/Antwerp) wrote:
>  > Have the authors confirmed that this feature is available on 
> commonly  > deployed operator gear (e.g., IOS-XR, JUNOS)?
> 

Thanks. Are you sure FPM is supported on IOS-XR? I'm not finding any evidence of that. I'm not finding any evidence that it is supported on Juniper PTX boxes, either, and the story for MX boxes seems confusing.

Since this is critical to enabling operators (not participating in an
experiment) to protect themselves from L4S traffic, it would be worthwhile to confirm this capability is widely available on deployed gear. Perhaps the draft could include some configuration information in an appendix?

Regards,

// Steve

---

From: Sebastian Moeller <[email-masked]>
Date: Wed, 24 Mar 2021 10:26:17 +0100

Hi Ruediger,

do you know the cost of doing FPM filtering on all packets? That is, is such filtering something operators do routinely in production networks (as I expect), or is that a feature used for debugging mostly due to high computational cost? 

Best Regards
	Sebastian

> On Mar 24, 2021, at 07:56, <[email-masked]> <[email-masked]> wrote:
> 
> Hi Steve,
>

---

From: <[email-masked]>
Date: Wed, 24 Mar 2021 11:04:27 +0000

Hi Sebastian,

I've heard about bitmask filtering, but I don't deploy that. So far, making sure that the DSCP values of incoming traffic don't cause harm is part of my job, but that doesn't include the ECN bits. So I can't judge the impact and convenience of FPM filtering.

Regards,

Ruediger

-----Ursprüngliche Nachricht-----
Von: Sebastian Moeller <[email-masked]> 
Gesendet: Mittwoch, 24. März 2021 10:26
An: Geib, Rüdiger <[email-masked]>
Cc: [email-masked]; [email-masked]
Betreff: Re: [tsvwg] Classifying on ECT(1) (was: Adoption call for draft-white-tsvwg-l4sops - to conclude 24th March 2021)

Hi Ruediger,

Best Regards
	Sebastian

> Betreff: Re: [tsvwg] Classifying on ECT(1) (was: Adoption call for 
> draft-white-tsvwg-l4sops - to conclude 24th March 2021)
> 
>> classify  based on arbitrary bit masks, and use classification 
>> results as usual, e.g., map to qos-groups/CoS/VRF/...
>> 
>> on a config by config basis, i.e., your NOC is likely your best 
>> source of answers.
>> 
>> 
>> Best,
>> Olivier
>

---

From: Sebastian Moeller <[email-masked]>
Date: Wed, 24 Mar 2021 12:09:01 +0100

Hi Ruediger,

thank you very much, anybody else here knowing the "cost" of FPM, please let us know.

Best Regards
	Sebastian

> On Mar 24, 2021, at 12:04, <[email-masked]> <[email-masked]> wrote:
> 
> Hi Sebastian,
>