Subject: [tsvwg] draft-white-tsvwg-nqb-02#page-7 correctness issue

From: Sebastian Moeller <[email-masked]>
Date: Sat, 24 Apr 2021 21:42:38 +0200

https://datatracker.ietf.org/doc/html/draft-white-tsvwg-nqb-02#page-7 states about fq_codel:
"In effect, the network element is
   making a decision as to what constitutes a flow, and then forcing all
   such flows to take equal bandwidth at every instant."

That seems simply incorrect. Only flows with queued up packets will be served equally, flows with lower rates will a) only be served up to that rate, and b) the reminder to their "fair-share of the capacity" will be equitably shared among all flows with higher rates.
I wonder why the NQB draft needs such along section about "Comparison to Existing Approaches" at all, but if it carries such a section I would prefer that section to be factual correct.

"The Dual-queue approach defined in this document achieves the main
   benefit of fq_codel: latency improvement without value judgements,
   without the downsides."

That also seems counterfactual, as NQB works exactly by looking at the value of the DSCP and hence makes a value judgement, while fq_codel looks at the behavior of flows (dynamically in relation to available capacity).

Best Regards
	Sebastian

---

From: Greg White <[email-masked]>
Date: Tue, 27 Apr 2021 22:54:02 +0000

Hi Sebastian,

The current version of the NQB draft can be found here: https://www.ietf.org/archive/id/draft-ietf-tsvwg-nqb-05.html

Best Regards,
Greg

On 4/24/21, 1:43 PM, "tsvwg on behalf of Sebastian Moeller" <[email-masked] on behalf of [email-masked]> wrote:

    Best Regards
    	Sebastian

---

From: Sebastian Moeller <[email-masked]>
Date: Wed, 28 Apr 2021 09:35:53 +0200

Hi Greg,

thanks, sorry for my confusion, I had googled for the NQB draft to look up another detail and failed to check whether I got the most recent version. I should have double checked that before reading/posting, the text in question is not part of the current draft, so my points are moot.

Thanks
	Sebastian

> On Apr 28, 2021, at 00:54, Greg White <[email-masked]> wrote:
> 
> Hi Sebastian,
>