Subject: [tsvwg] 3GPP Liaison Statement clarifying port requests

From: Martin Duke <[email-masked]>
Date: Tue, 18 May 2021 10:48:58 -0700

Hello TSVWG and port experts,

We got this 3GPP Liaison Statement last month:
https://datatracker.ietf.org/liaison/1726/

The key paragraphs are:

3GPP understands that it could be possible to assign to 3GPP a port per
transport protocol (UDP, TCP, SCTP, DCCP) that will be used for service port
negotiation/discovery for all the future internal interfaces defined by 3GPP,
avoiding the need for a systematic IANA port assignment for interfaces used
only inside the 3GPP system...

...it is also the 3GPP understanding that this statement cannot
prohibit 3GPP to request in the future a port assignment for a new service
application for which none of the port assignment alternatives would be
applicable.

They would like confirmation, IIUC, that they are not cut off from any
further port assignments.

Any feedback on what I should tell them in response?

Your friendly AD,
Martin

---

From: Joseph Touch <[email-masked]>
Date: Tue, 18 May 2021 20:08:07 -0700

Hi, Martin,

The only response I can imagine would be:

“Port assignments are assigned as per RFC6335 and RCC7605. No party is ever directly prohibited from applying for port assignments. Those terms are set by the IETF and IANA, and are updated by IETF consensus; they are not subject to negotiation.”

I.e., although what they state is true, it is not true by some sort of agreement between the IETF and 3GPP.

Joe

> On May 18, 2021, at 10:48 AM, Martin Duke <[email-masked]> wrote:
> 
> https://datatracker.ietf.org/liaison/1726/ <https://datatracker.ietf.org/liaison/1726/>
> 
> The key paragraphs are:
> They would like confirmation, IIUC, that they are not cut off from any further port assignments.

---

From: Martin Duke <[email-masked]>
Date: Wed, 19 May 2021 16:46:29 -0700

OK, here's what I have:

Thank you for your correspondence about port allocation. In your latest
message you write:

“However, besides the assignment of transport protocol port(s) that could be

requested by 3GPP for the deployment of specific service discovery

mechanism(s), it is also the 3GPP understanding that this statement cannot

applicable.”

Your understanding is correct. Our previous statements on this subject are
intended to reduce port requests with a low chance of approval, but no
party is ever prohibited from requesting a port assignment. A application
justified by a particular use case will be evaluated in accordance with
IETF and IANA policy, just like any other.

***
anything to add, or is that good enough?

On Tue, May 18, 2021 at 8:08 PM Joseph Touch <[email-masked]> wrote:

> “Port assignments are assigned as per RFC6335 and RCC7605. No party is
> ever directly prohibited from applying for port assignments. Those terms
> are set by the IETF and IANA, and are updated by IETF consensus; they are
> not subject to negotiation.”
>

---

From: Joe Touch <[email-masked]>
Date: Wed, 19 May 2021 16:47:49 -0700

Looks good to me.  

> On May 19, 2021, at 4:47 PM, Martin Duke <[email-masked]> wrote:
> 
> 
> OK, here's what I have:
> 
> Thank you for your correspondence about port allocation. In your latest message you write:
> 
> Your understanding is correct. Our previous statements on this subject are intended to reduce port requests with a low chance of approval, but no party is ever prohibited from requesting a port assignment. A application justified by a particular use case will be evaluated in accordance with IETF and IANA policy, just like any other.
> 
> ***

---

From: Mirja Kuehlewind <[email-masked]>
Date: Thu, 20 May 2021 09:04:41 +0000

Hi Martin,

this generally looks good to me and keeping it short is probably the right approach. I believe one of their meta-concern is still that it is maybe not fully clear to them when they should ask for a port. Also I think if they specify any new services that could be used internet-wide, we actually want them to come to us.

Maybe a tiny little tweak could help:

OLD

A application justified by a particular use case will be evaluated in accordance with IETF and IANA policy, just like any other.

NEW

A application justified by a particular use case, especially if that use case is deployed over the open Internet, should be registered with IANA and will be evaluated in accordance with IETF and IANA policy, just like any other request.

Not sure if that is too much or helps at all but wanted to propose it for your consideration.

Mirja

From: tsvwg <[email-masked]> on behalf of Martin Duke <[email-masked]>
Date: Thursday, 20. May 2021 at 01:47
To: Joseph Touch <[email-masked]>
Cc: Joseph Touch via IANA-Port-Experts <[email-masked]>, tsvwg <[email-masked]>
Subject: Re: [tsvwg] 3GPP Liaison Statement clarifying port requests

OK, here's what I have:

applicable.”

***

On Tue, May 18, 2021 at 8:08 PM Joseph Touch <[email-masked]<mailto:[email-masked]>> wrote:
Hi, Martin,

Joe

On May 18, 2021, at 10:48 AM, Martin Duke <[email-masked]<mailto:[email-masked]>> wrote:

The key paragraphs are:

applicable.

Your friendly AD,
Martin

---

From: Spencer Dawkins at IETF <[email-masked]>
Date: Thu, 20 May 2021 07:46:28 -0500

Martin,

On Thu, May 20, 2021 at 4:05 AM Mirja Kuehlewind <mirja.kuehlewind=
[email-masked]> wrote:

> Hi Martin,
>
>
>
> this generally looks good to me and keeping it short is probably the right
> approach. I believe one of their meta-concern is still that it is maybe not
> fully clear to them when they should ask for a port. Also I think if they
> specify any new services that could be used internet-wide, we actually want
> them to come to us.
>
>
>
> A application justified by a particular use case will be evaluated in
> accordance with IETF and IANA policy, just like any other.
>
>
>
> NEW
>
> A application justified by a particular use case, especially if that use
> case is deployed over the open Internet, should be registered with IANA
> and will be evaluated in accordance with IETF and IANA policy, just like
> any other request.
>
>
>

I think this helps.

There are certainly 3GPP participants who know what the "IETF and IANA
policy" for port assignments is, but for other participants who don't know
yet, and might be tempted to request a port assignment in the future, you
might want to include a reference to where you think people can find the
relevant policy.

Do The RIght Thing, of course.

Best,

Spencer

> Mirja
>
>
>
>
>
> *From: *tsvwg <[email-masked]> on behalf of Martin Duke <
> [email-masked]>
> *Date: *Thursday, 20. May 2021 at 01:47
> *To: *Joseph Touch <[email-masked]>
> *Cc: *Joseph Touch via IANA-Port-Experts <[email-masked]>,
> tsvwg <[email-masked]>
> *Subject: *Re: [tsvwg] 3GPP Liaison Statement clarifying port requests
>
>
>
> OK, here's what I have:
>
>
>

---

From: Martin Duke <[email-masked]>
Date: Thu, 20 May 2021 10:10:42 -0700

Thanks, changes applies.

On Thu, May 20, 2021 at 5:46 AM Spencer Dawkins at IETF <
[email-masked]> wrote:

>> this generally looks good to me and keeping it short is probably the
>> right approach. I believe one of their meta-concern is still that it is
>> maybe not fully clear to them when they should ask for a port. Also I think
>> if they specify any new services that could be used internet-wide, we
>> actually want them to come to us.
>>
>>
>>
>> Your understanding is correct. Our previous statements on this subject
>> are intended to reduce port requests with a low chance of approval, but no

---

From: Fred Baker <[email-masked]>
Date: Thu, 20 May 2021 10:43:48 -0700

From my perspective, 3GPP is forever and always empowered to ask, as is anyone else. However, there is no mandate requiring IANA to respond positively to the request. I would hope that they would file an internet draft proposing the new port assignment and arguing for it.

---

From: Joseph Touch <[email-masked]>
Date: Thu, 20 May 2021 11:10:22 -0700

Hi, Fred,

Although any sort of description is useful, we don’t require drafts for port assignments.

They used to be required for system ports (actually, they need to be standards-track), but we deprecate assigning those ports anyway now.

Joe

> On May 20, 2021, at 10:43 AM, Fred Baker <[email-masked]> wrote:
>

---

From: <[email-masked]>
Date: Thu, 20 May 2021 19:41:12 +0000

Hi,

To Fred:

When a port is requested by 3GPP, the solution requiring the new port is described in a 3GPP normative specification, document accepted by the IANA policy. Obviously, if the proposed solution is of general interest for Internet, an RFC publication will be requested.
And it is clear that it is not requested to be able to bypass the IANA policy regarding port number allocation nor to be automatic blessing for any request (as indicated in the liaison). I admit that it was not so clear in the past for some 3GPP folks.

To Martin:

The current proposed answer is fine for me. It is the level of feedback requested by 3GPP.

I don't know when the final version will be available but it would be great if an official LS reply could be received on Tuesday next week at the latest. The 3GPP CT4 working group is currently in virtual meeting.

Regards,

Lionel

-------- Message original --------
De : Joseph Touch <[email-masked]>
Date : jeu. 20 mai 2021 à 20:11
À : Fred Baker <[email-masked]>
Cc : [email-masked], tsvwg <[email-masked]>
Objet : Re: [tsvwg] 3GPP Liaison Statement clarifying port requests
Hi, Fred,

Joe

>> Any feedback on what I should tell them in response?

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: Martin Duke <[email-masked]>
Date: Thu, 20 May 2021 13:50:01 -0700

Lionel,

 I just submitted this for IESG review, and the 3GPP LS is addressed to the
IESG, so this Tuesday is unlikely.

On Thu, May 20, 2021 at 12:41 PM <[email-masked]> wrote:

> Hi,
>
> To Fred:
>
> When a port is requested by 3GPP, the solution requiring the new port is
> described in a 3GPP normative specification, document accepted by the IANA
> policy. Obviously, if the proposed solution is of general interest for
> Internet, an RFC publication will be requested.
> And it is clear that it is not requested to be able to bypass the IANA
> policy regarding port number allocation nor to be automatic blessing for
> any request (as indicated in the liaison). I admit that it was not so clear
> in the past for some 3GPP folks.
>
> To Martin:
>
> I don't know when the final version will be available but it would be
> great if an official LS reply could be received on Tuesday next week at the
> latest. The 3GPP CT4 working group is currently in virtual meeting.
>
> Regards,
>
> Lionel
>
>
> They used to be required for system ports (actually, they need to be
> standards-track), but we deprecate assigning those ports anyway now.
>
> Joe
>
> > From my perspective, 3GPP is forever and always empowered to ask, as is
> anyone else. However, there is no mandate requiring IANA to respond
> positively to the request. I would hope that they would file an internet
> draft proposing the new port assignment and arguing for it.
> >