Subject: [tsvwg] 3GPP SA2 submission "Use of L4S in 5GS"

From: Ingemar Johansson S <[email-masked]>
Date: Mon, 17 May 2021 08:47:00 +0000

Gentlepeople!

This input paper was submitted to the SA2 meeting that happens this week.

https://www.3gpp.org/ftp/tsg_sa/WG2_Arch/TSGS2_145E_Electronic_2021-05/Docs/
S2-2103904.zip

Co-signed by : Ericsson, Deutsche Telekom, AT&T, Verizon, Apple, T-Mobile
USA Inc. (possibly it will be supported  by more attendees)              

In retrospective : Yes TCP Prague should perhaps have be listed as
reference, the reason why not is (not bullet proof argument) that Prague is
still an individual draft. Weak argument, I know as e.g. L4S in SCReAM is
still only in running code, not in RFC8298, I will personally make up for
that ignorance in the future.

Regards
Ingemar

================================

Ingemar Johansson  M.Sc. 

Master Researcher

Ericsson Research

RESEARCHER

GFTL ER NAP NCM Netw Proto & E2E Perf

Labratoriegränd 11

977 53, Luleå, Sweden

Phone +46-1071 43042

SMS/MMS +46-73 078 3289

[email-masked]

www.ericsson.com <http://www.ericsson.com/> 

              Look again at that dot. 

   That's here. That's home. That’s us.
            Carl Sagan “A Pale Blue Dot”

=================================

---

From: Sebastian Moeller <[email-masked]>
Date: Mon, 17 May 2021 12:32:31 +0200

Hi Ingemar,

I read:

"L4S has been demonstrated in the RITE EU project [3],[4] and L4S technology is already used in data centers today [5].
[...]
[5.]  Data Center TCP (DCTCP): TCP Congestion Control for Data Centers, Bensley et al, Internet-draft, IETF, October 2017, https://tools.ietf.org/html/rfc8257"

and I wonder whether it might not be more cautious to maintain causal ordering and not subsume DCTCP as a L4S technology (or describe L4S as a successor to/extension of DCTCP)? IIRC DCTCP was already used before the rite project got started (with ACM conference contributions from 2010 and 2011)?

Best Regards
	Sebastian

> On May 17, 2021, at 10:47, Ingemar Johansson S <ingemar.s.johansson=[email-masked]> wrote:
> 
> Gentlepeople!
> 
> https://www.3gpp.org/ftp/tsg_sa/WG2_Arch/TSGS2_145E_Electronic_2021-05/Docs/S2-2103904.zip
> Co-signed by : Ericsson, Deutsche Telekom, AT&T, Verizon, Apple, T-Mobile USA Inc. (possibly it will be supported  by more attendees)              
>  
> In retrospective : Yes TCP Prague should perhaps have be listed as reference, the reason why not is (not bullet proof argument) that Prague is still an individual draft. Weak argument, I know as e.g. L4S in SCReAM is still only in running code, not in RFC8298, I will personally make up for that ignorance in the future.
>  
> Regards
> Ingemar
> www.ericsson.com

---

From: Ingemar Johansson S <[email-masked]>
Date: Mon, 17 May 2021 13:17:05 +0000

Hi Sebastian.

You are right, DCTCP stems from the time when it the shallow queue marking was termed immediate ECN, a few years before the term L4S was coined. 
It was needed to bake a message that is reasonably compact and perhaps the timeline was lost in the edit. I don't however believe that this is a critical matter as the first goal is to get this on the table in 3GPP.

/Ingemar

> -----Original Message-----
> From: Sebastian Moeller <[email-masked]>
> Sent: den 17 maj 2021 12:33
> To: Ingemar Johansson S <[email-masked]>
> Cc: TSVWG <[email-masked]>
> Subject: Re: [tsvwg] 3GPP SA2 submission "Use of L4S in 5GS"
> 
> Hi Ingemar,
> 
> I read:
> 
> "L4S has been demonstrated in the RITE EU project [3],[4] and L4S
> technology is already used in data centers today [5].
> [...]
> [5.]  Data Center TCP (DCTCP): TCP Congestion Control for Data Centers,
> Bensley et al, Internet-draft, IETF, October 2017,
> https://tools.ietf.org/html/rfc8257"
> 
> and I wonder whether it might not be more cautious to maintain causal
> ordering and not subsume DCTCP as a L4S technology (or describe L4S as a
> successor to/extension of DCTCP)? IIRC DCTCP was already used before the
> rite project got started (with ACM conference contributions from 2010 and
> 2011)?
> 
> 
> Best Regards
> 	Sebastian
> 
> 
> > On May 17, 2021, at 10:47, Ingemar Johansson S
> <ingemar.s.johansson=[email-masked]> wrote:
> >
> > Gentlepeople!
> >
> still an individual draft. Weak argument, I know as e.g. L4S in SCReAM is still
> only in running code, not in RFC8298, I will personally make up for that
> ignorance in the future.
> >
> > Regards
> > Ingemar