Subject: [tsvwg] Adoption call for draft-custura-tsvwg-dscp-considerations-02 - to conclude 12th July 2021

From: "Black, David" <[email-masked]>
Date: Sat, 26 Jun 2021 01:50:33 +0000

TSVWG,

The WG is running an adoption call for:

    Considerations for Assigning a new Recommended DiffServ Codepoint (DSCP)

              draft-custura-tsvwg-dscp-considerations-02

    https://datatracker.ietf.org/doc/draft-custura-tsvwg-dscp-considerations/

This document is currently marked as INFORMATIONAL. The adoption call

will end at midnight UTC on 12th July 2021.

Please do read the draft, and send any comments/concerns to either the

tsvwg or to the chairs <[email-masked]<mailto:[email-masked]>>. Notes of support to

progress this work, and volunteers to review the drafts will also be

very welcome at this stage.

Martin Duke (as an individual) has already expressed his support for adopting this draft:

https://mailarchive.ietf.org/arch/msg/tsvwg/XVQW7x5CjElZkwbkMnBvzP_IWtg/

Thanks,

David and Wes

(tsvwg co-chairs)

[Gorry (third co-chair) is recused as an author of this draft]

---

From: Sebastian Moeller <[email-masked]>
Date: Wed, 30 Jun 2021 12:01:31 +0200

Dear tsvwg,

For what it is worth, I support that draft to be adopted.

I have one note though:

"5.1.  Mapping Specified for IEEE 802.11

   << This section is currently seeking more input. >>

   A 3-bit Priority Code Point (PCP) is specified in the IEEE 802.1Q tag
   to mark Ethernet frames to one of eight priority values.  The value
   zero indicates the default best effort treatment, and the value one
   indicates a background traffic class.  The remaining values indicate
   increasing priority.  Internet control traffic can be marked as six,
   and network control is marked as seven."

First, maybe reference IEEE Std 802.1Q-2018 Annex-I here as that discusses PCPs and their relationship to diffserv/intserv?

Then, there are still devices out in the field that do not treat PCP1 below PCP0 (for example some low port-count consumer switches). And given that older IEEE standards mapped PCP2, but not PCP1 lower than PCP0, it is to be expected that  there will be different behaviour depending on the age of deployed devices, especially since cheap consumer routers will likely never see a firmware update after they are sold, but might still linger on in the field for some time.

Best Regards
	Sebastian

> On Jun 26, 2021, at 03:50, Black, David <[email-masked]> wrote:
> 
> TSVWG,
>  
> tsvwg or to the chairs <[email-masked]>. Notes of support to

---

From: Gorry Fairhurst <[email-masked]>
Date: Wed, 30 Jun 2021 11:39:39 +0100

Please sse below:

> First, maybe reference IEEE Std 802.1Q-2018 Annex-I here as that discusses PCPs and their relationship to diffserv/intserv?
Yes - I see we need an IEEE reference here, we will add.
> Then, there are still devices out in the field that do not treat PCP1 below PCP0 (for example some low port-count consumer switches). And given that older IEEE standards mapped PCP2, but not PCP1 l…

Ah, there is more story here, thanks. I think we can add a note with 
this to the editor's copy, and ask the INTAREA people for more insight 
on how they see this developing ... that would be a useful part of 
developing this as a WG item.

Gorry