Subject: [tsvwg] RFC 9065 on Considerations around Transport Header Confidentiality, Network Operations, and the Evolution of Internet Transport Protocols

From: [email-masked]
Date: Wed, 14 Jul 2021 23:43:56 -0700 (PDT)

A new Request for Comments is now available in online RFC libraries.

        RFC 9065

        Title:      Considerations around Transport Header Confidentiality, 
                    Network Operations, and the Evolution of 
                    Internet Transport Protocols 
        Author:     G. Fairhurst,
                    C. Perkins
        Status:     Informational
        Stream:     IETF
        Date:       July 2021
        Mailbox:    [email-masked],
                    [email-masked]
        Pages:      37
        Updates/Obsoletes/SeeAlso:   None

        I-D Tag:    draft-ietf-tsvwg-transport-encrypt-21.txt

        URL:        https://www.rfc-editor.org/info/rfc9065

        DOI:        10.17487/RFC9065

To protect user data and privacy, Internet transport protocols have
supported payload encryption and authentication for some time. Such
encryption and authentication are now also starting to be applied to
the transport protocol headers. This helps avoid transport protocol
ossification by middleboxes, mitigate attacks against the transport
protocol, and protect metadata about the communication. Current
operational practice in some networks inspect transport header
information within the network, but this is no longer possible when
those transport headers are encrypted.

This document discusses the possible impact when network traffic uses
a protocol with an encrypted transport header. It suggests issues to
consider when designing new transport protocols or features.

This document is a product of the Transport Area Working Group Working Group of the IETF.

INFORMATIONAL: This memo provides information for the Internet community.
It does not specify an Internet standard of any kind. Distribution of
this memo is unlimited.

This announcement is sent to the IETF-Announce and rfc-dist lists.
To subscribe or unsubscribe, see
  https://www.ietf.org/mailman/listinfo/ietf-announce
  https://mailman.rfc-editor.org/mailman/listinfo/rfc-dist

For searching the RFC series, see https://www.rfc-editor.org/search
For downloading RFCs, see https://www.rfc-editor.org/retrieve/bulk

Requests for special distribution should be addressed to either the
author of the RFC in question, or to [email-masked].  Unless
specifically noted otherwise on the RFC itself, all RFCs are for
unlimited distribution.

The RFC Editor Team
Association Management Solutions, LLC

---

From: "Black, David" <[email-masked]>
Date: Thu, 15 Jul 2021 20:12:38 +0000

Congratulations to Gorry and Colin (authors) on publication of this RFC, and many thanks to all who have contributed.  

Thanks, --David (document shepherd)

David L. Black, Sr. Distinguished Engineer, Technology & Standards
Infrastructure Solutions Group, Dell Technologies
mobile +1 978-394-7754 [email-masked]

-----Original Message-----
From: IETF-Announce <[email-masked]> On Behalf Of [email-masked]
Sent: Thursday, July 15, 2021 2:44 AM
To: [email-masked]; [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: RFC 9065 on Considerations around Transport Header Confidentiality, Network Operations, and the Evolution of Internet Transport Protocols

[EXTERNAL EMAIL] 

        RFC 9065

        URL:        https://urldefense.com/v3/__https://www.rfc-editor.org/info/rfc9065__;!!LpKI!3M0NO0ODV-nt3C_DC5DEbl-yI4A8OwdN7J0j217lSSwjSNEywrkzCV8F7p9ezBCb$ [rfc-editor[.]org]

        DOI:        10.17487/RFC9065

This announcement is sent to the IETF-Announce and rfc-dist lists.
To subscribe or unsubscribe, see
  https://urldefense.com/v3/__https://www.ietf.org/mailman/listinfo/ietf-announce__;!!LpKI!3M0NO0ODV-nt3C_DC5DEbl-yI4A8OwdN7J0j217lSSwjSNEywrkzCV8F7h725XPb$ [ietf[.]org]
  https://urldefense.com/v3/__https://mailman.rfc-editor.org/mailman/listinfo/rfc-dist__;!!LpKI!3M0NO0ODV-nt3C_DC5DEbl-yI4A8OwdN7J0j217lSSwjSNEywrkzCV8F7uTvOMSc$ [mailman[.]rfc-editor[.]org]

For searching the RFC series, see https://urldefense.com/v3/__https://www.rfc-editor.org/search__;!!LpKI!3M0NO0ODV-nt3C_DC5DEbl-yI4A8OwdN7J0j217lSSwjSNEywrkzCV8F7hsHsezy$ [rfc-editor[.]org]
For downloading RFCs, see https://urldefense.com/v3/__https://www.rfc-editor.org/retrieve/bulk__;!!LpKI!3M0NO0ODV-nt3C_DC5DEbl-yI4A8OwdN7J0j217lSSwjSNEywrkzCV8F7ieNbsoW$ [rfc-editor[.]org]

The RFC Editor Team

_______________________________________________
IETF-Announce mailing list
[email-masked]
https://urldefense.com/v3/__https://www.ietf.org/mailman/listinfo/ietf-announce__;!!LpKI!3M0NO0ODV-nt3C_DC5DEbl-yI4A8OwdN7J0j217lSSwjSNEywrkzCV8F7h725XPb$ [ietf[.]org]

---

From: Colin Perkins <[email-masked]>
Date: Tue, 20 Jul 2021 22:34:40 +0100

Thanks, David. Hopefully the resulting document is useful to some.
Colin

> On 15 Jul 2021, at 21:12, Black, David <[email-masked]> wrote:
> 

-- 
Colin Perkins
https://csperkins.org/