Subject: Re: [tsvwg] New Liaison Statement, "LS to IETF TSVWG on MP-DCCP"

From: "Rakocevic, Veselin" <[email-masked]>
Date: Fri, 2 Jul 2021 12:24:39 +0000

Hi Markus, all

At City, University of London we have a testbed based on the open-source MP-DCCP code from https://multipath-dccp.org. We also use Google Pixel phones running the MP-DCCP framework and run tests with real applications, both WebRTC-based and file downloads, over commercial networks, testing the performance of MP-DCCP in different switching and steering scenarios. In future we plan to extend this towards the splitting scenario. We already published some academic papers with results and will continue our work on this.

While the steering and switching already delivers promising results, the splitting seems to have some implementation issues. We are looking forward to the next revision of the open-source software.

with regards

Veselin

--

________________________________
From: tsvwg <[email-masked]> on behalf of [email-masked] <[email-masked]>
Sent: 28 June 2021 17:35
To: [email-masked] <[email-masked]>; jholland=[email-masked] <jholland=[email-masked]>
Cc: [email-masked] <[email-masked]>
Subject: Re: [tsvwg] New Liaison Statement, "LS to IETF TSVWG on MP-DCCP"

CAUTION: This email originated from outside of the organisation. Do not click links or open attachments unless you recognise the sender and believe the content to be safe.

Hi Anna, all,

Thanks for raising this important point, why DCCP is a good choice for multipath support especially for non-TCP traffic.

I wonder if there are already testbed installation available which prove and verify MP-DCCP to be lightweight, as well as efficient due to access to path characteristic information (available bandwidth, RTT, ...)? Moreover, are there use cases in which you like to explore MP-DCCP?

For Deutsche Telekom I can reveal, that we have three testbed implementation using the open source Linux reference implementation from https://multipath-dccp.org. These testbeds are setup for PoC and trial activities with real devices and customers.

1. Provide Multipath in enterprise environment, converging Wi-Fi and 5G access.
Autonomous Guided Vehicles (AGV) is a first use case in this scenario, which verifies the resilience provided by MP-DCCP in a real industry environment. Integrated in the AGV and a MP-DCCP Proxy attached to a converged Wi-Fi6 and 5G SA core, builds the foundation of the testbed which is ready to be used in real customer PoCs. See also https://www.telekom.com/en/company/details/deutsche-telekom-demonstrates-multipath-for-fixed-mobile-convergence-on-campus-625838

2. Integrated in Google Pixel 4 devices as part of the OS (and controlled by the Android Network Manager) to verify its applicability towards 3GPP ATSSS. In this scenario, the MP-DCCP proxy is hosted in the public Internet and enables multipath transport between the phone and ANY Internet service. A video demonstrating this with a real Skype call can be found on the start page of https://multipath-dccp.org/. For the purpose of ATSSS, the GSMA ZTC taskforce identified MP-DCCP to be a solution, to close the open gap towards UDP support and therefore triggered the LS https://datatracker.ietf.org/liaison/1741/ towards TSVWG. DT provides all the members in the ZTC round access to their MP-DCCP testbed.

3. As part of internal residential gateway prototypes, MP-DCCP allows us to investigate its Hybrid Access capabilities according to BBF TR-470 on Wireless Wireline Convergence.

To all: I'm highly interested in your experience on MP-DCCP, details about existing testbeds and your potential plans with MP-DCCP. Please feel free to share your insights here...

Br

Markus

> -----Original Message-----
> From: Anna Brunström <[email-masked]>
> Sent: Mittwoch, 23. Juni 2021 17:25
> To: Holland, Jake <jholland=[email-masked]>; Amend, Markus
> <[email-masked]>
> Cc: [email-masked]
> Subject: RE: [tsvwg] New Liaison Statement, "LS to IETF TSVWG on MP-DCCP"
>
> > -----Original Message-----
> > From: tsvwg <mailto:[email-masked]> On Behalf Of Holland, Jake
> > Sent: den 18 juni 2021 17:23
> > To: mailto:[email-masked]; mailto:jholland=[email-masked];
> > mailto:[email-masked]; mailto:[email-masked]; mailto:[email-masked];
> > mailto:[email-masked]
> > Cc: mailto:[email-masked]; mailto:[email-masked]
> > Subject: Re: [tsvwg] New Liaison Statement, "LS to IETF TSVWG on MP-DCCP"
> >
> > Hi Markus,
> >
> > Thanks.  I think those diagrams are helpful.
> > https://multipath-dccp.org/intro.html
> > It looks like the idea is to wrap generic UDP traffic in a multipath-capable
> > tunnel at the OS level.
> >
> > That makes sense, and it looks like maybe ease of implementation on the
> > client devices is among the reasons to prefer it to other kinds of tunnels, if
> > I'm understanding it.  That seems like a fine reason.  Thanks for clearing that
> > up.
>
> I think you are correct here Jake, that MP-DCCP is quite light weight is a benefit.
> You also have the congestion control state, with RTT estimates etc., that can be
> used as input for scheduling and path management. This of course is a main
> benefit shared with other transport layer solutions.
>
> Best Regards,
> Anna
>
> >
> > Best,
> > Jake
> >
>
> När du skickar e-post till Karlstads universitet behandlar vi dina
> personuppgifter<https://www.kau.se/gdpr>.
> When you send an e-mail to Karlstad University, we will process your personal
> data<https://www.kau.se/en/gdpr>.

---

From: Andreas Kassler <[email-masked]>
Date: Tue, 13 Jul 2021 13:33:21 +0000

Hi Veselein, Markus, all,

at Karlstad University we have two testbeds based on the open-source version of MP-DCCP from https://multipath-dccp.org. One is based on the kernel space version and we also re-implemented MP-DCCP in user space under Mininet which allows us for rapid prototyping of new schedulers and reordering mechanisms. Using these two testbeds, we implemented a new packet scheduler “Adaptive Cheapest Path First”, which removes some problems with strict priority scheduling (CPF) when using it with congestion controlled tunnels. More information is available in our upcoming ANRW paper “Adaptive Cheapest Path First Scheduling in a Transport-Layer Multi-Path Tunnel Context”.
A preprint is available at https://arxiv.org/abs/2106.16003

We also have initial results for both switching versus splitting for mobile scenarios.

with regards

Andreas

> On 2 Jul 2021, at 14:24, Rakocevic, Veselin <[email-masked]> wrote:
>
>
>
>
> Hi Markus, all
>
> 2. Integrated in Google Pixel 4 devices as part of the OS (and controlled by the Android Network Manager) to verify its applicability towards 3GPP ATSSS. In this scenario, the MP-DCCP proxy is hosted in the public Internet and enables multipath transport between the phone and ANY Internet service. A video demonstrating this with a real Skype call can be found on the start page of https://multipath-dccp.org/. For the purpose of ATSSS, the GSMA ZTC taskforce identified MP-DCCP to be a solution, to close the open gap towards UDP support and therefore triggered the LShttps://datatracker.ietf.org/liaison/1741/ towards TSVWG. DT provides all the members in the ZTC round access to their MP-DCCP testbed.
>

Kind regards, Andreas Kassler
====================================
Prof. Dr. Andreas J. Kassler
Computer Science Department
Universitetsgatan 2
SE-65188 Karlstad
Sweden
Tel:   ++46 (0)54 700-2168
Fax:   ++46 (0)54 700-1828
eMail: [email-masked]
skype: andreaskassler
Web:   www.kau.se/forskare/andreas-kassler

När du skickar e-post till Karlstads universitet behandlar vi dina personuppgifter<https://www.kau.se/gdpr>.
When you send an e-mail to Karlstad University, we will process your personal data<https://www.kau.se/en/gdpr>.

---

From: <[email-masked]>
Date: Fri, 16 Jul 2021 09:10:28 +0000

Hi Andreas, Markus, all,

BT sees MP-DCCP as a good option for future Hybrid Access solutions that support non-TCP traffic, and especially for latency sensitive and unreliable flows. An aspect of MP-DCCP that is of particular interest is that it offers a lightweight mechanism for multipath traffic delivery which we believe is important in terms of reducing resource requirements (and improving energy efficiency) for mobile devices, CPE and network infrastructure.

Kind Regards,
Stephen

> From: tsvwg <[email-masked]> On Behalf Of Andreas Kassler
> Sent: Tuesday, 13 July 2021 14:33
> To: [email-masked]
> at Karlstad University we have two testbeds based on the open-source
> version of MP-DCCP from
> https://eur02.safelinks.protection.outlook.com/?url=https%3A%2F%2Fmulti
> path-
> dccp.org%2F&amp;data=04%7C01%7Cstephen.h.johnson%40bt.com%7Ceb3
> 27a3c585b40de3c0508d94602df9a%7Ca7f356889c004d5eba4129f146377ab0%
> 7C0%7C0%7C637617801620407922%7CUnknown%7CTWFpbGZsb3d8eyJWIjoi
> MC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C300
> 0&amp;sdata=RNJ3hwkDh75im4mIDGVa5M8Jpge7xr5PFEPl1KAKlHI%3D&am
> p;reserved=0. One is based on the kernel space version and we also re-
> implemented MP-DCCP in user space under Mininet which allows us for rapid
> prototyping of new schedulers and reordering mechanisms. Using these two
> testbeds, we implemented a new packet scheduler "Adaptive Cheapest Path
> First", which removes some problems with strict priority scheduling (CPF)
> when using it with congestion controlled tunnels. More information is
> available in our upcoming ANRW paper "Adaptive Cheapest Path First
> Scheduling in a Transport-Layer Multi-Path Tunnel Context".
> A preprint is available at
> https://eur02.safelinks.protection.outlook.com/?url=https%3A%2F%2Farxiv.
> org%2Fabs%2F2106.16003&amp;data=04%7C01%7Cstephen.h.johnson%40bt
> .com%7Ceb327a3c585b40de3c0508d94602df9a%7Ca7f356889c004d5eba4129f
> 146377ab0%7C0%7C0%7C637617801620407922%7CUnknown%7CTWFpbGZsb
> 3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0
> %3D%7C3000&amp;sdata=WAPx%2B1ehSRmI692OdAQMQK53mmHlBlpWBo
> nVdIpSt5I%3D&amp;reserved=0
> 
> > At City, University of London we have a testbed based on the open-source
> MP-DCCP code from
> https://eur02.safelinks.protection.outlook.com/?url=https%3A%2F%2Fmulti
> path-
> dccp.org%2F&amp;data=04%7C01%7Cstephen.h.johnson%40bt.com%7Ceb3
> 27a3c585b40de3c0508d94602df9a%7Ca7f356889c004d5eba4129f146377ab0%
> 7C0%7C0%7C637617801620407922%7CUnknown%7CTWFpbGZsb3d8eyJWIjoi
> MC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C300
> 0&amp;sdata=RNJ3hwkDh75im4mIDGVa5M8Jpge7xr5PFEPl1KAKlHI%3D&am
> p;reserved=0. We also use Google Pixel phones running the MP-DCCP
> framework and run tests with real applications, both WebRTC-based and file
> downloads, over commercial networks, testing the performance of MP-DCCP
> in different switching and steering scenarios. In future we plan to extend this
> towards the splitting scenario. We already published some academic papers
> with results and will continue our work on this.
> >
> > While the steering and switching already delivers promising results, the
> splitting seems to have some implementation issues. We are looking forward
> to the next revision of the open-source software.
> >
> > with regards
> >
> > Veselin
> >
> > --
> >
> >
> >
> >
> >
> >
> >
> >
> >
> > From: tsvwg <[email-masked]> on behalf of
> > [email-masked] <[email-masked]>
> > Sent: 28 June 2021 17:35
> > To: [email-masked] <[email-masked]>;
> > jholland=[email-masked]
> > <jholland=[email-masked]>
> > CAUTION: This email originated from outside of the organisation. Do not
> click links or open attachments unless you recognise the sender and believe
> the content to be safe.
> >
> >
> > Hi Anna, all,
> >
> > Thanks for raising this important point, why DCCP is a good choice for
> multipath support especially for non-TCP traffic.
> >
> > I wonder if there are already testbed installation available which prove and
> verify MP-DCCP to be lightweight, as well as efficient due to access to path
> characteristic information (available bandwidth, RTT, ...)? Moreover, are
> there use cases in which you like to explore MP-DCCP?
> >
> > For Deutsche Telekom I can reveal, that we have three testbed
> implementation using the open source Linux reference implementation from
> https://eur02.safelinks.protection.outlook.com/?url=https%3A%2F%2Fmulti
> path-
> dccp.org%2F&amp;data=04%7C01%7Cstephen.h.johnson%40bt.com%7Ceb3
> 27a3c585b40de3c0508d94602df9a%7Ca7f356889c004d5eba4129f146377ab0%
> 7C0%7C0%7C637617801620407922%7CUnknown%7CTWFpbGZsb3d8eyJWIjoi
> MC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C300
> 0&amp;sdata=RNJ3hwkDh75im4mIDGVa5M8Jpge7xr5PFEPl1KAKlHI%3D&am
> p;reserved=0. These testbeds are setup for PoC and trial activities with real
> devices and customers.
> >
> > Autonomous Guided Vehicles (AGV) is a first use case in this scenario,
> > which verifies the resilience provided by MP-DCCP in a real industry
> > environment. Integrated in the AGV and a MP-DCCP Proxy attached to a
> > converged Wi-Fi6 and 5G SA core, builds the foundation of the testbed
> > which is ready to be used in real customer PoCs. See also
> >
> https://eur02.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww
> .
> > telekom.com%2Fen%2Fcompany%2Fdetails%2Fdeutsche-telekom-
> demonstrates-m
> > ultipath-for-fixed-mobile-convergence-on-campus-
> 625838&amp;data=04%7C0
> >
> 1%7Cstephen.h.johnson%40bt.com%7Ceb327a3c585b40de3c0508d94602df9
> a%7Ca7
> >
> f356889c004d5eba4129f146377ab0%7C0%7C0%7C637617801620407922%7CU
> nknown%
> >
> 7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haW
> wiLCJX
> >
> VCI6Mn0%3D%7C3000&amp;sdata=F7YsNS9bDzcYQ0O3IiPiqdrzqJ1fX3CqDbF
> QCdCkZS
> > s%3D&amp;reserved=0
> >
> > 2. Integrated in Google Pixel 4 devices as part of the OS (and controlled by
> the Android Network Manager) to verify its applicability towards 3GPP
> ATSSS. In this scenario, the MP-DCCP proxy is hosted in the public Internet
> and enables multipath transport between the phone and ANY Internet
> service. A video demonstrating this with a real Skype call can be found on the
> start page of
> https://eur02.safelinks.protection.outlook.com/?url=https%3A%2F%2Fmulti
> path-
> dccp.org%2F&amp;data=04%7C01%7Cstephen.h.johnson%40bt.com%7Ceb3
> 27a3c585b40de3c0508d94602df9a%7Ca7f356889c004d5eba4129f146377ab0%
> 7C0%7C0%7C637617801620407922%7CUnknown%7CTWFpbGZsb3d8eyJWIjoi
> MC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C300
> 0&amp;sdata=RNJ3hwkDh75im4mIDGVa5M8Jpge7xr5PFEPl1KAKlHI%3D&am
> p;reserved=0. For the purpose of ATSSS, the GSMA ZTC taskforce identified
> MP-DCCP to be a solution, to close the open gap towards UDP support and
> therefore triggered the
> LShttps://eur02.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdat
> atracker.ietf.org%2Fliaison%2F1741%2F&amp;data=04%7C01%7Cstephen.h.j
> ohnson%40bt.com%7Ceb327a3c585b40de3c0508d94602df9a%7Ca7f356889c0
> 04d5eba4129f146377ab0%7C0%7C0%7C637617801620407922%7CUnknown%
> 7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haW
> wiLCJXVCI6Mn0%3D%7C3000&amp;sdata=Fdre%2FttRfG1Ka8bDVFeyPTOqP
> PxJC7kzoJW0BoYkK10%3D&amp;reserved=0 towards TSVWG. DT provides all
> the members in the ZTC round access to their MP-DCCP testbed.
> >
> > 3. As part of internal residential gateway prototypes, MP-DCCP allows us to
> investigate its Hybrid Access capabilities according to BBF TR-470 on Wireless
> Wireline Convergence.
> >
> > To all: I'm highly interested in your experience on MP-DCCP, details about
> existing testbeds and your potential plans with MP-DCCP. Please feel free to
> share your insights here...
> >
> > Br
> >
> > Markus
> >
> >
> > > To: Holland, Jake <jholland=[email-masked]>; Amend,
> > > Markus <[email-masked]>
> > > Cc: [email-masked]
> > > > To: mailto:[email-masked];
> > > > mailto:jholland=[email-masked];
> > > > mailto:[email-masked]; mailto:[email-masked];
> > > > mailto:[email-masked]; mailto:[email-masked]
> > > > https://eur02.safelinks.protection.outlook.com/?url=https%3A%2F%2F
> > > > multipath-
> dccp.org%2Fintro.html&amp;data=04%7C01%7Cstephen.h.johns
> > > >
> on%40bt.com%7Ceb327a3c585b40de3c0508d94602df9a%7Ca7f356889c004d5
> eb
> > > >
> a4129f146377ab0%7C0%7C0%7C637617801620417884%7CUnknown%7CTWFp
> bGZsb
> > > >
> 3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0
> > > >
> %3D%7C3000&amp;sdata=VOpMaZ4SCMwpgLV4g2ix7EoSj7T%2F4zTCllkoycB
> 25%2
> > > > BE%3D&amp;reserved=0 It looks like the idea is to wrap generic UDP
> > > > traffic in a multipath-capable tunnel at the OS level.
> > > >
> > > > That makes sense, and it looks like maybe ease of implementation
> > > > on the client devices is among the reasons to prefer it to other
> > > > kinds of tunnels, if I'm understanding it.  That seems like a fine
> > > > reason.  Thanks for clearing that up.
> > >
> > > You also have the congestion control state, with RTT estimates etc.,
> > > that can be used as input for scheduling and path management. This
> > > of course is a main benefit shared with other transport layer solutions.
> > >
> > > Best Regards,
> > > Anna
> > >
> > > >
> > > > Best,
> > > > Jake
> > > >
> > >
> personuppgifter<https://eur02.safelinks.protection.outlook.com/?url=https
> %3A%2F%2Fwww.kau.se%2Fgdpr&amp;data=04%7C01%7Cstephen.h.johns
> on%40bt.com%7Ceb327a3c585b40de3c0508d94602df9a%7Ca7f356889c004d5
> eba4129f146377ab0%7C0%7C0%7C637617801620417884%7CUnknown%7CTW
> FpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJX
> VCI6Mn0%3D%7C3000&amp;sdata=6DOJPnNEeJja5Tbu5YnJCAArWsUKVMvH
> rNdd21CxnVo%3D&amp;reserved=0>.
> data<https://eur02.safelinks.protection.outlook.com/?url=https%3A%2F%2F
> www.kau.se%2Fen%2Fgdpr&amp;data=04%7C01%7Cstephen.h.johnson%40
> bt.com%7Ceb327a3c585b40de3c0508d94602df9a%7Ca7f356889c004d5eba412
> 9f146377ab0%7C0%7C0%7C637617801620417884%7CUnknown%7CTWFpbGZ
> sb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6M
> n0%3D%7C3000&amp;sdata=tQnkfkmnf%2BQF7KxzDAAmqvHN8VCMOk4z7x
> KnoeCX5dI%3D&amp;reserved=0>.
> 
> Web:
> https://eur02.safelinks.protection.outlook.com/?url=http%3A%2F%2Fwww.
> kau.se%2Fforskare%2Fandreas-
> kassler&amp;data=04%7C01%7Cstephen.h.johnson%40bt.com%7Ceb327a3c
> 585b40de3c0508d94602df9a%7Ca7f356889c004d5eba4129f146377ab0%7C0%7
> C0%7C637617801620417884%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4w
> LjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&am
> p;sdata=ul0QzuQDhBo3Qdtj797JBDJF3xwlGXigXL%2BIokChVhU%3D&amp;re
> served=0
> 
> personuppgifter<https://eur02.safelinks.protection.outlook.com/?url=https
> %3A%2F%2Fwww.kau.se%2Fgdpr&amp;data=04%7C01%7Cstephen.h.johns
> on%40bt.com%7Ceb327a3c585b40de3c0508d94602df9a%7Ca7f356889c004d5
> eba4129f146377ab0%7C0%7C0%7C637617801620417884%7CUnknown%7CTW
> FpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJX
> VCI6Mn0%3D%7C3000&amp;sdata=6DOJPnNEeJja5Tbu5YnJCAArWsUKVMvH
> rNdd21CxnVo%3D&amp;reserved=0>.
> data<https://eur02.safelinks.protection.outlook.com/?url=https%3A%2F%2F
> www.kau.se%2Fen%2Fgdpr&amp;data=04%7C01%7Cstephen.h.johnson%40
> bt.com%7Ceb327a3c585b40de3c0508d94602df9a%7Ca7f356889c004d5eba412
> 9f146377ab0%7C0%7C0%7C637617801620417884%7CUnknown%7CTWFpbGZ
> sb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6M
> n0%3D%7C3000&amp;sdata=tQnkfkmnf%2BQF7KxzDAAmqvHN8VCMOk4z7x
> KnoeCX5dI%3D&amp;reserved=0>.