Subject: Re: [tsvwg] start of WGLC on L4S drafts

From: Praveen Balasubramanian <[email-masked]>
Date: Wed, 25 Aug 2021 04:58:00 +0000

I support publication of these drafts as RFC.

One minor comment on draft-ietf-tsvwg-l4s-arch:

"Therefore, just deploying an L4S AQM at a network
   bottleneck immediately gives a working deployment of all the L4S
   parts."
L4S requires the host to set the L4S identifier ETC(1) so this seems incorrect.

Subject:
[tsvwg] start of WGLC on L4S drafts
Date:
Thu, 29 Jul 2021 12:18:10 -0400
From:
Wesley Eddy <[email-masked]><mailto:[email-masked]>
To:
[email-masked]<mailto:[email-masked]> <[email-masked]><mailto:[email-masked]>

This message is starting a combined working group last call on 3 of the L4S drafts:

- Architecture: https://datatracker.ietf.org/doc/draft-ietf-tsvwg-l4s-arch/<https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-ietf-tsvwg-l4s-arch%2F&data=04%7C01%7Cpravb%40microsoft.com%7C7059b66eed6149034c7808d967403f88%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637654348526700316%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C2000&sdata=8lI%2Bmp5kb9AJ8TA1NPMj7WvURIPOeTJSY7kk3neMlfk%3D&reserved=0>

- DualQ: https://datatracker.ietf.org/doc/draft-ietf-tsvwg-aqm-dualq-coupled/<https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-ietf-tsvwg-aqm-dualq-coupled%2F&data=04%7C01%7Cpravb%40microsoft.com%7C7059b66eed6149034c7808d967403f88%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637654348526710265%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C2000&sdata=SWSnhxKZA64osFpt9sEyxCkETpLxRd62Y64QIr8e%2ByE%3D&reserved=0>

- ECN ID: https://datatracker.ietf.org/doc/draft-ietf-tsvwg-ecn-l4s-id/<https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-ietf-tsvwg-ecn-l4s-id%2F&data=04%7C01%7Cpravb%40microsoft.com%7C7059b66eed6149034c7808d967403f88%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637654348526710265%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C2000&sdata=dhzz3FhhF%2B3ofkpQ7h9WhJlh8ugi9jXC1rLcLqFImPw%3D&reserved=0>

The WGLC will last through 4 weeks from today, and then we'll see what to do next.  Please submit any comments you have on these to the TSVWG list in that timeframe.

The chairs are considering a possible virtual interim following the close in order to work through feedback received.

The work on the L4S operational guidance draft is continuing in parallel, but that draft is not being last called yet.

---

From: Bob Briscoe <[email-masked]>
Date: Wed, 25 Aug 2021 09:39:10 +0100

Praveen, see [BB] inline...

On 25/08/2021 05:58, Praveen Balasubramanian wrote:
> “Therefore, just deploying an L4S AQM at a network
>
>    parts.”

[BB] Good point. I'll fix. This sentence is in the context of the 
previous sentence about using existing DCTCP code for testing, but it's 
true that it needs to say that DCTCP would need at least the codepoint 
switched over (for closed source, the experimenter could even do this in 
the stack).

Cheers

Bob

> *Subject: *
> *Date: *
> *From: *
> Wesley Eddy <[email-masked]> <mailto:[email-masked]>
>
> *To: *
>
> 	
>
> [email-masked] <mailto:[email-masked]> <[email-masked]> 
> <mailto:[email-masked]>
>
>
>
> - Architecture: 
> https://datatracker.ietf.org/doc/draft-ietf-tsvwg-l4s-arch/ 
> <https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-ietf-tsvwg-l4s-arch%2F&data=04%7C01%7Cpravb%40microsoft.com%7C7059b66eed6149034c7808d967403f88%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637654348526700316%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C2000&sdata=8lI%2Bmp5kb9AJ8TA1NPMj7WvURIPOeTJSY7kk3neMlfk%3D&reserved=0>
>
> - DualQ: 
> https://datatracker.ietf.org/doc/draft-ietf-tsvwg-aqm-dualq-coupled/ 
> <https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-ietf-tsvwg-aqm-dualq-coupled%2F&data=04%7C01%7Cpravb%40microsoft.com%7C7059b66eed6149034c7808d967403f88%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637654348526710265%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C2000&sdata=SWSnhxKZA64osFpt9sEyxCkETpLxRd62Y64QIr8e%2ByE%3D&reserved=0>
>
> - ECN ID: 
> https://datatracker.ietf.org/doc/draft-ietf-tsvwg-ecn-l4s-id/ 
> <https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-ietf-tsvwg-ecn-l4s-id%2F&data=04%7C01%7Cpravb%40microsoft.com%7C7059b66eed6149034c7808d967403f88%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637654348526710265%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C2000&sdata=dhzz3FhhF%2B3ofkpQ7h9WhJlh8ugi9jXC1rLcLqFImPw%3D&reserved=0>
>
> The WGLC will last through 4 weeks from today, and then we'll see what 
> to do next.  Please submit any comments you have on these to the TSVWG 
> list in that timeframe.
>
> The chairs are considering a possible virtual interim following the 
> close in order to work through feedback received.
>
> The work on the L4S operational guidance draft is continuing in 
> parallel, but that draft is not being last called yet.
>

-- 
________________________________________________________________
Bob Briscoe                               http://bobbriscoe.net/