Subject: [tsvwg] port 3000

From: t petch <[email-masked]>
Date: Tue, 28 Sep 2021 16:54:12 +0100

Looking at some sample I code in an I-D I saw that it was using port 300 
which IANA has registered to 'hbci'.

Anyone know what 'hbci' is?

Is there a port reserved for documentation use, as there is for ipv4, 
ipv6, enterprise, ASN, ......

Tom Petch

---

From: Joe Touch <[email-masked]>
Date: Tue, 28 Sep 2021 09:03:04 -0700

3000 is assigned as you note to hbci via an IBM contact. 

300 is not assigned and IANA isn’t generally assigning ports from that range anymore per RFC 7605 sec 7.3. 

As to your second question, can you clarify?? 

> On Sep 28, 2021, at 8:55 AM, t petch <[email-masked]> wrote:
> 
> Looking at some sample I code in an I-D I saw that it was using port 300 which IANA has registered to 'hbci'.
> 
> Is there a port reserved for documentation use, as there is for ipv4, ipv6, enterprise, ASN, ......
> 
> Tom Petch
>

---

From: t petch <[email-masked]>
Date: Tue, 28 Sep 2021 17:24:17 +0100

> Anyone know what 'hbci' is?

Whoops 3000 is a typo - the Subject line got it right, the body wrong.

> ipv6, enterprise, ASN, ......

Documentation use is a reserved value for use in documentation.  Use a 
real value and some users will build networks with that value squatting 
on production networks, usually in ignorance.

These values appear in the IANA registry set up by RFC such as 5398 and 
5612 but not AFAICT for a port number.

Tom Petch

---

From: "[email-masked]" <[email-masked]>
Date: Tue, 28 Sep 2021 10:57:59 -0700

See below….
—
Joe Touch, temporal epistemologist
www.strayalpha.com

> On Sep 28, 2021, at 9:24 AM, t petch <[email-masked]> wrote:
> 
> 
> 
> Documentation use is a reserved value for use in documentation.  Use a real value and some users will build networks with that value squatting on production networks, usually in ignorance.
> 
> These values appear in the IANA registry set up by RFC such as 5398 and 5612 but not AFAICT for a port number.

Agreed. There is no example port number for such uses. I don’t know that it makes sense to bother with one; it’s easy enough to pick any dynamic port number for such purposes.

Joe