Subject: [tsvwg] draft-ietf-tcpm-rfc8312bis-04: flipped exponents in the AVG_W_cubic formulas?

From: Neal Cardwell <[email-masked]>
Date: Fri, 3 Sep 2021 14:01:06 -0400

Dear rfc8312bis authors,

First, thanks for all your work on rfc8312bis!

Next: I was about to use the AVG_W_cubic formulas in the rfc8312bis text,
and noticed what appears to be a discrepancy between the rfc8312bis
AVG_W_cubic formulas and the AVG_W_cubic formulas in both:

(1) the RFC 8312: https://datatracker.ietf.org/doc/html/rfc8312#section-5
(2) the CUBIC paper: https://dl.acm.org/doi/10.1145/1400097.1400105

In both (1) and (2) the formulas have RTT and p taken to the power of 3/4;
for example:

   With beta_cubic set to 0.7, the above formula is reduced to:
       AVG_W_cubic = (C*3.7/1.2)^0.25 * (RTT^0.75) / (p^0.75) (Eq. 6)

By contrast, the rfc8312bis text, in Figures 5, 6, and 7, has RTT and p
taken to the power of 4/3:

                                  ________________      ____
                                 /C * (3 + β     )   3 /   4
                            4   /           cubic    |/ RTT
               AVG_W      = |  /  ---------------- * -------
                    cubic   | /   4 * (1 - β     )       __
                            |/              cubic     3 / 4
                                                      |/ p

                                  Figure 5

----

____ _______ 3 / 4 4 /C * 3.7 |/ RTT AVG_W = | / ------- * ------- cubic |/
1.2 __ 3 / 4 |/ p Figure 6

----

3 / 4

                                            |/ RTT
                       AVG_W      = 1.054 * -------
                            cubic               __
                                             3 / 4
                                             |/ p

                                  Figure 7

That is, it appears there are typos in the formulas in rfc8312bis that
systematically swapped the 3 and 4 in the exponents for RTT and p,
yielding exponents of 4/3 instead of the  3/4 value from the original paper
and RFC 8312.

best regards,
neal

---

From: "Black, David" <[email-masked]>
Date: Fri, 3 Sep 2021 18:19:39 +0000

+tcpm list,  Thanks, --David

From: tsvwg <[email-masked]> On Behalf Of Neal Cardwell
Sent: Friday, September 3, 2021 2:01 PM
To: [email-masked]
Cc: tsvwg IETF list
Subject: [tsvwg] draft-ietf-tcpm-rfc8312bis-04: flipped exponents in the AVG_W_cubic formulas?

[EXTERNAL EMAIL]
Dear rfc8312bis authors,

Next: I was about to use the AVG_W_cubic formulas in the rfc8312bis text, and noticed what appears to be a discrepancy between the rfc8312bis AVG_W_cubic formulas and the AVG_W_cubic formulas in both:

(1) the RFC 8312: https://datatracker.ietf.org/doc/html/rfc8312#section-5 [datatracker.ietf.org]<https://urldefense.com/v3/__https:/datatracker.ietf.org/doc/html/rfc8312*section-5__;Iw!!LpKI!welVSQZsssTZQj9y8Cm-amEp4qNGzHvB78GbqqIy54xLFYKtqVkmuUpzvGuHwrVI$>
(2) the CUBIC paper: https://dl.acm.org/doi/10.1145/1400097.1400105 [dl.acm.org]<https://urldefense.com/v3/__https:/dl.acm.org/doi/10.1145/1400097.1400105__;!!LpKI!welVSQZsssTZQj9y8Cm-amEp4qNGzHvB78GbqqIy54xLFYKtqVkmuUpzvJFEothA$>

In both (1) and (2) the formulas have RTT and p taken to the power of 3/4; for example:

By contrast, the rfc8312bis text, in Figures 5, 6, and 7, has RTT and p taken to the power of 4/3:

                                  ________________      ____

                                 /C * (3 + β     )   3 /   4

                            4   /           cubic    |/ RTT

                            |/              cubic     3 / 4

                                                      |/ p

                                  Figure 5

----

                                                  ____

                                     _______   3 /   4

                                 4  /C * 3.7   |/ RTT

                    AVG_W      = | / ------- * -------

                         cubic   |/    1.2         __

                                                3 / 4

                                                |/ p

                                  Figure 6

----
3 / 4

                                            |/ RTT

                       AVG_W      = 1.054 * -------

                            cubic               __

                                             3 / 4

                                             |/ p

                                  Figure 7

That is, it appears there are typos in the formulas in rfc8312bis that systematically swapped the 3 and 4 in the exponents for RTT and p, yielding exponents of 4/3 instead of the  3/4 value from the original paper and RFC 8312.

best regards,
neal

---

From: Lisong Xu <[email-masked]>
Date: Fri, 3 Sep 2021 18:39:05 +0000

Thank you very much, Neal, for finding this important typo. You are right that the exponent should be 3/4 instead of 4/3 for Figures 5, 6, and 7.

Thanks
Lisong

________________________________
From: Neal Cardwell <[email-masked]>
Sent: Friday, September 3, 2021 1:01 PM
To: [email-masked] <[email-masked]>
Cc: tsvwg IETF list <[email-masked]>
Subject: draft-ietf-tcpm-rfc8312bis-04: flipped exponents in the AVG_W_cubic formulas?

Non-NU Email
________________________________
Dear rfc8312bis authors,

(1) the RFC 8312: https://datatracker.ietf.org/doc/html/rfc8312#section-5<https://urldefense.com/v3/__https://datatracker.ietf.org/doc/html/rfc8312*section-5__;Iw!!PvXuogZ4sRB2p-tU!XrfKDCjwS6huhjdCHYDYUlgBpZ4GD0kXzOG363gPaoXUS9UNHjoMt0_BK0Ny1Q$>
(2) the CUBIC paper: https://dl.acm.org/doi/10.1145/1400097.1400105<https://urldefense.com/v3/__https://dl.acm.org/doi/10.1145/1400097.1400105__;!!PvXuogZ4sRB2p-tU!XrfKDCjwS6huhjdCHYDYUlgBpZ4GD0kXzOG363gPaoXUS9UNHjoMt0_wZ47m5g$>

                                  ________________      ____
                                 /C * (3 + β     )   3 /   4
                            4   /           cubic    |/ RTT

                                  Figure 5

----

____ _______ 3 / 4 4 /C * 3.7 |/ RTT AVG_W = | / ------- * ------- cubic |/ 1.2 __ 3 / 4 |/ p Figure 6

----

3 / 4

                                            |/ RTT
                       AVG_W      = 1.054 * -------
                            cubic               __
                                             3 / 4
                                             |/ p

                                  Figure 7

best regards,
neal

---

From: Lars Eggert <[email-masked]>
Date: Fri, 3 Sep 2021 21:53:48 +0300

This was my mistake when doing the formula - THANK YOU for finding that!

-- 
Sent from a mobile device; please excuse typos.

> On Sep 3, 2021, at 21:39, Lisong Xu <[email-masked]> wrote:
> 
> 
> (1) the RFC 8312: MailScanner has detected a possible fraud attempt from "urldefense.com" claiming to be https://datatracker.ietf.org/doc/html/rfc8312#section-5
> (2) the CUBIC paper: MailScanner has detected a possible fraud attempt from "urldefense.com" claiming to be https://dl.acm.org/doi/10.1145/1400097.1400105
>

---

From: Lars Eggert <[email-masked]>
Date: Mon, 6 Sep 2021 18:11:35 +0300

Hi,

please review https://github.com/NTAP/rfc8312bis/pull/107

Thanks,
Lars