Subject: Re: [tsvwg] Designated Experts for SCTP IANA Registries

From: John Mattsson <[email-masked]>
Date: Sun, 31 Oct 2021 19:29:12 +0000

Hi,

If there is a future update to RFC 4895 I would suggest to change the scope of the IANA registry to MACs in general. HMAC is just one example of a MAC. SHA-3 can be used in HMAC mode but is typically used in the more efficient KMAC mode [NIST SP 800-185]. I don't think it make sense for SCTP-AUTH to restrict the types of registered MAC to just HMAC.

Cheers,
John

---

From: Michael Tuexen <[email-masked]>
Date: Sun, 31 Oct 2021 22:23:58 +0100

> On 31. Oct 2021, at 20:29, John Mattsson <john.mattsson=[email-masked]> wrote:
> 
> Hi,
>  
In general, I agree.

However, I'm only aware of two issues which where reported:
(1) One editorial issue: https://www.rfc-editor.org/errata/eid995
(2) A suggestion to improve the description of the shared keys.

I'm not aware of any interop issue related to this extension.

Best regards
Michael