Subject: [tsvwg] I-D Action: draft-ietf-tsvwg-udp-options-dplpmtud-01.txt

From: [email-masked]
Date: Thu, 18 Nov 2021 08:35:54 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Transport Area Working Group WG of the IETF.

        Title           : Datagram PLPMTUD for UDP Options
        Authors         : Godred Fairhurst
                          Tom Jones
	Filename        : draft-ietf-tsvwg-udp-options-dplpmtud-01.txt
	Pages           : 10
	Date            : 2021-11-18

Abstract:
   This document specifies how a UDP Options sender implements Datagram
   Packetization Layer Path Maximum Transmission Unit Discovery
   (DPLPMTUD) as a robust method for Path Maximum Transmission Unit
   discovery.  This method uses the UDP Options packetization layer.  It
   allows a datagram application to discover the largest size of
   datagram that can be sent across a network path.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-tsvwg-udp-options-dplpmtud/

There is also an htmlized version available at:
https://datatracker.ietf.org/doc/html/draft-ietf-tsvwg-udp-options-dplpmtud-01

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-tsvwg-udp-options-dplpmtud-01

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Tom Jones <[email-masked]>
Date: Thu, 18 Nov 2021 16:41:13 +0000

> https://datatracker.ietf.org/doc/html/draft-ietf-tsvwg-udp-options-dplpmtud-01

Hi TSVWG,

We have uploaded an update to UDP Options DPLPMTUD, this version has
made a number of changes and we would like to ask the working group to
read and comment on it.

Changes include:

- Update to reflect new fragmentation design in UDP Options.
- Add a description of uses of DPLPMTUD with UDP Options.
- Add a description on how to form probe packets with padding.
- Say that MSS options can be used to initialise the search algorithm.
- Say that the recommended approach is to not use user data for probes.
- Attempts to clarify and improve wording throughout.
- Remove text saying you can respond to multiple probes in a single packet.
- Simplified text by removing options that don't yield benefit.

Thanks

- Tom and Gorry

---

From: <[email-masked]>
Date: Wed, 24 Nov 2021 12:11:28 +0000

Hi Tom, Gorry,

Thank you for this work. 

FWIW, you may find some few comments at: 

* pdf: https://raw.githubusercontent.com/boucadair/IETF-Drafts-Reviews/master/draft-ietf-tsvwg-udp-options-dplpmtud-01-rev%20Med.pdf 
* doc: https://github.com/boucadair/IETF-Drafts-Reviews/raw/master/draft-ietf-tsvwg-udp-options-dplpmtud-01-rev%20Med.docx 

Cheers,
Med

> -----Message d'origine-----
> De : tsvwg <[email-masked]> De la part de Tom Jones
> Envoyé : jeudi 18 novembre 2021 17:41
> À : [email-masked]
> Objet : Re: [tsvwg] I-D Action: draft-ietf-tsvwg-udp-options-dplpmtud-
> 01.txt
> 
> We have uploaded an update to UDP Options DPLPMTUD, this version has made
> a number of changes and we would like to ask the working group to read and
> comment on it.
> 
> Changes include:
> 

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.