Subject: [tsvwg] I-D Action: draft-ietf-tsvwg-aqm-dualq-coupled-19.txt

From: [email-masked]
Date: Wed, 03 Nov 2021 12:11:56 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Transport Area Working Group WG of the IETF.

        Title           : DualQ Coupled AQMs for Low Latency, Low Loss and Scalable Throughput (L4S)
        Authors         : Koen De Schepper
                          Bob Briscoe
                          Greg White
	Filename        : draft-ietf-tsvwg-aqm-dualq-coupled-19.txt
	Pages           : 61
	Date            : 2021-11-03

Abstract:
   This specification defines a framework for coupling the Active Queue
   Management (AQM) algorithms in two queues intended for flows with
   different responses to congestion.  This provides a way for the
   Internet to transition from the scaling problems of standard TCP
   Reno-friendly ('Classic') congestion controls to the family of
   'Scalable' congestion controls.  These are designed for consistently
   very Low queuing Latency, very Low congestion Loss and Scaling of
   per-flow throughput (L4S) by using Explicit Congestion Notification
   (ECN) in a modified way.  Until the Coupled DualQ, these L4S senders
   could only be deployed where a clean-slate environment could be
   arranged, such as in private data centres.  The coupling acts like a
   semi-permeable membrane: isolating the sub-millisecond average
   queuing delay and zero congestion loss of L4S from Classic latency
   and loss; but pooling the capacity between any combination of
   Scalable and Classic flows with roughly equivalent throughput per
   flow.  The DualQ achieves this indirectly, without having to inspect
   transport layer flow identifiers and without compromising the
   performance of the Classic traffic, relative to a single queue.  The
   DualQ design has low complexity and requires no configuration for the
   public Internet.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-tsvwg-aqm-dualq-coupled/

There is also an HTML version available at:
https://www.ietf.org/archive/id/draft-ietf-tsvwg-aqm-dualq-coupled-19.html

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-tsvwg-aqm-dualq-coupled-19

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Sebastian Moeller <[email-masked]>
Date: Wed, 3 Nov 2021 20:56:59 +0100

Dear All,

this still contains this gem:
"*  RTT_typ is taken as 25 ms.  This is based on an average CDN
      latency measured in each country weighted by the number of
      Internet users in that country to produce an overall weighted
      average for the Internet [PI2param].  Countries were ranked by
      number of Internet users, and once 90% of Internet users were
      covered, smaller countries were excluded to avoid
      unrepresentatively small sample sizes.  Also, importantly, the
      data for the average CDN latency in China (with the largest number
      of Internet users) has been removed, because the CDN latency was a
      significant outlier and, on reflection, the experimental technique
      seemed inappropriate to the CDN market in China."

This is still massively misrepresenting the data from its original source and still seems to continue the fiction that in Nigeria the average CDN latency to be 4ms.

The whole "theory" of selecting the classic target seems to be wrong on multiple levels. 
"This is based on an average CDN latency measured in each country" is simply wrong, the study the data was sourced from measured the average RTT between up to 50 measurement nodes per country to 7 different CDNs and reported per country the smallest per CDN average number. This is not a meaningful "average CDN latency" that is representative for the "internet".... 

And removing China, because the value appears to hight for the taste of the authors seems scientifically dubious... Especially since Nigeria s still included with an average CDN latency of 4ms, which, as I posted multiple times is not representative for Nigeria... 
Really, as it stands the  [PI2param] Briscoe, B., "PI2 Parameters", Technical Report TR-BB-2021-001 arXiv:2107.01003 [cs.NI], July 2021 <https://arxiv.org/abs/2107.01003>. would not make it through peer review.

Regards
	Sebastian

P.S.: I am pretty sure this is not the only deficit in this draft, but what use would be a deeper dive into other parts as long as this clear problem is not fixed first.... 

> On Nov 3, 2021, at 20:11, [email-masked] wrote:
> 
>