Subject: Re: [tsvwg] Fwd: Can DPLPMTUD for UDP Optionsbe considered to be adopted by tsvwg?

From: "C. M. Heard" <[email-masked]>
Date: Tue, 9 Nov 2021 07:38:00 -0800

On Fri, Sep 3, 2021 at 3:09 AM Tom Jones <[email-masked]> wrote:

> On Thu, Sep 02, 2021 at 08:07:38PM -0700, C. M. Heard wrote:
> > [ resend with working address for Tom Jones ]
> >
> > I certainly support adoption. There is one substantive issue that I have
> > noticed:
> >
> > In Section 3.2.1 (page 4) the draft says:
> >
> >    Implementations MAY track multiple requests and respond acknowledging
> >    them with a single packet.
> >
> >
> > That contradicts the following provision in
> draft-ietf-tsvwg-udp-options-13:
> >
> >    >> Except for NOP, each option SHOULD NOT occur more than once in a
> >    single UDP datagram. If an option other than NOP occurs more than
> >    once, a receiver MUST interpret only the first instance of that
> >    option and MUST ignore all others.
> >
> >
> > This inconsistency must be resolved before this draft (or
> > draft-udp-options) can progress.
> >
>
> Talking with Gorry, we think we will remove this text from the next
> revision of the draft.

That change does not seem to have made it into the WG version of the draft.

Mike Heard

---

From: Tom Jones <[email-masked]>
Date: Tue, 9 Nov 2021 16:21:02 +0000

> That change does not seem to have made it into the WG version of the draft.

There was some interesting temporal ordering between the wg -00
submission and formal adoption.

We will fix it in the next revision.

Thanks

- Tom