Subject: Re: [tsvwg] Designated Experts for SCTP IANA Registries

From: John Mattsson <[email-masked]>
Date: Mon, 1 Nov 2021 14:54:51 +0000

Hi Michael,

There is no interop problem with the current specification. It is very clear that the current algorithms are HMAC-SHA-1 and HMAC-SHA-256. The current specification is in my view a bit too restrictive. If somebody would like to register any of the MAC algorithms AES-CMAC, KMAC128, or BLAKE3, they cannot do so. I don't that is a major problem right now, but _if_ TSVWG ever do RFC4895bis I think the restriction should be removed.

Cheers,
John

From: Michael Tuexen <[email-masked]>
Date: Sunday, 31 October 2021 at 22:24
To: John Mattsson <[email-masked]>
Cc: [email-masked] <[email-masked]>
Subject: Re: [tsvwg] Designated Experts for SCTP IANA Registries
> On 31. Oct 2021, at 20:29, John Mattsson <john.mattsson=[email-masked]> wrote:
>
> Hi,
>
> If there is a future update to RFC 4895 I would suggest to change the scope of the IANA registry to MACs in general. HMAC is just one example of a MAC. SHA-3 can be used in HMAC mode but is typically used in the more efficient KMAC mode [NIST SP 800-185]. I don't think it make sense for SCTP-AUTH to restrict the types of registered MAC to just HMAC.
In general, I agree.

However, I'm only aware of two issues which where reported:
(1) One editorial issue: https://www.rfc-editor.org/errata/eid995
(2) A suggestion to improve the description of the shared keys.

I'm not aware of any interop issue related to this extension.

Best regards
Michael
> Cheers,
> John

---

From: Michael Tuexen <[email-masked]>
Date: Mon, 1 Nov 2021 16:15:35 +0100

> On 1. Nov 2021, at 15:54, John Mattsson <john.mattsson=[email-masked]> wrote:
> 
> Hi Michael,
>  
As I said: I agree.

Best regards
Michael