Subject: Re: [tsvwg] L4S: AQM Algorithm Choice Issues (2)

From: "Livingood, Jason" <[email-masked]>
Date: Wed, 2 Feb 2022 13:39:21 +0000

I agree with the chairs’ proposed path forward, that remaining concerns should not be considered blocking for moving the L4S drafts to Experimental RFC and that publishing as such enables further experimentation & design improvement.

Thanks
Jason

From: tsvwg <[email-masked]> on behalf of "Black, David" <[email-masked]>
Date: Tuesday, February 1, 2022 at 10:15
To: "[email-masked]" <[email-masked]>
Subject: [tsvwg] L4S: AQM Algorithm Choice Issues (2)

With many of the smaller L4S WGLC concerns having been dealt with via draft updates, the WG Chairs are starting to work through the larger concerns.  David Black's slides on this topic from IETF 111 (https://datatracker.ietf.org/meeting/111/materials/slides-111-tsvwg-sessb-31-a-l4s-issues-00 [datatracker.ietf.org]<https://urldefense.com/v3/__https:/datatracker.ietf.org/meeting/111/materials/slides-111-tsvwg-sessb-31-a-l4s-issues-00__;!!LpKI!zVBRipbLjaAbYig1ZebG8gLPYfURQ9_feiG5u8XtqBrgoEcpPeRPs3Di5te1z0pk$>) are a useful starting point – WG rough consensus will need to be reached on at least these concerns, and there may be additional concerns.

This message addresses the two concerns at the end of those slides, as stated in the last two main bullets on slide 2:
• AQM disadvantages fragmented and small-MTU traffic
• Congestion marking algorithm biased against small packets
• DualQ AQM algorithm intolerant of bursty traffic
• Bursty applications (e.g., real-time video) and links (e.g., WiFi) cause large reduction in goodput

These two concerns are specific to the aqm-dualq-coupled draft, as they concern the details of the AQM algorithm used in the DualQ[ueue] Coupled structure, specifically PI (in the form of PI2), and not the overall DualQ Coupled structure (which is the subject of other concerns in the IETF 111 slides).  The DualQ Coupled structure does not require use of the PI2 algorithm, as Appendix B of the aqm-dualq-coupled draft describes the use of the Curvy RED algorithm, and other AQM algorithms, e.g., CoDel, could be used.  Hence these concerns do not apply to the other two L4S drafts.

The WG chairs believe that the appropriate path forward for these two concerns is design, modification and experimentation with different AQM algorithms in the DualQ Coupled structure, e.g., a DualQ Coupled AQM based on CoDel, and hence the chairs believe that these concerns are not reasons to avoid experimentation with DualQ Coupled AQMs, e.g., the Dual Q Coupled PI2 and Curvy RED algorithms described in Appendixes A & B of draft-ietf-tsvwg-aqm-dualq-coupled.  Publishing the aqm-dualq-coupled draft as an Experimental RFC supports AQM design, modification and experimentation, making these concerns are suitable for resolution via experimentation, so they are not blocking issues for Experimental RFC publication of the aqm-dualq-coupled draft.

Thanks, --David, Wes & Gorry
TSVWG WG chairs

---

From: "Black, David" <[email-masked]>
Date: Wed, 2 Feb 2022 16:17:27 +0000

For clarity, this email thread is only about the two concerns explicitly listed in the first message below.  Please start a separate thread for other comments.

Thanks, --David

From: Livingood, Jason <[email-masked]>
Sent: Wednesday, February 2, 2022 8:39 AM
To: Black, David; [email-masked]
Subject: Re: [tsvwg] L4S: AQM Algorithm Choice Issues (2)

[EXTERNAL EMAIL]

Thanks
Jason

From: tsvwg <[email-masked]<mailto:[email-masked]>> on behalf of "Black, David" <[email-masked]<mailto:[email-masked]>>
Date: Tuesday, February 1, 2022 at 10:15
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: [tsvwg] L4S: AQM Algorithm Choice Issues (2)