Subject: [tsvwg] I-D Action: draft-ietf-tsvwg-multipath-dccp-03.txt

From: [email-masked]
Date: Tue, 15 Feb 2022 01:01:04 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Transport Area Working Group WG of the IETF.

        Title           : DCCP Extensions for Multipath Operation with Multiple Addresses
        Authors         : Markus Amend
                          Anna Brunstrom
                          Andreas Kassler
                          Veselin Rakocevic
                          Stephen Johnson
	Filename        : draft-ietf-tsvwg-multipath-dccp-03.txt
	Pages           : 33
	Date            : 2022-02-15

Abstract:
   DCCP communication is currently restricted to a single path per
   connection, yet multiple paths often exist between peers.  The
   simultaneous use of these multiple paths for a DCCP session could
   improve resource usage within the network and, thus, improve user
   experience through higher throughput and improved resilience to
   network failures.  Use cases for a Multipath DCCP (MP-DCCP) are
   mobile devices (handsets, vehicles) and residential home gateways
   simultaneously connected to distinct paths as, e.g., a cellular link
   and a WiFi link or to a mobile radio station and a fixed access
   network.  Compared to existing multipath protocols such as MPTCP, MP-
   DCCP provides specific support for non-TCP user traffic as UDP or
   plain IP.  More details on potential use cases are provided in
   [website], [slide], and [paper].  All these use cases profit from an
   Open Source Linux reference implementation provided under [website].

   This document presents a set of extensions to traditional DCCP to
   support multipath operation.  Multipath DCCP provides the ability to
   simultaneously use multiple paths between peers.  The protocol offers
   the same type of service to applications as DCCP and it provides the
   components necessary to establish and use multiple DCCP flows across
   potentially disjoint paths.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-tsvwg-multipath-dccp/

There is also an HTML version available at:
https://www.ietf.org/archive/id/draft-ietf-tsvwg-multipath-dccp-03.html

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-tsvwg-multipath-dccp-03

Internet-Drafts are also available by rsync at rsync.ietf.org::internet-drafts

---

From: <[email-masked]>
Date: Tue, 15 Feb 2022 10:49:52 +0000

Dear TSVWG community,

upfront to the TSVWG interim meeting tomorrow we published a -03 version, which incorporates a lot of bugfixes and smaller enhancements. Along with that we also updated our Open Source implementation available at https://multipath-dccp.org. A lot of traction is also now coming from 3GPP who consider MP-DCCP for 5G ATSSS purposes in Rel. 18 and discuss this in the ongoing study phase.

We more and more come closer to a - from the authors view - complete draft. It would be very welcome if others besides the authors could start reviewing and give us their feedback.

Hope to see you tomorrow in the interim meeting, the slides therefore are already available at https://datatracker.ietf.org/meeting/interim-2022-tsvwg-01/materials/slides-interim-2022-tsvwg-01-sessa-31-multipath-dccp-00.

Br

Markus

> -----Original Message-----
> From: tsvwg <[email-masked]> On Behalf Of [email-masked]
> Sent: Dienstag, 15. Februar 2022 10:01
> To: [email-masked]
> Cc: [email-masked]
> Subject: [tsvwg] I-D Action: draft-ietf-tsvwg-multipath-dccp-03.txt
> 
>