Subject: [tsvwg] I-D Action: draft-ietf-tsvwg-udp-options-16.txt

From: [email-masked]
Date: Sat, 19 Mar 2022 16:59:00 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Transport Area Working Group WG of the IETF.

        Title           : Transport Options for UDP
        Author          : Joe Touch
	Filename        : draft-ietf-tsvwg-udp-options-16.txt
	Pages           : 41
	Date            : 2022-03-19

Abstract:
   Transport protocols are extended through the use of transport header
   options. This document extends UDP by indicating the location,
   syntax, and semantics for UDP transport layer options.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-tsvwg-udp-options/

There is also an htmlized version available at:
https://datatracker.ietf.org/doc/html/draft-ietf-tsvwg-udp-options-16

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-tsvwg-udp-options-16

Internet-Drafts are also available by rsync at rsync.ietf.org::internet-drafts

---

From: "[email-masked]" <[email-masked]>
Date: Sat, 19 Mar 2022 17:05:32 -0700

Hi, all,

This version has all currently known pending updates. 

HOWEVER:
- it still needs a consistency check for error handling
- it still needs additional passes for overall terminology consistency
- the API discussion may need some additional text for clarity

Feedback welcome.

Joe
—
Dr. Joe Touch, temporal epistemologist
www.strayalpha.com

> On Mar 19, 2022, at 4:59 PM, [email-masked] wrote:
> 
>

---

From: Tom Herbert <[email-masked]>
Date: Sun, 20 Mar 2022 07:58:42 -0400

> - the API discussion may need some additional text for clarity

Joe,

What is the status of implemtation for UDP options? Have all the API and
options described in the draft been implemented? Can you provide a
reference in the draft to an open source implemtation?

Thanks,
Tom

---

From: "[email-masked]" <[email-masked]>
Date: Sun, 20 Mar 2022 09:34:19 -0700

Hi, Tom,

Others will be reporting on status.

I don’t think a software link in the doc will be useful, though - they’re rarely stable in comparison to the longevity of the doc.

As to the API, the doc takes its cues from TCP and stays generic; the appendix gives details of the kinds of switches and parameters of an OS implementation as an example but not as a requirement.

Joe

—

> On Mar 20, 2022, at 4:58 AM, Tom Herbert <[email-masked]> wrote:
> 
> 
> 
> On Sat, Mar 19, 2022, 8:05 PM [email-masked] <mailto:[email-masked]> <[email-masked] <mailto:[email-masked]>> wrote:
> Hi, all,
> 
> What is the status of implemtation for UDP options? Have all the API and options described in the draft been implemented? Can you provide a reference in the draft to an open source implemtation?
> 
> Thanks,
> Tom
> 
> 
> 
> Feedback welcome.
> 
> Joe
> —
> www.strayalpha.com <http://www.strayalpha.com/>
> 
>> On Mar 19, 2022, at 4:59 PM, [email-masked] <mailto:[email-masked]> wrote:
>> 
>> 
>> https://datatracker.ietf.org/doc/draft-ietf-tsvwg-udp-options/ <https://datatracker.ietf.org/doc/draft-ietf-tsvwg-udp-options/>
>> 
>> https://datatracker.ietf.org/doc/html/draft-ietf-tsvwg-udp-options-16 <https://datatracker.ietf.org/doc/html/draft-ietf-tsvwg-udp-options-16>
>> 
>> https://www.ietf.org/rfcdiff?url2=draft-ietf-tsvwg-udp-options-16 <https://www.ietf.org/rfcdiff?url2=draft-ietf-tsvwg-udp-options-16>
>> 
>>

---

From: Tom Herbert <[email-masked]>
Date: Sun, 20 Mar 2022 09:59:49 -0700

Joe,

Great! It would be useful if they could present implementation and
provide links to open source implementation.

> I don’t think a software link in the doc will be useful, though - they’re rarely stable in comparison to the longevity of the doc.

IETF is "rough consensus and running code". If we can't get running
code it's next to impossible to evaluate whether the protocol on paper
is actually feasible in real implementation. For instance, I've
already pointed out a number of potential issues in implementation
particularly with common hardware accelerations for UDP-- the concerns
haven't been addressed and probably can only be addressed if somebody
sits down and goes through the details of it.

> As to the API, the doc takes its cues from TCP and stays generic; the appendix gives details of the kinds of switches and parameters of an OS implementation as an example but not as a requirement.

As an OS developer, having a "standard" API without reference
implementation is pretty useless to me.

Tom

> On Sat, Mar 19, 2022, 8:05 PM [email-masked] <[email-masked]> wrote:
>>
>> Hi, all,
>>

---

From: "[email-masked]" <[email-masked]>
Date: Sun, 20 Mar 2022 11:37:52 -0700

Hi, Tom,
—

> On Mar 20, 2022, at 9:59 AM, Tom Herbert <[email-masked]> wrote:
> 
> IETF is "rough consensus and running code".

Agreed; just saying the link inside the doc isn’t all that useful.

> ...

The doc currently talks about what information needs to be provided during sends and receives. How that is rendered into spec is up to the implementer. 

E.g., TCP requires certain types of commands as ’standard’, but does not describe how they appear in code, The code APIs were standardized as a socket interface API by the IEEE POSIX and others, but not the IETF. 

Perhaps we should call these “application layer interfaces”, because they’re not programming interfaces per se.

Joe