Subject: [Tzdist-bis] slight editorial on UNIX time

From: Eliot Lear <[email-masked]>
Date: Mon, 28 May 2018 11:28:42 +0200

It currently reads as follows:

> As an extension to
>       POSIX, negative values represent times before the POSIX Epoch,
>       using UTC and its predecessors such as GMT and UT.

It would be best to state this in slightly different terms:

      This varies from POSIX in that negative values represent times
before the POSIX Epoch,
      using UTC and its predecessors such as GMT and UT.

Eliot

---

From: Paul Eggert <[email-masked]>
Date: Mon, 28 May 2018 10:47:56 -0700

On 05/28/2018 02:28 AM, Eliot Lear wrote:
>        This varies from POSIX

Why is "varies from" a better term? POSIX deliberately does not define 
the meaning of negative time_t. Isn't it better to tell the reader that 
we are extending POSIX rather than possibly being incompatible with POSIX?

---

From: Eliot Lear <[email-masked]>
Date: Mon, 28 May 2018 20:02:27 +0200

On 28.05.18 19:47, Paul Eggert wrote:
> the meaning of negative time_t. Isn't it better to tell the reader
> that we are extending POSIX rather than possibly being incompatible
> with POSIX?
>

I am nervous about getting this particular wording correct so that it
doesn't appear that we're treading on their toes.  I don't have a good
test for that but when others tell the IETF they are going to expand our
specifications, we tend to get a bit antsy about it.  That's why I
prefer to be up front.  But this is something of a nit, to be sure.

Eliot

---

From: Paul Eggert <[email-masked]>
Date: Mon, 28 May 2018 11:23:57 -0700

On 05/28/2018 11:02 AM, Eliot Lear wrote:
> doesn't appear that we're treading on their toes. 

The phrase "extension to POSIX" should do that pretty clearly, as it's 
the same phraseology that POSIX itself uses when it specifies extensions 
to the C standard. See:

http://pubs.opengroup.org/onlinepubs/9699919799/help/codes.html#CX

---

From: Eliot Lear <[email-masked]>
Date: Mon, 28 May 2018 20:26:33 +0200

Ok.

On 28.05.18 20:23, Paul Eggert wrote:
> the same phraseology that POSIX itself uses when it specifies
> extensions to the C standard. See:
>

---

From: Ken Murchison <[email-masked]>
Date: Tue, 29 May 2018 11:05:50 -0400

It appears that we will leave this text as-is, correct?

On 05/28/2018 02:26 PM, Eliot Lear wrote:
> _______________________________________________
> Tzdist-bis mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tzdist-bis

-- 
Ken Murchison
Cyrus Development Team
FastMail US LLC

---

From: Eliot Lear <[email-masked]>
Date: Tue, 29 May 2018 18:07:41 +0200

> It appears that we will leave this text as-is, correct?

Yes.