Subject: [Tzdist-bis] File extension for TZif?

From: Ken Murchison <[email-masked]>
Date: Wed, 20 Jun 2018 13:54:29 -0400

Do we want to specify a file extension for TZif in this spec? Currently 
the spec says that there is no file extension for this format, primarily 
because that's how they are stored in system zoneinfo/ directories.

-- 

Ken Murchison
Cyrus Development Team
FastMail US LLC

---

From: Paul Eggert <[email-masked]>
Date: Wed, 20 Jun 2018 12:32:08 -0700

On 06/20/2018 10:54 AM, Ken Murchison wrote:
> Do we want to specify a file extension for TZif in this spec? 
> Currently the spec says that there is no file extension for this 
> format, primarily because that's how they are stored in system 
> zoneinfo/ directories.

It pretty much universal practice to not have an extension. The obvious 
extension name would be '.tzif', if people want to have an extension in 
new applications.

---

From: Ken Murchison <[email-masked]>
Date: Wed, 20 Jun 2018 15:36:32 -0400

On 06/20/2018 03:32 PM, Paul Eggert wrote:
> It pretty much universal practice to not have an extension. The 
> obvious extension name would be '.tzif', if people want to have an 
> extension in new applications.

I was thinking the same thing.  Should I add it to the IANA section as 
an option?

If we decide to have a separate MIME type for TZif + leap seconds, would 
we use a different extension?

-- 
Ken Murchison
Cyrus Development Team
FastMail US LLC

---

From: Eliot Lear <[email-masked]>
Date: Wed, 20 Jun 2018 18:04:40 -0700

> I was thinking the same thing.  Should I add it to the IANA section as

I don't see it as necessary.

>
> If we decide to have a separate MIME type for TZif + leap seconds,
> would we use a different extension?

n/A

Eliot
>
>
>
> _______________________________________________
> Tzdist-bis mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tzdist-bis