Subject: [Tzdist-bis] New Version Notification - draft-murchison-tzdist-tzif-13.txt

From: [email-masked]
Date: Mon, 10 Sep 2018 12:37:57 -0700

A new version (-13) has been submitted for draft-murchison-tzdist-tzif:
https://www.ietf.org/internet-drafts/draft-murchison-tzdist-tzif-13.txt

Sub state has been changed to AD Followup from Revised ID Needed

The IETF datatracker page for this Internet-Draft is:
https://datatracker.ietf.org/doc/draft-murchison-tzdist-tzif/

Diff from previous version:
https://www.ietf.org/rfcdiff?url2=draft-murchison-tzdist-tzif-13

Please note that it may take a couple of minutes from the time of submission
until the diff is available at tools.ietf.org.

IETF Secretariat.

---

From: Ken Murchison <[email-masked]>
Date: Mon, 10 Sep 2018 15:39:46 -0400

I *think* this addresses all of Alexey's comments.

After consulting with the RFC editors, it was recommended to use a 
single xref for POSIX but use inline erefs to point to the specific 
sections of the POSIX spec.

On 09/10/2018 03:37 PM, [email-masked] wrote:
> _______________________________________________
> Tzdist-bis mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tzdist-bis

-- 
Ken Murchison
Cyrus Development Team
FastMail US LLC

---

From: Paul Eggert <[email-masked]>
Date: Mon, 10 Sep 2018 20:57:36 -0700

Ken Murchison wrote:
> After consulting with the RFC editors, it was recommended to use a single xref 
> for POSIX but use inline erefs to point to the specific sections of the POSIX spec.

Unfortunately the inline erefs still have problems. For example, if I visit here:

https://tools.ietf.org/html/draft-murchison-tzdist-tzif-13

and click on the "Section 3" link at the start of the text "Section 3 of the 
"System Interfaces" Volume of [POSIX]", my browser is directed to 
<https://tools.ietf.org/html/draft-murchison-tzdist-tzif-13#section-3>, which is 
the wrong place. That is, the XML says "<eref 
target="http://pubs.opengroup.org/onlinepubs/9699919799/functions/time.html">Section 
3 of the "System Interfaces" Volume</eref>", but the generated HTML says "<a 
href="#section-3">Section 3</a> of the "System Interfaces" Volume [<a 
href="#ref-2">2</a>]". Evidently the reader is supposed to click on that little 
"[2]" and then click again on the the citation it points to (and these two 
clicks are awkward, if you ask me), but the much longer "Section 3" will likely 
lead readers astray.

There are similar problems with the other erefs. I hope we can do better, though 
I'm afraid I don't know RFC XML well enough to say how.

---

From: Ken Murchison <[email-masked]>
Date: Tue, 11 Sep 2018 05:14:21 -0400

Hmm.  That's weird.  Somehow the automated tooling is breaking this.  
When I run the raw XML through xml2rfc and generate HTML, the erefs are 
fine.  I expect that this is something that we can make sure is correct 
during AUTH48.

On 09/10/2018 11:57 PM, Paul Eggert wrote:
> and click on the "Section 3" link at the start of the text "Section 3 
> of the "System Interfaces" Volume of [POSIX]", my browser is directed 
> to 
> <https://tools.ietf.org/html/draft-murchison-tzdist-tzif-13#section-3>, 
> which is the wrong place. That is, the XML says "<eref 
> 3 of the "System Interfaces" Volume</eref>", but the generated HTML 
> says "<a href="#section-3">Section 3</a> of the "System Interfaces" 
> Volume [<a href="#ref-2">2</a>]". Evidently the reader is supposed to 
> click on that little "[2]" and then click again on the the citation it 
> points to (and these two clicks are awkward, if you ask me), but the 
> much longer "Section 3" will likely lead readers astray.
>
> There are similar problems with the other erefs. I hope we can do 
> better, though I'm afraid I don't know RFC XML well enough to say how.

-- 
Ken Murchison
Cyrus Development Team
FastMail US LLC

---

From: Alexey Melnikov <[email-masked]>
Date: Tue, 11 Sep 2018 15:45:33 +0100

Hi Paul,

On Tue, Sep 11, 2018, at 4:57 AM, Paul Eggert wrote:
> which is 

This tool is not generating HTML from XML (as far as I know), it is parsing text/plain version. It has bugs as you point out. As this is not an official IETF tool (the official one is worked on by a contractor for RFC Editor), I wouldn't worry too much about this.

> better, though 

Best Regards,
Alexey

---

From: Ken Murchison <[email-masked]>
Date: Tue, 11 Sep 2018 10:50:05 -0400

Attached is what xml2rfc outputs.

-- 
Ken Murchison
Cyrus Development Team
FastMail US LLC

---

From: Ken Murchison <[email-masked]>
Date: Tue, 11 Sep 2018 19:31:54 -0400

I forgot to remove/augment the Privacy Considerations section in -13 as 
suggested by Alexey.  I'm thinking of simply starting this:

      "The Time Zone Information Format contains publicly available
       data and the format does not define any extensible areas that
       could be used to store private data."

Does this work for folks?

-- 
Ken Murchison
Cyrus Development Team
FastMail US LLC

---

From: Paul Eggert <[email-masked]>
Date: Tue, 11 Sep 2018 22:24:14 -0700

> Does this work for folks?

Looks good to me, thanks.