Subject: [Tzdist-bis] draft-tzdist-geolocate tz associated to the point

From: Daniel Migault <[email-masked]>
Date: Sat, 3 Nov 2018 14:10:44 -0400

Hi,

I believe the last point that needs to be discussed is whether the WG
believe we should indicate which time zones are related to the point or
not.

In case there we believe this is useful, how should we provide such
indication ? One suggestion is to indicate this via a boolean value. Are
they any other suggestions?

Please share your thoughts by the end of the week.

Yours,
Daniel
.

---

From: Paul Eggert <[email-masked]>
Date: Sat, 3 Nov 2018 12:42:17 -0700

> believe we should indicate which time zones are related to the point or

Sorry, I've lost context. Could you give an example query and set of possible 
results, and use it to illustrate the issue that needs to be discussed?

---

From: Daniel Migault <[email-masked]>
Date: Sat, 3 Nov 2018 23:38:03 -0400

Hi,

Of course, taken the example of the draft here is the response:

When the client is located in America/New_York the suggestion was
to indicate that America/New_York is the time zone associated to
the location of the point (coordinates provided in the request with
uncertainty set to 0 ) while America/Toronto is the zone in the
50m neighborhood. The response could be for example as follows:

   >> Request <<

   GET /tzdist/zones?location=geo:43.0799,-79.0747;u=50 HTTP/1.1
   Host: tz.example.com
 >> Response <<

   HTTP/1.1 200 OK
   Date: Thu, 09 Nov 2017 13:58:07 GMT
   Content-Type: application/json; charset="utf-8"
   Content-Length: xxxx

   {
     "synctoken": "2860088640-1510059107",
     "timezones": [
       {
         "tzid": "America/New_York",
         "etag": "6602582-1510059107",
         "last-modified": "2017-11-07T12:51:47Z",
         "publisher": "IANA Time Zone Database",
         "version": "2017c",
         "aliases": [
           "US/Eastern"
         ],

         "Is-geoloc-coordinates" : True // tz corresponding to
geo:43.0799,-79.0747

       },
       {
         "tzid": "America/Toronto",
         "etag": "3297806-1510059107",
         "last-modified": "2017-11-07T12:51:47Z",
         "publisher": "IANA Time Zone Database",
         "version": "2017c",
         "aliases": [
           "America/Montreal",
           "Canada/Eastern"
         ],
         "Is-geoloc-coordinates" : False // tz corresponding to the neighborhood
       }
     ]
   }

The discussion should be whether we believe that is useful and maybe
how to tag the parameter.

Yours,

Daniel

On Sat, Nov 3, 2018 at 3:42 PM Paul Eggert <[email-masked]> wrote:

> _______________________________________________
> Tzdist-bis mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tzdist-bis
>