Subject: [Tzdist] Ticket #17

From: Cyrus Daboo <[email-masked]>
Date: Tue, 26 Aug 2014 15:50:46 -0400

Hi,
To address <http://trac.tools.ietf.org/wg/tzdist/trac/ticket/17> I propose 
changing the last paragraph in Section 4.1.6 to:

   When an HTTP error response is returned to the client, the server SHOULD
   also return a JSON error object, as per Section 7.4, in the response 
body,
   with some suitable descriptive text in the JSON object, in addition to
   the applicable error code (as per Section 6).

I will also move the text from the original paragraph that refers to 
"invalid-action" to the first paragraph in Section 6 (where it seems more 
appropriate to describe the response to an unknown action).

-- 
Cyrus Daboo

---

From: Ken Murchison <[email-masked]>
Date: Tue, 26 Aug 2014 16:00:59 -0400

On 08/26/2014 03:50 PM, Cyrus Daboo wrote:
> Hi,
> To address <http://trac.tools.ietf.org/wg/tzdist/trac/ticket/17> I 
> propose changing the last paragraph in Section 4.1.6 to:
>
> "invalid-action" to the first paragraph in Section 6 (where it seems 
> more appropriate to describe the response to an unknown action).
>

Looks reasonable to me.

-- 
Kenneth Murchison
Principal Systems Software Engineer
Carnegie Mellon University