Subject: [Tzdist] Request to respect RFC 2606 and RFC 6761, proposal to use example.com

From: Tobias Conradi <[email-masked]>
Date: Sat, 27 Sep 2014 13:01:01 +0200

====================================================
http://tools.ietf.org/html/rfc2606#section-2

2. TLDs for Testing, & Documentation Examples
[....]

   To safely satisfy these needs, four domain names are reserved as
   listed and described below.

                   .test
                .example
                .invalid
              .localhost

[....]

      ".example" is recommended for use in documentation or as examples.

http://tools.ietf.org/html/rfc2606#section-3

3. Reserved Example Second Level Domain Names

   The Internet Assigned Numbers Authority (IANA) also currently has the
   following second level domain names reserved which can be used as
   examples.
        example.com
        example.net
        example.org

http://tools.ietf.org/html/rfc6761#section-6.5

The domains "example.", "example.com.", "example.net.",
   "example.org.", and any names falling within those domains, are
   special in the following ways:

   1.  Users SHOULD understand that example names are reserved for use
       in documentation.
====================================================

Benefit of using these:
- example URLs are easier to find by readers
- example URLs can be copied directly to documentation
- example URLs are more standardized within the WG, and thus easier to read

As long as no special meaning is assigned to .com, .net, .org, and
different TLDs are not used to distinguish between two example URLs, I
propose to use the first from the 2nd level domains, i.e. example.com.

That has the benefit that example URLs are more likely to agree for the string

<example>.<com|net|org>/<base-path>

-- 
Tobias Conradi
Rheinsberger Str. 18
10115 Berlin
Germany

http://tobiasconradi.com

---

From: Tobias Conradi <[email-masked]>
Date: Sat, 27 Sep 2014 14:01:33 +0200

Occurrences of example URLs
======================

Found
---------
1)
https://tools.ietf.org/html/draft-ietf-tzdist-service-01

- 10 x example.com
- 10 x  tz.example.com
- 10 x .example
- 2 x tz.example.com.
- 1 x example.org
- 0 x example.net

2)
http://www.ietf.org/mail-archive/web/tzdist/current/msg00645.html

From: Stephen Colebourne <scolebourne at joda.org>
Date: Fri, 26 Sep 2014 10:56:00 +0100

several examples using
http://tzdbserver.com/data....

3)
http://www.ietf.org/mail-archive/web/tzdist/current/msg00652.html

From: Stephen Colebourne <scolebourne at joda.org>
Date: Fri, 26 Sep 2014 16:21:25 +0100

several examples using
http://tzdbserver.com/data....

4)
http://www.ietf.org/mail-archive/web/tzdist/current/msg00669.html

Stephen Colebourne <scolebourne at joda.org>
Date: Sat, 27 Sep 2014 11:12:56 +0100

several examples using
http://tzdist-provider.com/publishers/...

Not found
--------------
There might be more, but I know no way of finding them with one search
command in my email interface.

Fix that the proposal offers
===================
One could search emails for "example.com" and find example URLs.

-- 
Tobias Conradi
Rheinsberger Str. 18
10115 Berlin
Germany

http://tobiasconradi.com