Subject: Re: [Tzdist] Find action pattern questions

From: Cyrus Daboo <[email-masked]>
Date: Wed, 01 Oct 2014 13:45:34 +0100

Hi Paul,

--On September 30, 2014 at 1:28:34 PM -0700 Paul Eggert 
<[email-masked]> wrote:

> For what it's worth, the current tzid naming restrictions are listed
> below, taken from the Theory file, and they exclude "*".  I doubt whether
> these restrictions would be relaxed any time soon, except possibly the
> 14-character limit might be increased to 255.

Windows names seem to allow spaces too (e.g., see 
<http://unicode.org/repos/cldr/tags/latest/common/supplemental/windowsZones.xml>).

At this point I don't think we need to worry about tz names with a "*" in 
them but perhaps we could future proof it by stating an * in the search 
pattern is escaped via a backslash.

-- 
Cyrus Daboo

---

From: Ken Murchison <[email-masked]>
Date: Wed, 01 Oct 2014 08:49:00 -0400

On 10/01/2014 08:45 AM, Cyrus Daboo wrote:
> At this point I don't think we need to worry about tz names with a "*" 
> in them but perhaps we could future proof it by stating an * in the 
> search pattern is escaped via a backslash.
>

Just to be clear, would the escaped * match a single literal * or match 
0+ characters?

-- 
Kenneth Murchison
Principal Systems Software Engineer
Carnegie Mellon University

---

From: Cyrus Daboo <[email-masked]>
Date: Wed, 01 Oct 2014 13:56:58 +0100

Hi Ken,

> Just to be clear, would the escaped * match a single literal * or match

\* would match a single literal "*". An unescaped "*" could only occur at 
the start or end of the entire pattern as per the four" choices for pattern 
matching in the current spec.

i.e., "New_Y\*rk" would match "New_Y*rk" and not "New_York". And "\*York" 
would match "*York" and not "New_York".

-- 
Cyrus Daboo

---

From: Lester Caine <[email-masked]>
Date: Wed, 01 Oct 2014 14:07:04 +0100

> <http://unicode.org/repos/cldr/tags/latest/common/supplemental/windowsZones.xml>).

I don't think they have screwed things up again by allowing spaces in
names. While the group titles have spaces in, the TZID element are
'clean' with spaces just used to divide list of matching aliases.

-- 
Lester Caine - G8HFL
-----------------------------
Contact - http://lsces.co.uk/wiki/?page=contact
L.S.Caine Electronic Services - http://lsces.co.uk
EnquirySolve - http://enquirysolve.com/
Model Engineers Digital Workshop - http://medw.co.uk
Rainbow Digital Media - http://rainbowdigitalmedia.co.uk