Subject: Re: [Tzdist] # 1 LMT transition

From: Daniel Migault <[email-masked]>
Date: Thu, 23 Oct 2014 19:51:11 +0200

Dear Friends and Colleagues,

My understanding is that this issues is out of scope of the current draft.
This should be treated as an extension and current draft make such
extension possible. So I would like to close this issue.

Please let me know what you think of it.

BR,
Daniel

On Wed, Aug 20, 2014 at 10:48 PM, Lester Caine <[email-masked]> wrote:

> On 20/08/14 20:55, Ken Murchison wrote:
> > But I think such a mapping is outside the charter of this WG.
>
> Hence my original post about 'passing the buck'. The base data range
> that the protocol is treating as un-truncated has no limit, so since the
> IANA timezone data default is truncated at 1970, that is already
> covered. However the charter document allows for an unlimited time
> range, which the tzdist protocol would have to support? Which then
> throws up the problem of timezoneid values outside the range of the
> current full zone table in tz ...
>
> Restrictions to what is supported need to be fully documented.
>
> --
> Lester Caine - G8HFL
> -----------------------------
> Contact - http://lsces.co.uk/wiki/?page=contact
> L.S.Caine Electronic Services - http://lsces.co.uk
> EnquirySolve - http://enquirysolve.com/
> Model Engineers Digital Workshop - http://medw.co.uk
> Rainbow Digital Media - http://rainbowdigitalmedia.co.uk
>
> _______________________________________________
> Tzdist mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tzdist
>

-- 
Daniel Migault
Orange Labs -- Security
+33 6 70 72 69 58

---

From: Lester Caine <[email-masked]>
Date: Thu, 23 Oct 2014 19:38:00 +0100

On 23/10/14 18:51, Daniel Migault wrote:
> My understanding is that this issues is out of scope of the current
> draft. This should be treated as an extension and current draft make
> such extension possible. So I would like to close this issue.
> 

As long as there is no pretence that the initial offerings will provide
an un-truncated data set from day one then I will be happy. This is
related in part to historic data management and since there is currently
a diversity of opinion as to the way of handling this in tz, then there
is no reliable base for tzdist to currently distribute anyway. The
problem perhaps is getting some agreement as to a reliable start date
since while tz only guarantees data post 1970 there is valid pre-1970
data and many people will want a pre-1970 source.

Yes all out of scope of current draft, but publishing 'suspect' data has
to be avoided.