Subject: [Tzdist] draft-ietf-tzdist-service-05 demo server

From: Ken Murchison <[email-masked]>
Date: Fri, 23 Jan 2015 13:38:08 -0500

All,

I have updated my server implementation to be compliant with draft -05.

synctoken, version and etags in list response: 
https://cyrus-test.andrew.cmu.edu/tzdist/zones/

leapseconds action: https://cyrus-test.andrew.cmu.edu/tzdist/leapseconds/

The leap seconds data comes from the leap-seconds.list file in 2014J, so 
I list the publisher and version as IANA and 2014j respectively.  I'm 
wondering if I should instead use NIST as publisher and the last update 
timestamp in the file as the version. Thoughts?

-- 
Kenneth Murchison
Principal Systems Software Engineer
Carnegie Mellon University

---

From: Steve Allen <[email-masked]>
Date: Fri, 23 Jan 2015 11:12:56 -0800

On Fri 2015-01-23T13:38:08 -0500, Ken Murchison hath writ:
> The leap seconds data comes from the leap-seconds.list file in
> 2014J, so I list the publisher and version as IANA and 2014j
> respectively.  I'm wondering if I should instead use NIST as
> publisher and the last update timestamp in the file as the version.
> Thoughts?

IERS Paris is the authority for the list.  They currently have it as text
http://hpiers.obspm.fr/iers/bul/bulc/Leap_Second.dat
IERS Paris has begun to experiment with publishing their data as XML.
I think they might be able to produce the entire leap second list as
XML with digital signature.

--
Steve Allen                 <[email-masked]>                WGS-84 (GPS)
UCO/Lick Observatory--ISB   Natural Sciences II, Room 165    Lat  +36.99855
1156 High Street            Voice: +1 831 459 3046           Lng -122.06015
Santa Cruz, CA 95064        http://www.ucolick.org/~sla/     Hgt +250 m

---

From: Cyrus Daboo <[email-masked]>
Date: Fri, 23 Jan 2015 11:38:22 -0800

Hi Steve,

> XML with digital signature.

The JSON format now in the tzdist draft is basically the same as that, but 
without the MJD column.

-- 
Cyrus Daboo

---

From: Steve Allen <[email-masked]>
Date: Fri, 23 Jan 2015 12:05:26 -0800

> The JSON format now in the tzdist draft is basically the same as
> that, but without the MJD column.

Right, so for that list the full name of the authority is, verbosely
EOP Product Centre of International Earth Rotation Service and Reference Systems
and the version is
C49

---

From: Cyrus Daboo <[email-masked]>
Date: Fri, 23 Jan 2015 12:10:06 -0800

Hi Steve,

--On January 23, 2015 at 12:05:26 PM -0800 Steve Allen <[email-masked]> 
wrote:

> EOP Product Centre of International Earth Rotation Service and Reference
> Systems and the version is
> C49

Well except that since the IANA DB effectively re-publishes that data - it 
is also OK to use the IANA DB name and version.

-- 
Cyrus Daboo

---

From: Steve Allen <[email-masked]>
Date: Fri, 23 Jan 2015 12:18:24 -0800

On Fri 2015-01-23T12:10:06 -0800, Cyrus Daboo hath writ:
> Well except that since the IANA DB effectively re-publishes that
> data - it is also OK to use the IANA DB name and version.

Agreed, but in this arena there are bureaucratic sensitivities,
regulations, and statutes which require some users to hearken
to specific authorities and sources, so some publishers might
need to credit IERS EOP PC Paris.

---

From: Harlan Stenn <[email-masked]>
Date: Fri, 23 Jan 2015 12:35:00 -0800

List both/all?

Sent from my iPhone - please excuse brevity and typos

> On Jan 23, 2015, at 12:18 PM, Steve Allen <[email-masked]> wrote:
> 
> _______________________________________________
> Tzdist mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tzdist
>