Subject: [Unbearable] Token binding version (0, 10) support is global on google servers

From: Bill Cox <[email-masked]>
Date: Fri, 20 Jan 2017 04:29:24 -0800

I'm seeing 5.7K token binding headers per second at the moment, about 5K/s
sending both channel-ID and token binding (probably chrome), and about
700/s with just token binding (probably not chrome).

Bill

---

From: John Bradley <[email-masked]>
Date: Fri, 20 Jan 2017 10:01:30 -0300

Great news.

Is token binding not behind a feature flag for some of the newer builds of Chrome?

We should check if it is on in the Edge preview rings.   I think Andrei mentioned that was about to happen in Korea.  

Do you have any test page that would show if the cookies are successfully token bound ?

Thanks
John B.

> On Jan 20, 2017, at 9:29 AM, Bill Cox <[email-masked]> wrote:
> 
> I'm seeing 5.7K token binding headers per second at the moment, about 5K/s sending both channel-ID and token binding (probably chrome), and about 700/s with just token binding (probably not chrome).
> 
> Bill
> _______________________________________________
> Unbearable mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/unbearable

---

From: Bill Cox <[email-masked]>
Date: Fri, 20 Jan 2017 05:35:28 -0800

> Is token binding not behind a feature flag for some of the newer builds of

It still is behind a feature flag.  Nick Harper is doing a launch to turn
token binding on by default, IIUC.

> We should check if it is on in the Edge preview rings.   I think Andrei
> mentioned that was about to happen in Korea.
>

I don't think we've built such a page yet.  Would it be useful?

Bill

---

From: John Bradley <[email-masked]>
Date: Fri, 20 Jan 2017 10:45:19 -0300

Can you remind people in the WG what the flag is.

I think a test page is useful for PR.

The browserauth.net page run my Dirk should be updated to point to it.

I know that there is a test in the Chromium source but having some public page will encourage testing.

Thanks 
John B.

> On Jan 20, 2017, at 10:35 AM, Bill Cox <[email-masked]> wrote:
> 
> On Fri, Jan 20, 2017 at 5:01 AM, John Bradley <[email-masked] <mailto:[email-masked]>> wrote:
> Great news.
> 
> It still is behind a feature flag.  Nick Harper is doing a launch to turn token binding on by default, IIUC.
>

---

From: Brian Campbell <[email-masked]>
Date: Fri, 20 Jan 2017 08:22:54 -0700

chrome://flags/#enable-token-binding AFAIK is where one can flip the flag

---

From: Andrei Popov <[email-masked]>
Date: Fri, 20 Jan 2017 17:36:53 +0000

Ø  We should check if it is on in the Edge preview rings.   I think Andrei mentioned that was about to happen in Korea.
TB v0.10 is enabled by default in IE & Edge on the latest Windows 10 insider preview build.

Cheers,

Andrei

From: Unbearable [mailto:[email-masked]] On Behalf Of Brian Campbell
Sent: Friday, January 20, 2017 7:23 AM
To: John Bradley <[email-masked]>
Cc: Tokbind WG <[email-masked]>; token-binding-team <[email-masked]>; Bill Cox <[email-masked]>
Subject: Re: [Unbearable] Token binding version (0, 10) support is global on google servers

On Fri, Jan 20, 2017 at 6:45 AM, John Bradley <[email-masked]<mailto:[email-masked]>> wrote:
Can you remind people in the WG what the flag is.

The browserauth.net<http://browserauth.net> page run my Dirk should be updated to point to it.

Thanks
John B.

On Jan 20, 2017, at 10:35 AM, Bill Cox <[email-masked]<mailto:[email-masked]>> wrote:

On Fri, Jan 20, 2017 at 5:01 AM, John Bradley <[email-masked]<mailto:[email-masked]>> wrote:
Great news.

Bill

_______________________________________________
Unbearable mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/unbearable

---

From: John Bradley <[email-masked]>
Date: Fri, 20 Jan 2017 14:50:31 -0300

Fast and Slow or just Fast?

That explains the 700/s without channel-ID.

Thanks
John B.

> On Jan 20, 2017, at 2:36 PM, Andrei Popov <[email-masked]> wrote:
> 
> On Fri, Jan 20, 2017 at 6:45 AM, John Bradley <[email-masked] <mailto:[email-masked]>> wrote:
> The browserauth.net <http://browserauth.net/> page run my Dirk should be updated to point to it.
>  
> On Jan 20, 2017, at 10:35 AM, Bill Cox <[email-masked] <mailto:[email-masked]>> wrote:
>  
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/unbearable <https://www.ietf.org/mailman/listinfo/unbearable>

---

From: Vinod Anupam <[email-masked]>
Date: Fri, 20 Jan 2017 10:02:16 -0800

> 700/s with just token binding (probably not chrome).

Based on information in our logs, the requests with just token binding
headers are primarily from Edge.

cheers,
-Anupam

> Bill
>
> --
> You received this message because you are subscribed to the Google Groups
> "token-binding-team" group.
> To unsubscribe from this group and stop receiving emails from it, send an
> email to [email-masked].
> To post to this group, send email to [email-masked].
> To view this discussion on the web visit https://groups.google.com/a/
> google.com/d/msgid/token-binding-team/CAH9QtQHiMNKTWkExDduH%3DhuCzs%
> 3DyVW%2BE7YM3Wnoh0DoeYUe08A%40mail.gmail.com
> <https://groups.google.com/a/google.com/d/msgid/token-binding-team/CAH9QtQHiMNKTWkExDduH%3DhuCzs%3DyVW%2BE7YM3Wnoh0DoeYUe08A%40mail.gmail.com?utm_medium=email&utm_source=footer>
> .
>

---

From: John Bradley <[email-masked]>
Date: Fri, 20 Jan 2017 15:11:06 -0300

That is good news assuming everything is working. 

You now have support in IE and Edge in the latest Windows 10 preview.

John B.
> On Jan 20, 2017, at 3:02 PM, Vinod Anupam <[email-masked]> wrote:
> 
> 
> 
> On Fri, Jan 20, 2017 at 4:29 AM, Bill Cox <[email-masked] <mailto:[email-masked]>> wrote:
> Based on information in our logs, the requests with just token binding headers are primarily from Edge.
> 
> cheers,
> -Anupam
> 
> 
> Bill
> 
> -- 
> You received this message because you are subscribed to the Google Groups "token-binding-team" group.
> To unsubscribe from this group and stop receiving emails from it, send an email to [email-masked] <mailto:[email-masked]>.
> To post to this group, send email to [email-masked] <mailto:[email-masked]>.
> To view this discussion on the web visit https://groups.google.com/a/google.com/d/msgid/token-binding-team/CAH9QtQHiMNKTWkExDduH%3DhuCzs%3DyVW%2BE7YM3Wnoh0DoeYUe08A%40mail.gmail.com <https://groups.google.com/a/google.com/d/msgid/token-binding-team/CAH9QtQHiMNKTWkExDduH%3DhuCzs%3DyVW%2BE7YM3Wnoh0DoeYUe08A%40mail.gmail.com?utm_medium=email&utm_source=footer>.
>

---

From: Nick Harper <[email-masked]>
Date: Fri, 20 Jan 2017 10:15:01 -0800

Yes, that's the correct place to flip the flag to enable Token Binding in
Chrome.

---

From: Andrei Popov <[email-masked]>
Date: Fri, 20 Jan 2017 18:19:11 +0000

?  That is good news assuming everything is working.
We have reports of some interop failures; they're under investigation.

?  Fast and Slow or just Fast?
Fast for sure; I'm not certain about Slow.

From: Unbearable [mailto:[email-masked]] On Behalf Of John Bradley
Sent: Friday, January 20, 2017 10:11 AM
To: Vinod Anupam <[email-masked]>
Cc: Tokbind WG <[email-masked]>; token-binding-team <[email-masked]>; Bill Cox <[email-masked]>
Subject: Re: [Unbearable] Token binding version (0, 10) support is global on google servers

John B.
On Jan 20, 2017, at 3:02 PM, Vinod Anupam <[email-masked]<mailto:[email-masked]>> wrote:

On Fri, Jan 20, 2017 at 4:29 AM, Bill Cox <[email-masked]<mailto:[email-masked]>> wrote:
I'm seeing 5.7K token binding headers per second at the moment, about 5K/s sending both channel-ID and token binding (probably chrome), and about 700/s with just token binding (probably not chrome).

cheers,
-Anupam

Bill

--
You received this message because you are subscribed to the Google Groups "token-binding-team" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [email-masked]<mailto:[email-masked]>.
To post to this group, send email to [email-masked]<mailto:[email-masked]>.
To view this discussion on the web visit https://groups.google.com/a/google.com/d/msgid/token-binding-team/CAH9QtQHiMNKTWkExDduH%3DhuCzs%3DyVW%2BE7YM3Wnoh0DoeYUe08A%40mail.gmail.com<https://groups.google.com/a/google.com/d/msgid/token-binding-team/CAH9QtQHiMNKTWkExDduH%3DhuCzs%3DyVW%2BE7YM3Wnoh0DoeYUe08A%40mail.gmail.com?utm_medium=email&utm_source=footer>.

---

From: Pranav Kukreja <[email-masked]>
Date: Fri, 20 Jan 2017 19:46:35 +0000

Anupam, are those connections from Edge resulting in any connection errors post the TLS handshake, especially during false start. I am chasing down some interop issues with Edge talking to google servers with TB enabled at the moment. If you notice anything please let us know.

Thanks!
Pranav

From: Unbearable [mailto:[email-masked]] On Behalf Of Vinod Anupam
Sent: Friday, January 20, 2017 10:02 AM
To: Bill Cox <[email-masked]>
Cc: Tokbind WG <[email-masked]>; token-binding-team <[email-masked]>
Subject: Re: [Unbearable] Token binding version (0, 10) support is global on google servers

cheers,
-Anupam

Bill