Subject: [Uri-review] Fwd: Re: Informational RFC to be: draft-paskin-doi-uri-03.txt (updated from -02.txt)

From: [email-masked]
Date: Mon, 12 May 2003 12:38:32 -0700

Hi folks,
	The authors have revised doi: in light of
some of the comments.  If you can, please evaluate
the new document and comment on whether it solves
some of the problems previously identified.
			thanks,
				Ted

>
>Hi Ted,
>
>We have revised the "doi" Internet-Draft in light of your comments. The new
>draft is available under
>http://www.ietf.org/internet-drafts/draft-paskin-doi-uri-03.txt. Added to
>the draft are:
>
>* definitions of DOI key concepts (section 1)
>* lexical equivalence of "doi" URIs (sections 4, 5)
>* DOI administration and resolution (sections 6, 7)
>* rationale for a toplevel "doi" URI scheme (section 8).
>
>Could you review the document and send us your comments?
>
>
>Many thanks,
Sam
_______________________________________________
Uri-review mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/uri-review

---

From: "Larry Masinter" <[email-masked]>
Date: Wed, 14 May 2003 09:55:21 -0700

I cannot find a functional difference between the spelling
"permanent identifiers" with a D, O and I rather than
a U, R and N. It seems to me that both have the same
intrinsic difficulties. If the DOI consortium wants to
resolve identifiers, it could as easily resolve those
that start with "urn" as those that start with "doi",
couldn't it? Or at least those that start with "urn:doi"?

>* DOI administration and resolution (sections 6, 7)

But the document's statement in section 7 is vacuous. It says:

  "Resolution of a DOI is accomplished through an appropriate 
  resolution service using a network protocol specific to that 
  service."

I can't figure out what this means; it isn't to contrast
the method with resolution through an inappropriate resolution
service, or using a network protocol which isn't appropriate
for the service? But there's no actual definition for how
resolution takes place.

Nor does it actually say how administration works. It makes
reference to the "International DOI Foundation", without
any reference to the terms of incorporation of this
organization (if it is?) or its provenance. For all
I know, the "International DOI Foundation" is Norm in
his garage. Should we assign a URI namespace for everyone
who asks for one?

Section 8.1 attempts to address "demonstrated utility",
and claims there are "10 million examples in current
use on the Internet". How was this number measured?
(A google search on 'doi' shows 1 million hits, but
most of those are about Doi-san (Japanese name) or
the Department of Industry or Directorate of
Information.

I wouldn't mind so much if the document were up-front about
this being a naming service for a for-fee service
for name registration, whether or not it is "non-profit".
It's the same business model as the for-fee domain name
business, or, for that matter, RealNames.

Since "DOI and DOI.ORG are registered in the U.S. Patent
and Trademark Office" (according to
 http://www.doi.org/registration_agencies.html), shouldn't
there be an additional intellectual property statement?

If someone were to use a 'doi' URI without the permission
of the trademark/patent holder, would they be subject
to any intellectual property constraints?

Larry