Subject: Re: [Uri-review] Request for review of IAX2 URI scheme Registration

From: Cullen Jennings <[email-masked]>
Date: Mon, 15 Jan 2007 18:11:19 -0800

Hi Ed, one question. Why iax2 instead of just iax? Is the 2 for the  
version of the protocol?

On Nov 2, 2006, at 5:37 PM, Ed Guy wrote:

> Hello URI reviewers,
>
> I am working on "IAX2: Inter-Asterisk eXchange Version 2" (IAX2) an  
> application-layer control and media protocol for
> creating, modifying, and terminating multimedia sessions over
> Internet Protocol (IP) networks.
>
> The current draft is at http://www.ietf.org/internet-drafts/draft- 
> guy-iax-02.txt
>
> I would like to solicit early review of the IANA registration
> published in this draft and repeated below.
>
> The URI scheme is also utilized by "IANA Registration for IAX  
> Enumservice"
> http://www.ietf.org/internet-drafts/draft-ietf-enum-iax-01.txt
>
>
> Thank you in advance
>
> Ed Guy
> mailto:[email-masked]
>
> *****
>
> #START IAX2 URI Scheme Registration
>
> 5.1.  IAX2 URI Scheme Registration
>
>   This section registers IAX2 according to the guidelines in  
> [RFC4395].
>
>   URI scheme name:
>
>      iax2.
>
>   Status:
>
>      Permanent.
>
>   URI scheme syntax:
>
>      The "iax2:" scheme follows the guidelines in [RFC3986].
>
>      The general form is as follows:
>
>         iax2:[username@]host[:port][/number[?context]]
>
>         where these tokens have the following meanings:
>
>         iax2: The literal 'iax2:'.
>
>         username: A string used for identification purposes.
>
>         host: The domain of the resource.  The host part contains
>            either a fully-qualified domain name or numeric IPv4 or  
> IPv6
>            address.  An IPv6 address must be enclosed within brackets
>            (i.e., '[2001:db8::1]') as defined in [RFC3986].  Using the
>            fully-qualified domain name form is RECOMMENDED whenever
>            possible.
>
>         port: The numeric UDP port number.
>
>         number: The name or number identifying the resource on that
>            host.
>
>         context: The name of the host partition in which the  
> service is
>            identified or processed.
>
>      Examples
>         iax2:atlanta.com/alice
>         iax2:atlanta.com:4569/alice
>         iax2:atlanta.com:4570/alice?friends
>         iax2:192.0.2.4:4569/alice?friends
>         iax2:[2001:db8::1]:4569/alice?friends
>         iax2:whitehouse.gov/12022561414
>         iax2:[email-masked]/12022561414
>
>      ABNF Certain values are included by reference from [RFC3986]:
>
>         iax2-uri = "iax2:" [userinfo "@" ]host[":" port][ "/" number[
>         "?" context]]
>
>         userinfo = // as specified in RFC 3986
>
>         host = // as specified in RFC 3986
>
>         port = // as specified in RFC 3986
>
>         number = *(unreserved | sub-delims | pct-encoded )
>
>         context = *(unreserved | sub-delims | pct-encoded )
>
>         unreserved = // as specified in RFC 3986
>
>         sub-delims = // as specified in RFC 3986
>
>         pct-encoded = // as specified in RFC 3986
>
>   URI Scheme Semantics:
>
>      An IAX2 URI identifies a communications resource capable of
>      communicating using the IAX2 Version 2 protocol defined in this
>      document.  Within this document, we refer to IAX2 Version 2
>      protocol URI as IAX2.  An IAX2 URI contains enough information to
>      initiate an IAX2-based call with that resource.
>
>      IAX2 URIs are associated with server resources to which calls may
>      be routed.  For instance, an IAX2 URI may represent an appearance
>      on a phone, a voice-mail box on a messaging service, an
>      interactive program, a PSTN address or gateway, or any group of
>      the above.
>
>      The iax2 uri scheme translates into a location that may be  
> used by
>      the iax2 protocol to establish a new call using the uri scheme
>      components described in the previous section.  This new call
>      function is the only defined operation.
>
>   Encoding considerations:
>
>      IAX2 URI scheme encoding conforms to the encoding rules
>      established for URIs in [RFC3986].
>
>   Applications/protocols that use this URI scheme name:
>
>      The scheme is used by ENUM DDDS services to specify resources  
> that
>      support the IAX2 protocol.  The IAX2 protocol provides
>      application-layer control and media protocol for creating,
>      modifying, and terminating multimedia sessions over Internet
>      Protocol (IP) networks.
>
>   Interoperability considerations:
>
>      None.
>
>   Security considerations:
>
>      The IAX2 URI Scheme does not introduce any new security concerns
>      except that it provides a uniform syntax for describing IAX2
>      resources and that, when published, these addresses are  
> subject to
>      various denial os service attacks.
>
>   Contact:
>
>      Ed Guy, [email-masked], +1.973.437.4519.
>
>   Author/Change controller
>
>      Not Applicable.
>
>   References:
>
>      Spencer, M., Shumard, K., Capouch, B., and E. Guy, 'IAX2: Inter-
>      Asterisk eXchange Version 2,' draft-guy-iax-02 Work In Progress,
>      October 2006.
>
> 5.2.  URI Comparison
>
>   Some operations in this specification require determining whether  
> two
>   IAX2 URIs are equivalent.  IAX2 URIs are compared for equality
>   according to the following rules:
>
>   All components of the URI MUST be identical except:
>
>      A host in domain form and in IP address form are considered
>      identical if and only if the host name resolves to exactly one
>
>      address record and that address record matches the given IP
>      address.
>
>      The port, if omitted, is considered to be the same as the  
> default,
>      4569.
>
>      Only the user and password fields are case sensitive.
>
>   The URIs within each of the following sets are equivalent:
>   iax2:atlanta.com/alice
>   iax2:AtLaNtA.com/ALicE
>   iax2:atlanta.com:4569/alice
>
>   iax2:atlanta.com:4569/alice
>   iax2:192.168.1.1/alice (if atlanta.com resolves to 192.168.1.1)
>
>   The URIs within each of the following sets are not equivalent:
>   iax2:[email-masked]/alice
>   iax2:[email-masked]/alice
>
> #END
>
>
>
>
>
> _______________________________________________
> Uri-review mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/uri-review

_______________________________________________
Uri-review mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/uri-review

---

From: Ed Guy <[email-masked]>
Date: Tue, 16 Jan 2007 03:39:24 -0500

Cullen,

 >Hi Ed, one question. Why iax2 instead of just iax? Is the 2 for the 
version of the protocol?
yes, the '2' is the protocol version.

/ed

Cullen Jennings wrote:
>> The current draft is at 
>> http://www.ietf.org/internet-drafts/draft-guy-iax-02.txt
>>
>>   This section registers IAX2 according to the guidelines in [RFC4395].
>>
>>   URI scheme name:
>>
>>      iax2.
>>
>>   Status:
>>
>>      Permanent.
>>
>>   URI scheme syntax:
>>
>>            either a fully-qualified domain name or numeric IPv4 or IPv6
>>         context: The name of the host partition in which the service is
>>            identified or processed.
>>
>>      Examples
>>         iax2:atlanta.com/alice
>>      The iax2 uri scheme translates into a location that may be used by
>>      The scheme is used by ENUM DDDS services to specify resources that
>>      resources and that, when published, these addresses are subject to
>>   Some operations in this specification require determining whether two
>>      The port, if omitted, is considered to be the same as the default,
>>      4569.
>>