Subject: Re: [Uri-review] [rfc-i] Review:: draft-shur-pack-uri-scheme

From: Graham Klyne <[email-masked]>
Date: Mon, 07 Apr 2008 10:05:32 +0100

Frank Ellermann wrote:
> Hi, some issues in draft-shur-pack-uri-scheme:
> 
>  3) Redefining the STD 66 <authority> is confusing.  What
>     is apparently wanted here is a complete URI replacing
>     slashes by commas everywhere.

Not only confusing, but contravening the requirements for registering a new URI 
scheme.  See: http://www.rfc-editor.org/rfc/rfc4395.txt sections 2.8, 3.

The examples in section 3.2 of 
http://tools.ietf.org/id/draft-shur-pack-uri-scheme-03.txt are not allowable 
according to the syntax defined in http://www.ietf.org/rfc/rfc3986.txt (only 
digits may follow a ':').

#g

-- 
Graham Klyne
Contact info: http://www.ninebynine.org/#Contact

_______________________________________________
Uri-review mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/uri-review

---

From: "Frank Ellermann" <[email-masked]>
Date: Mon, 7 Apr 2008 20:43:30 +0200

Graham Klyne wrote:
 
> not allowable according to the syntax defined in
> http://www.ietf.org/rfc/rfc3986.txt (only digits
> may follow a ':').

Yes, it cannot match a <userinfo> without "@".  The
right hand side does not match <port>, it is no URI.

Pseudo-URIs caused enough havoc in 2007 on a popular
platform where ECMA 376 might be used if implemented.

 Frank