Subject: Re: [Uri-review] Review request: ggz URI scheme

From: Ted Hardie <[email-masked]>
Date: Mon, 5 Jan 2009 09:39:04 -0800

At 1:28 AM -0800 12/28/08, Josef Spillner wrote:
>Hello,
>
>a first draft on URIs/IRIs for use with GGZ Gaming Zone clients is attached. I
>would like to have it reviewed. One particular uncertainty from my side is
>how to handle URI and IRI differences, built into the grammar or added as an
>afterthought like done in the draft.
>
>Josef

Hello Josef,
	In your document, you give the ABNF for ggz as

  URI         = "ggz://" authority ["/" room ["/#" table]]
      room        = ggz-segment
      table       = ggz-segment
      ggz-segment = 1*( unreserved / pct-encoded / sub-delims
                  / ":" / "?" / "[" / "]" / "@" )

I suspect that using a two-character separator between
room and table isn't  a big problem, but I am somewhat
concerned about the use of # as one of the two.  RFC 3986
says:

  The generic syntax uses the slash ("/"), question mark ("?"), and
   number sign ("#") characters to delimit components that are
   significant to the generic parser's hierarchical interpretation of an
   identifier.

Since both / and # might be handled by a generic parser, I think
you run the risk that your special purpose parser won't
get the first shot at them.  If you think the relationship
of room and table actual fits into one of the existing relationships,
you should probably just pick that delimiter.  I can't really
see it as a fragment relationship (which is what # normally means),
but you know your own system best.

On the IRI question, you might want to look at RFC 5122 for an
example of how to describe the relationship.  As it stands,
though, unless you believe ggz URIs will show up on the side
of a bus, I'd suggest using the URI form (and I'd really strongly
suggest using the URI form for anything internal to your system).
The %-encoding mechanisms and IDNA dns names seem to
fit everything you've described.

			regards,
				Ted Hardie

_______________________________________________
Uri-review mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/uri-review

---

From: "Mark Baker" <[email-masked]>
Date: Mon, 5 Jan 2009 13:40:35 -0500

> but you know your own system best.

I was going to say the same thing.

Mark.

From: Cullen Jennings <[email-masked]>
To: [email-masked]
Impp: xmpp:[email-masked]
Date: Sun, 22 Feb 2009 23:41:48 -0700
Subject: [Uri-review] Review request: draft-jennings-http-srv

draft-jennings-http-srv defines two new schemes http+srv and https 
+srv. They basically are normal http but they use a DNS SRV lookups.  
Any thoughts appreciated.

Thanks, Cullen