Subject: [Uri-review] [uri-review] Review Request for Icon URI Scheme

From: Pierre-Antoine LaFayette <[email-masked]>
Date: Mon, 5 Apr 2010 11:12:05 -0400

Hi everyone!

I've put together a draft document for an icon URI scheme, used for
displaying platform specific icons in web pages, that I would like to get
some feedback on.

http://draft-icon-uri-scheme.googlecode.com/hg/draft-lafayette-icon-uri-scheme-00.html
.

Discussion of this scheme has been going on in the
[email-masked] list:
http://www.mail-archive.com/[email-masked]/msg07377.html

Thanks.

-- 
Pierre.

---

From: Toby Inkster <[email-masked]>
Date: Fri, 09 Apr 2010 12:06:12 +0100

On Mon, 2010-04-05 at 11:12 -0400, Pierre-Antoine LaFayette wrote:
> displaying platform specific icons in web pages, that I would like to
> get some feedback on.

This seems to have pretty poor fallback behaviour in existing user
agents. It would seem advantageous to reuse the existing HTTP scheme.

Rather than, have a URI of say:

	<icon:image/jpeg;32>

Instead use:

	<http://icons.example.net/image/jpeg;32>

Where icons.example.net is a domain name registered to someone
shepherding this idea.

icons.example.net would issue a policy stating that user agents are
permitted to resolve URIs beginning with <http://icons.example.net/>
internally (i.e. without making an HTTP GET request).

icons.example.net would provide an icon delivery service for legacy user
agents that did not resolve these URIs internally.

-- 
Toby A Inkster
<mailto:[email-masked]>
<http://tobyinkster.co.uk>

---

From: Joseph Holsten <[email-masked]>
Date: Fri, 9 Apr 2010 06:54:59 -0500

> Where icons.example.net is a domain name registered to someone

As you are recommending it, would you care to host this magic HTTP resource? Of course, we'd want to standardize on your host, as it would be needlessly complicated if every browser group used their own host.

Implementors tend to know where to look when they encounter an unknown URI scheme. Your idea has terrific fallback behaviour, but I'm not sure how best to inform developers that HTTP URIs with a host of icons.example.net. are okay to treat magically. Perhaps a HEAD request could say "More-Magic: icon"?

Also, congrats on the most useful variant of "Let's solve this URI scheme idea with HTTP URIs" that I've encountered this year.
--
http://josephholsten.com

---

From: Julian Reschke <[email-masked]>
Date: Fri, 09 Apr 2010 15:35:58 +0200

On 05.04.2010 17:12, Pierre-Antoine LaFayette wrote:
> http://draft-icon-uri-scheme.googlecode.com/hg/draft-lafayette-icon-uri-scheme-00.html.
>
> Discussion of this scheme has been going on in the [email-masked]
> <mailto:[email-masked]> mailing list:
> ...

Nit: you really shouldn't have a normative reference to an obsoleted 
spec (RFC 1738).

Best regards, Julian

---

From: Ira McDonald <[email-masked]>
Date: Wed, 14 Apr 2010 19:44:11 -0400

Hi,

For the 'file:' URI scheme, RFC 1738 *is* the correct normative reference.

Note that RFC 1738 is NOT obsoleted but is only updated by RFC 3986
- its current status is Proposed Standard, according to the RFC Index at:

  http://www.ietf.org/download/rfc-index.txt

The ABNF for the 'file:' URI scheme is only specified in RFC 1738 (and a
5-year-old expired ID by Paul Hoffman).

The 'file:' URI scheme is ubiquitously supported (*not* in an interoperable
fashion) by web browsers and operating systems.  The lack of a modern
reference RFC is a sore point for many standards developers.

Cheers,
- Ira

Ira McDonald (Musician / Software Architect)
Chair - Linux Foundation Open Printing WG
Co-Chair - TCG Hardcopy WG
IETF Designated Expert - IPP & Printer MIB
Blue Roof Music/High North Inc
http://sites.google.com/site/blueroofmusic
http://sites.google.com/site/highnorthinc
mailto:[email-masked]
winter:
  579 Park Place  Saline, MI  48176
  734-944-0094
summer:
  PO Box 221  Grand Marais, MI 49839
  906-494-2434

On Fri, Apr 9, 2010 at 9:35 AM, Julian Reschke <[email-masked]> wrote:
> Nit: you really shouldn't have a normative reference to an obsoleted spec
> (RFC 1738).
>
> Best regards, Julian
> _______________________________________________
> Uri-review mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/uri-review
>

---

From: Pierre-Antoine LaFayette <[email-masked]>
Date: Wed, 14 Apr 2010 20:22:21 -0400

Thanks to all for the comments. I did see the warning about RFC 1738 being
obsoleted by RFC 3986 while using the xml2rfc tool but that did not seem
correct to me --as Ira pointed out.

Regarding Toby's thoughts on using HTTP, I'm with Joseph on this one. For
this to be standardized, it really seems that an independent URI is needed.
Developers already use the moz-icon scheme in Mozilla; a generic icon scheme
is a simple and trustworthy way to bring this desired functionality to all
browsers and have developers be comfortable using it.

On 14 April 2010 19:44, Ira McDonald <[email-masked]> wrote:

> [email-masked]

-- 
Pierre.

---

From: Julian Reschke <[email-masked]>
Date: Thu, 15 Apr 2010 09:16:22 +0200

> For the 'file:' URI scheme, RFC 1738 *is* the correct normative reference.

Yes.

Why do you need a normative reference to "file" when defining a new URI 
scheme?

As far as I can tell, your spec imports two ABNF productions from that 
spec, so the simple fix is not to. Get them from the ABNF spec, the URI 
spec, or just copy what you need.

Best regards, Julian