Subject: [Uri-review] New icon URI scheme vs new URN namespace

From: Pierre-Antoine LaFayette <[email-masked]>
Date: Fri, 30 Apr 2010 13:42:09 -0400

In my provisional URI scheme registration request with IANA, my reviewer
noted that it may be preferable to use a URN namespace rather than create a
new URI scheme.

E.g.

*urn:icon:ext:pdf:small
urn:icon:mime:text:plain:64
urn:icon:unknown*

instead of:

*icon:.pdf;small*
*icon:text:plain;64*
*icon:unknown*

I wanted to run this by the list to see what the general opinion is on this
matter. What are the advantages/disadvantages and limitations of each? I'm
not sure which is more appropriate for the icon URI's use cases.

http://draft-icon-uri-scheme.googlecode.com/hg/draft-lafayette-icon-uri-scheme-00.html

Thanks,
Pierre.

---

From: David Booth <[email-masked]>
Date: Fri, 30 Apr 2010 20:43:39 -0400

On Fri, 2010-04-30 at 13:42 -0400, Pierre-Antoine LaFayette wrote:
> In my provisional URI scheme registration request with IANA, my
> reviewer noted that it may be preferable to use a URN namespace rather
> than create a new URI scheme.
> 
> 
> E.g.
> 
> urn:icon:ext:pdf:small
> urn:icon:unknown
> icon:.pdf;small
> icon:text:plain;64
> icon:unknown
> I wanted to run this by the list to see what the general opinion is on
> this matter. What are the advantages/disadvantages and limitations of
> each? I'm not sure which is more appropriate for the icon URI's use
> cases.
> 
> 
I agree with your reviewer.  IMO, if there isn't a new protocol defined
for it, there is no need for a new URI scheme.  URNs are intended for
exactly this kind of thing.

-- 
David Booth, Ph.D.
Cleveland Clinic (contractor)

Opinions expressed herein are those of the author and do not necessarily
reflect those of Cleveland Clinic.