Subject: Re: [Uri-review] URI for identifying a host

From: Alfred Hönes <[email-masked]>
Date: Fri, 21 May 2010 20:03:56 +0200 (MESZ)

Eran, you wrote:

> I would like to register a 'host' URN namespace for identifying a host
> (per RFC 3986, as the entity controlling all the resources with that
> URI host across all schemes and ports).  This urn-nid will be defined
> in the host-meta specification [2].
>
> I'm looking for some feedback before I change the host-meta draft to
> include the urn-nid registration.
>
> ...

Since host names (I guess you mean fully qualified domain names)
aren't "persistent, location-independent identifiers", you cannot
use URNs for this purpose.  You might want to take a look at
RFC 2141 and our initial draft intended to modernize this URN
specification and base it on RFC 3986 and other current standards,
draft-ah-rfc2141bis-urn-00, which now is discussed on [email-masked]
(and we intend to have a BOF at IETF 78 for an URNbis WG).

Kind regards,
  Alfred Hönes.

-- 

+------------------------+--------------------------------------------+
| TR-Sys Alfred Hoenes   |  Alfred Hoenes   Dipl.-Math., Dipl.-Phys.  |
| Gerlinger Strasse 12   |  Phone: (+49)7156/9635-0, Fax: -18         |
| D-71254  Ditzingen     |  E-Mail:  [email-masked]                     |
+------------------------+--------------------------------------------+

---

From: Eran Hammer-Lahav <[email-masked]>
Date: Fri, 21 May 2010 13:43:52 -0700

Hi Alfred,

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: Friday, May 21, 2010 11:04 AM
> To: Eran Hammer-Lahav
> Cc: [email-masked]
> Subject: Re: [Uri-review] URI for identifying a host
> 
> Eran, you wrote:
> 
> Since host names (I guess you mean fully qualified domain names) aren't
> "persistent, location-independent identifiers", you cannot use URNs for this
> purpose. 

I disagree. The identifier is about the host, regardless of who controls it or where it is currently "located". For example, the host urn:host:example.com will always identify the entity in control over http://example.com/1 and ftp://example.com/file. The domain name can change hands, the DNS records can point elsewhere, but it is always about the same entity, as I defined it.

EHL

> You might want to take a look at RFC 2141 and our initial draft
> intended to modernize this URN specification and base it on RFC 3986 and
> other current standards, draft-ah-rfc2141bis-urn-00, which now is discussed
> on [email-masked] (and we intend to have a BOF at IETF 78 for an URNbis WG).
> 
> Kind regards,
>   Alfred HÎnes.
> 
> --
>