Subject: Re: [Uri-review] New URI proposal.

From: "Smith, Kevin, (R&D) VF-Group" <[email-masked]>
Date: Mon, 14 Jun 2010 12:54:42 +0200

Dear Julian,
 
Thanks for the advice on the ACR proposal: as you say, it seems that a
URN would simplify matters. May I ask:
 
- is it acceptable to delineate metadata in the URN? For example - 
 
urn:acr:123456:mnc:12:cc:us
 
...would indicate a customer reference string of 123456; a mobile
network code of '12' and a country code of 'us'. The rationale is that a
Web developer wishing to consume a mobile network API on behalf of the
customer referenced would need to know the mobile network and country in
order to determine the API endpoint to use (an individual ACR is
published and known to only one network).
 
The Namespace-Specific Syntax section of RFC 2141 allows colons, however
I just wanted to check if it is recognised that the NSS may contain a
set of meta-information.
 
- would we still need to officially register the 'acr' namespace?
 
Many thanks for your time and advice.
 
Best regards,
Kevin
 
Vodafone Group R&D

---

From: Julian Reschke <[email-masked]>
Date: Wed, 16 Jun 2010 17:04:57 +0200

> I just wanted to check if it is recognised that the NSS may contain a

I think the NSS (namespace specific string) is under your control; you 
can use it anyway you want.

> - would we still need to officially register the 'acr' namespace?

Yes. See RFC 3406.

> ...

Best regards, Julian

---

From: Peter Saint-Andre <[email-masked]>
Date: Thu, 17 Jun 2010 20:42:12 -0600

>> - would we still need to officially register the 'acr' namespace?

If you would like to register a URN namespace identifier rather than a
URI scheme, please post to the [email-masked] list:

https://www.ietf.org/mailman/listinfo/urn-nid

Peter

-- 
Peter Saint-Andre
https://stpeter.im/