Subject: Re: [Uri-review] Review request for 'dvb' URI scheme

From: Mo McRoberts <[email-masked]>
Date: Sun, 4 Jul 2010 22:53:34 +0100

On 30-Jun-2010, at 00:18, Mo McRoberts wrote:

> Hello URI reviewers,
> 
> I’ve put together a -- perhaps slightly unorthodox -- draft for the 'dvb' URI scheme, with reference to the ETSI-published document (ETSI TS 102 851 — available from http://pda.etsi.org) which defines the scheme as part of the Digital Video Broadcasting (DVB) suite of standards:

FYI, this draft has been revised somewhat. The latest version is at:

http://www.ietf.org/id/draft-mcroberts-uri-dvb-03.txt

I'll wait a little while before sending this on to IANA, so any comments in the meantime are appreciated.

All the best,

Mo.

---

From: Graham Klyne <[email-masked]>
Date: Mon, 05 Jul 2010 17:00:13 +0100

Is there a common mechanism for dereferencing dvb: URIs (obtaining data for the 
identified resource), or do they serve as identifiers which are dereferenced by 
arbitrary or unspecified means?  I think it would help to have some indications 
about how they are actually used, other than simply as identifiers.

Also, is there a particular authority delegation structure for the allocation of 
the component parts?  If so, and indication of what this is could be helpful.

#g
--

Mo McRoberts wrote:
> _______________________________________________
> Uri-review mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/uri-review
>

---

From: Mo McRoberts <[email-masked]>
Date: Mon, 5 Jul 2010 21:59:35 +0100

Hi Graham,

Thanks for your comments.

On 5-Jul-2010, at 17:00, Graham Klyne wrote:

> Is there a common mechanism for dereferencing dvb: URIs (obtaining data for the identified resource), or do they serve as identifiers which are dereferenced by arbitrary or unspecified means?  I think it would help to have some indications about how they are actually used, other than simply as identifiers.

Dereferencing generally happens in the context of a receiver - an interactive TV application will use dvb: URIs in order to access resources delivered over the air. Outside of the receiver context, they serve more as opaque identifiers for stations and programmes.

> Also, is there a particular authority delegation structure for the allocation of the component parts?  If so, and indication of what this is could be helpful.

I can amend the draft to mention that, certainly. There is a hierarchy involved, with DVB Services <http://www.dvbservices.com/> the current RA for the "original_network_id" -- the 'network' (that is, the platform) then allocates, or delegates the allocation of, the other identifiers according to its own policy.

M.

---

From: "Martin J. Dürst" <[email-masked]>
Date: Wed, 07 Jul 2010 13:54:44 +0900

Hello Mo,

I agree with Graham, please amend the document as proposed. It may be 
tedious to add a lot of details, in that case, a pointer to the relevant 
document (and chapter/section number) would also help. The relevant 
document is actually accessible over the Web without any strings 
attached, at 
http://www.etsi.org/deliver/etsi_ts/102800_102899/102851/01.01.01_60/ts_102851v010101p.pdf.

Also, it would be good if you shortly mentioned that %-encoding is used 
with UTF-8-encoded octets. Section 5 of the above document says:

All characters not within the range of characters allowed in a URI must 
be encoded into UTF-8 and included in the URI
as a sequence of escaped octets. An escaped octet is encoded as a 
character triplet, consisting of the percent character
"%" followed by the two hexadecimal digits representing the octet code.

This makes dvb URIs compatible with IRIs, great!

Regards,   Martin.

On 2010/07/06 5:59, Mo McRoberts wrote:
> I can amend the draft to mention that, certainly. There is a hierarchy involved, with DVB Services<http://www.dvbservices.com/>  the current RA for the "original_network_id" -- the 'network' (that is, the platform) then allocates, or delegates the allocation of, the other identifiers according to its own policy.
>
> M.
>

-- 
#-# Martin J. Dürst, Professor, Aoyama Gakuin University
#-# http://www.sw.it.aoyama.ac.jp   mailto:[email-masked]

---

From: Mo McRoberts <[email-masked]>
Date: Wed, 7 Jul 2010 21:16:42 +0100

Hi folks,

Based on Graham and Martin's comments, I've updated the draft to -04:

http://www.ietf.org/id/draft-mcroberts-uri-dvb-04.txt

Many thanks for the feedback so far!

M.