Subject: Re: [Uri-review] The state of 'afs' URi scheme

From: Mykyta Yevstifeyev <[email-masked]>
Date: Tue, 11 Jan 2011 18:24:41 +0200

11.01.2011 18:11, Alastair Angwin1 wrote:
> Mykyta
> I have watched this thread and alerted some folks who would be closer to it
> than I am
> As someone who has been involved in standards and had to deal with legacy
> may I point out that the classification of "historic" is emotive,
> Regardless of whether or not it affects any current implementations or
> users it sends a less than desirable message. I cannot think of many of us
> other than a palaeontologist who would like ourselves or our work to be
> referred to as dinosaurs or ancient.
> May I suggest as a way forward that the team wanting to address these
> legacy, a much more preferred term, schemes actually contacts the OpenAFS
> folks or IBM who still support customers using AFS to get their input
> I don't think silence should always be taken as agreement ... perhaps those
> who would have an opinion are simply not sufficiently aware of current
> discussions
Alastair,

During the discussion that occurred here, it was mentioned that there is 
no any appropriate implementation that use the 'afs' URI scheme to 
access the AFS resources.  Maybe there are some server implementations, 
but having no interest to this scheme as a tool to access the resources 
provided by these servers makes the scheme just useless.  If there is no 
benefit from such a scheme.  Those who use AFS may use it, we don't 
restrict them.  We just want to indicate that the 'afs' scheme is out of 
use, deprecated.  And in this case, do you know any implementations to 
support this scheme?

Mykyta Yevstifeyev
> Regards
>
> Alastair Angwin
>
>
>
>
>
> From:       Mykyta Yevstifeyev<[email-masked]>
> To:         [email-masked]
> Date:       11/01/2011 15:31
> Subject:    The state of 'afs' URi scheme
> Sent by:    [email-masked]
>
>
>
> Dear all,
>
> I have posted the following message on 7 January:
>        Dear all,
>
>        Let me briefly summarize all the comments on 'afs' URI scheme.
>        Firstly,
>        those referring to OpenAFS, forget that AFS is not only network
>        service,
>        but just file system. If we move this scheme to historic, there will
>        be
>        no harm to those who use it. Moreover, I should repeat here that
>        moving
>        the scheme to Historic does not mean restricting them to be used. If
>        smbd still uses it, they will continue to do this. But it's
>        impossible,
>        as there is no clients for AFS as *network service*.
>
>        I personally think we should move it to Historic to indicate it is
>        not
>        used among the Internet and is outdated. So what we decide on 'afs'
>        URI
>        scheme?
>
>        All the best,
>        Mykyta Yevstifeyev
>
> and have not received any responses yet. Should I consider that as the
> 'silent agreement'?
>
> Mykyta
>
>

---

From: Mykyta Yevstifeyev <[email-masked]>
Date: Sun, 30 Jan 2011 14:03:12 +0200

Hello all,

I'd like to resume the discussion on 'afs' URI scheme by citing RFC 4395:

> In some circumstances, it is appropriate to note a URI scheme that
>    was once in use or registered but for whatever reason is *no longer in
>    common use* or the use is not recommended.  In this case, it is
>    possible for an individual to request that the URI scheme be
>    registered (newly, or as an update to an existing registration) as
>    'historical'.  Any scheme that is no longer in common use MAY be
>    designated as historical; the registration should contain some
>    indication to where the scheme was previously defined or documented.

So there is a sense in moving this scheme to Historical category since 
it fully matches to these guidelines.  Therefore I do not consider such 
action as inappropriate for the 'afs' URI scheme.

Any other thoughts as for this?

All the best,
Mykyta Yevstifeyev

---

From: Mykyta Yevstifeyev <[email-masked]>
Date: Mon, 31 Jan 2011 07:54:44 +0200

30.01.2011 20:20, Roy T. Fielding wrote:
> On Jan 30, 2011, at 4:03 AM, Mykyta Yevstifeyev wrote:
>
>> Hello all,
>>
>>>     was once in use or registered but for whatever reason is no longer in
>>>     common use or the use is not recommended.  In this case, it is
>> So there is a sense in moving this scheme to Historical category since it fully matches to these guidelines.  Therefore I do not consider such action as inappropriate for the 'afs' URI scheme.
> No, there is no reason to publish a new document about a
> scheme that was never used.  It is obsolete.
Roy,

I think that the document like that may be found here: 
https://datatracker.ietf.org/doc/draft-melnikov-mailserver-uri-to-historic/ 
is suitable for 'afs' URI scheme.  This is the same situation as with 
the 'mailserver' URI scheme.

Mykyta
> ....Roy

---

From: "Roy T. Fielding" <[email-masked]>
Date: Mon, 31 Jan 2011 00:28:29 -0800

On Jan 30, 2011, at 9:54 PM, Mykyta Yevstifeyev wrote:
> I think that the document like that may be found here: https://datatracker.ietf.org/doc/draft-melnikov-mailserver-uri-to-historic/ is suitable for 'afs' URI scheme.  This is the same situation as with the 'mailserver' URI scheme.

No, there is no reason to have that document either.  We don't need
these useless exercises in bit pushing -- there are plenty of other
drafts that need writing about actual protocols that were (and are)
used on the Web as identifiers.  afs, nfs, tn3270, and mailserver are
all examples of schemes that someone once thought might be a good idea,
but were in fact never used on the Internet.  They are obsolete.

....Roy

---

From: Mykyta Yevstifeyev <[email-masked]>
Date: Mon, 31 Jan 2011 13:20:32 +0200

Roy,

Since these schemes are in Provisional category, it means that they are 
'waiting for specification'.  If no-one specifies them, they should be 
moved to Historical.  That's clear, IMO.

Mykyta

---

From: "Roy T. Fielding" <[email-masked]>
Date: Mon, 31 Jan 2011 11:32:15 -0800

On Jan 31, 2011, at 3:20 AM, Mykyta Yevstifeyev wrote:
> Since these schemes are in Provisional category, it means that they are 'waiting for specification'.  If no-one specifies them, they should be moved to Historical.  That's clear, IMO.

No, they should be removed from the registry and allowed to be
defined by some other spec in the future.  There is no need to
reserve the schemes of unimplemented identifier mechanisms.

....Roy