Subject: [Uri-review] Requesting approval for URI schemes net.msmq, net.tcp, net.pipe

From: Piyush Joshi <[email-masked]>
Date: Mon, 17 Jan 2011 04:38:18 +0000

This is to request approval for the following URI schemes. Please find the information below, requested as per the template defined in RFC4395.  Please let me know if you have any additional questions.

URI scheme names

1)      net.msmq (to specify communication using .Net Message Framing protocol<http://msdn.microsoft.com/en-us/library/cc219293(PROT.10).aspx> over Microsoft Message Queuing)

2)      net.tcp (to specify communication using .Net Message Framing protocol<http://msdn.microsoft.com/en-us/library/cc219293(PROT.10).aspx> over TCP)

3)      net.pipe (to specify communication using .Net Message Framing protocol<http://msdn.microsoft.com/en-us/library/cc219293(PROT.10).aspx> over Microsoft Windows Named Pipe)

References
[MC-NMF]: .NET Message Framing Protocol Specification<http://msdn.microsoft.com/en-us/library/cc219293(PROT.10).aspx> describes the base .Net Message Framing Protocol.
[MS-NMFMB]: .NET Message Framing MSMQ Binding Protocol Specification<http://msdn.microsoft.com/en-us/library/ff469340(PROT.10).aspx> describes the .Net Message Framing Protocol binding to MSMQ protocol. (For details on net.msmq scheme)
[MS-NMFTB]: .NET Message Framing TCP Binding Protocol Specification<http://msdn.microsoft.com/en-us/library/ee941638.aspx>  describes the .Net Message Framing Protocol binding to TCP protocol. (For details on net.tcp scheme)

Status
Requesting 'Permanent' status

URI scheme syntax and semantics

*         For net.msmq - defined in 3.1.1.2 of [MS-NMFMB]

*         For net.tcp - defined in 3.1.1 of [MS-NMFTB]

*         For net.pipe - similar to net.tcp when the communication is using [MC-NMF] over Microsoft Windows Named Pipe.

Encoding considerations
      There are no special encoding considerations for these schemes.

Applications/protocols that use this URI scheme name
      These schemes are used for communication over .Net Message Framing Protocol [MC-NMF] in Microsoft Windows Communication Framework<http://msdn.microsoft.com/en-us/netframework/aa663324.aspx>

Interoperability considerations
      These schemes are used for communication over .Net Message Framing Protocol [MC-NMF] which is available for implementers under Microsoft Open Specification<http://www.microsoft.com/openspecifications/en/us/default.aspx>.

Security considerations
      There are no special security considerations mandated by the use of the aforementioned schemes.

Contact
      Piyush Joshi ([email-masked]<mailto:[email-masked]>), Microsoft Corporation
      Kirill Gavrylyuk ([email-masked]<mailto:[email-masked]> ), Microsoft Corporation

Author/Change controller
      NA (this is a request for 'Permanent' status)

Please let me know if you have any questions.

Thank you

-          Piyush

---

From: Mykyta Yevstifeyev <[email-masked]>
Date: Mon, 17 Jan 2011 11:25:23 +0200

Dear Piyush,

imo, It would really be more appropriate for the members of the
community to (1) introduce the particular draft(s) specifying the
schemes and (2) mention the schemes' syntax and semantics clearly
rather than making reference to the protocol specification where that
could hardly be found.

Mykyta Yevstifeyev

2011/1/17, Piyush Joshi <[email-masked]>:
> This is to request approval for the following URI schemes. Please find the
> information below, requested as per the template defined in RFC4395.  Please
> let me know if you have any additional questions.
>
> URI scheme names
>
> 1)      net.msmq (to specify communication using .Net Message Framing
> protocol<http://msdn.microsoft.com/en-us/library/cc219293(PROT.10).aspx>
> over Microsoft Message Queuing)
>
> 2)      net.tcp (to specify communication using .Net Message Framing
> protocol<http://msdn.microsoft.com/en-us/library/cc219293(PROT.10).aspx>
> over TCP)
>
> 3)      net.pipe (to specify communication using .Net Message Framing
> protocol<http://msdn.microsoft.com/en-us/library/cc219293(PROT.10).aspx>
> over Microsoft Windows Named Pipe)
>
> References
> [MC-NMF]: .NET Message Framing Protocol
> Specification<http://msdn.microsoft.com/en-us/library/cc219293(PROT.10).aspx>
> describes the base .Net Message Framing Protocol.
> [MS-NMFMB]: .NET Message Framing MSMQ Binding Protocol
> Specification<http://msdn.microsoft.com/en-us/library/ff469340(PROT.10).aspx>
> describes the .Net Message Framing Protocol binding to MSMQ protocol. (For
> details on net.msmq scheme)
> [MS-NMFTB]: .NET Message Framing TCP Binding Protocol
> Specification<http://msdn.microsoft.com/en-us/library/ee941638.aspx>
> describes the .Net Message Framing Protocol binding to TCP protocol. (For
> details on net.tcp scheme)
>
> Status
> *         For net.pipe - similar to net.tcp when the communication is using
> [MC-NMF] over Microsoft Windows Named Pipe.
>
> Encoding considerations
>       These schemes are used for communication over .Net Message Framing
> Protocol [MC-NMF] in Microsoft Windows Communication
> Framework<http://msdn.microsoft.com/en-us/netframework/aa663324.aspx>
>
>       These schemes are used for communication over .Net Message Framing
> Protocol [MC-NMF] which is available for implementers under Microsoft Open
> Specification<http://www.microsoft.com/openspecifications/en/us/default.aspx>.
>
> Security considerations

---

From: Julian Reschke <[email-masked]>
Date: Mon, 17 Jan 2011 11:06:35 +0100

On 17.01.2011 05:38, Piyush Joshi wrote:
> This is to request approval for the following URI schemes. Please find
> the information below, requested as per the template defined in RFC4395.
> Please let me know if you have any additional questions.

First of all: it's totally great that Microsoft is considering to 
register these. Thanks.

With that in mind:

> *URI scheme names *
>
> 1)*net.msmq* (to specify communication using .Net Message Framing
> protocol
> <http://msdn.microsoft.com/en-us/library/cc219293(PROT.10).aspx> over
> Microsoft Message Queuing)
> ...

Is that URI stable?

> *URI scheme syntax and semantics*
>
> ·For net.msmq – defined in 3.1.1.2 of [MS-NMFMB]
 > ...

I see a grammar here, but nothing resembling a URI scheme definition.

> *Encoding considerations*
>

That's hard to tell without knowing how the scheme looks like :-)

Generally, this part needs to discuss how non-URI characters are treated 
when building an identifier.

> *Security considerations*
>

I note that the first spec I picked *has* a section about Security 
Considerations...

 > ...

Best regards, Julian

---

From: Mykyta Yevstifeyev <[email-masked]>
Date: Mon, 17 Jan 2011 20:01:00 +0200

17.01.2011 12:06, Julian Reschke wrote:
> <.....>
I also do not find the description of URI syntax there.  I really wonder 
how did you want us to review the scheme registration template with no 
clear definition of syntax and semantics - the main in the scheme 
definition.
>
> <.....>
> _______________________________________________
> Uri-review mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/uri-review
>

---

From: Piyush Joshi <[email-masked]>
Date: Mon, 17 Jan 2011 22:58:03 +0000

Thanks Mykyta, Julian for your comments!
Do you have any example you could point me to which will help me in providing the syntax/definition which will be useful for this review? 

Julian - I didn't quite understand what is meant by this question. Could you please elaborate? 
>> Is that URI stable?

Thank you.

-----Original Message-----
From: Mykyta Yevstifeyev [mailto:[email-masked]] 
Sent: Monday, January 17, 2011 10:01 AM
To: Julian Reschke
Cc: Piyush Joshi; [email-masked]; Kirill Gavrylyuk
Subject: Re: [Uri-review] Requesting approval for URI schemes net.msmq, net.tcp, net.pipe

17.01.2011 12:06, Julian Reschke wrote:
>> *For net.msmq - defined in 3.1.1.2 of [MS-NMFMB]
> > ...
>
I also do not find the description of URI syntax there.  I really wonder how did you want us to review the scheme registration template with no clear definition of syntax and semantics - the main in the scheme definition.

---

From: Julian Reschke <[email-masked]>
Date: Tue, 18 Jan 2011 00:09:10 +0100

> Do you have any example you could point me to which will help me in providing the syntax/definition which will be useful for this review?

Have a look at a recently published scheme, such as 
<http://www.rfc-editor.org/rfc/rfc6068.txt>.

> Julian - I didn't quite understand what is meant by this question. Could you please elaborate?

Will the the spec still be served from the URI in five years from now? 
URIs assigned by some CMS (or something similar to that) always make be 
a bit skeptical...

Best regards, Julian

---

From: "Michael Wojcik" <[email-masked]>
Date: Tue, 18 Jan 2011 07:24:52 -0800

> From: [email-masked] [mailto:[email-masked]]
> On Behalf Of Julian Reschke
> Sent: Monday, 17 January, 2011 18:09
> 

I'm not sure what you mean by "assigned by some CMS", but the net.*
schemes are already widely used by Microsoft.NET applications, as
they're a basic part of WCF. It's extremely unlikely (extrapolating from
history) that many such applications won't still be in use five years
from now.
 
They're apparently also in use by Mono applications, since Mono appears
to support a decent subset of WCF, including NetTcpBinding and
NetMsmqBinding, and people are discussing using those bindings in Mono
applications. (I don't know if Mono supports NetPipeBinding.)

So that's two widely-used implementations, with URIs using those schemes
embedded in applications that are likely to see long use. I think
they're likely to be stable.

-- 
Michael Wojcik
Principal Software Systems Developer, Micro Focus

This message has been scanned for viruses by MailController - www.MailController.altohiway.com

---

From: Julian Reschke <[email-masked]>
Date: Tue, 18 Jan 2011 16:31:32 +0100

> history) that many such applications won't still be in use five years

I'm talking about the *specification* URIs, such as:

  <http://msdn.microsoft.com/en-us/library/cc219293(PROT.10).aspx>

Best regards, Julian

---

From: "Michael Wojcik" <[email-masked]>
Date: Tue, 18 Jan 2011 08:23:40 -0800

> From: Julian Reschke [mailto:[email-masked]]
> Sent: Tuesday, 18 January, 2011 10:32
> 
> > I'm not sure what you mean by "assigned by some CMS"...
> 

Oh, of course. Yes, I agree - if the RFC cites those URIs, they'd better
be stable. And MSDN library URIs do not have a terrific history in that
regard.

---

From: Julian Reschke <[email-masked]>
Date: Tue, 18 Jan 2011 17:50:03 +0100

> be stable. And MSDN library URIs do not have a terrific history in that

That's why I was asking :-)

In doubt make it a redirect on purl.org that later can be updated.

Best regards, Julian