Subject: [Uri-review] A question as for 'ipps' URI specification

From: Mykyta Yevstifeyev <[email-masked]>
Date: Sun, 13 Mar 2011 14:25:07 +0200

Hello Ira, all,

I've recently looked through the document of PWG called Internet 
Printing Protocol Version 2.0 
(ftp://ftp.pwg.org/pub/pwg/candidates/cs-ipp20-20090731-5100.10.pdf).  
So I'd like to ask whether your proposed 'ipps' scheme specification 
(http://tools.ietf.org/html/draft-mcdonald-ipps-uri-scheme-02) applies 
only to the cases when such URI identifies resources designated by 
IPP/1.1 or IPP/2.0 and 2.1 as well?

Mykyta Yevstifeyev

---

From: Ira McDonald <[email-masked]>
Date: Mon, 14 Mar 2011 12:48:21 -0400

Hi Mykyta,

Just like the 'ipp' URI scheme (RFC 3510), an 'ipps' URI
can refer to ANY IPP resource (printer, job, subscription,
others) supporting ANY version (current or future) of IPP.

The edition of IPP/2.0 spec (2009) that you're looking at
is *obsolete* and has several dozen known errors.

It is superseded by the brand new IPP/2.0 Second Edition
(which defines *3* new levels - 2.0, 2.1, and 2.2):

- ftp://ftp.pwg.org/pub/pwg/candidates/cs-ipp20-20110214-5100.12.pdf
  (PWG Candidate Standard 5100.12-2011, February 2011)

(The PWG web page for standards will be updated later
today to reflect the obsolete status of 5100.10)

Cheers,
- Ira

Ira McDonald (Musician / Software Architect)
Chair - Linux Foundation Open Printing WG
Co-Chair - IEEE-ISTO PWG IPP WG
Co-Chair - TCG Hardcopy WG
IETF Designated Expert - IPP & Printer MIB
Blue Roof Music/High North Inc
http://sites.google.com/site/blueroofmusic
http://sites.google.com/site/highnorthinc
mailto:[email-masked]
Christmas through April:
  579 Park Place  Saline, MI  48176
  734-944-0094
May to Christmas:
  PO Box 221  Grand Marais, MI 49839
  906-494-2434

On Sun, Mar 13, 2011 at 8:25 AM, Mykyta Yevstifeyev <[email-masked]>wrote:

>  Hello Ira, all,
>
> I've recently looked through the document of PWG called Internet Printing
> Protocol Version 2.0 (
> ftp://ftp.pwg.org/pub/pwg/candidates/cs-ipp20-20090731-5100.10.pdf).  So
> I'd like to ask whether your proposed 'ipps' scheme specification (
> http://tools.ietf.org/html/draft-mcdonald-ipps-uri-scheme-02) applies only
> to the cases when such URI identifies resources designated by IPP/1.1 or
> IPP/2.0 and 2.1 as well?
>
> Mykyta Yevstifeyev
>

---

From: Mykyta Yevstifeyev <[email-masked]>
Date: Mon, 14 Mar 2011 21:01:00 +0200

> (which defines *3* new levels - 2.0, 2.1, and 2.2):
In this case your document should reference this standard normatively, 
not only RFC 2910, 2911.  That is why I asked.

Mykyta Yevstifeyev
> mailto:[email-masked] <mailto:[email-masked]>
> Christmas through April:
> On Sun, Mar 13, 2011 at 8:25 AM, Mykyta Yevstifeyev 
> <[email-masked] <mailto:[email-masked]>> wrote:
>
>     Hello Ira, all,
>
>     (http://tools.ietf.org/html/draft-mcdonald-ipps-uri-scheme-02)
>     applies only to the cases when such URI identifies resources
>     designated by IPP/1.1 or IPP/2.0 and 2.1 as well?
>
>     Mykyta Yevstifeyev
>
>