Subject: [Uri-review] Any concerns with draft-yevstifeyev-xri-uri-rsrv?

From: Mykyta Yevstifeyev <[email-masked]>
Date: Sat, 11 Jun 2011 07:44:49 +0300

Hello,

Please see http://tools.ietf.org/html/draft-yevstifeyev-xri-uri-rsrv-00.

The document is currently under OASIS XRI TC 
(http://www.oasis-open.org/committees/tc_home.php?wg_abbrev=xri) review; 
however I'd like to ask whether anybody has concerns with regard to it.

Thanks,
Mykyta Yevstifeyev

---

From: Julian Reschke <[email-masked]>
Date: Sat, 11 Jun 2011 09:55:18 +0200

> however I'd like to ask whether anybody has concerns with regard to it.

Is it? The latest news are from April 2010.

XRI also has a long history with the W3C TAG; I recommend to research 
the mailing list before proceeding (maybe start at 
<http://lists.w3.org/Archives/Public/www-tag/2008May/0078.html>).

Best regards, Julian

---

From: Mykyta Yevstifeyev <[email-masked]>
Date: Sat, 11 Jun 2011 16:34:26 +0300

> Is it? The latest news are from April 2010.
I've applied to Drummond Reed, one of the TC co-chairs, to bring this to 
attention of TC members so that they could give the draft their review.
> <http://lists.w3.org/Archives/Public/www-tag/2008May/0078.html>).
Ok, I'll look through these archives.

Mykyta

---

From: Graham Klyne <[email-masked]>
Date: Sun, 12 Jun 2011 07:26:55 +0100

<sigh> Why does everyone want to reinvent URIs?

I can't see any point in this.  We already have urn: and info: schemes.  And the 
declared purpose of this scheme ("Extensible Resource Identifiers (XRIs) are a 
way of abstractly identifying a resource independently of any particular 
concrete representation of it") is demonstrably achievable using http (W3C specs 
do it all the time) or other existing URI schemes.

#g
--

Mykyta Yevstifeyev wrote:
> _______________________________________________
> Uri-review mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/uri-review
>

---

From: Mykyta Yevstifeyev <[email-masked]>
Date: Sun, 12 Jun 2011 11:48:09 +0300

12.06.2011 9:26, Graham Klyne wrote:
> I can't see any point in this.  We already have urn: and info: 
> schemes.  And the declared purpose of this scheme ("Extensible 
> Resource Identifiers (XRIs) are a way of abstractly identifying a 
> resource independently of any particular concrete representation of 
> it") is demonstrably achievable using http (W3C specs do it all the 
> time) or other existing URI schemes.
Actually, XRI 3.0 will abandon using 'xri' scheme, I've checked with TC 
chairs.  However, XRI 2.0, which is the most current XRI specification, 
still makes use of it.  Please note that XRI 2.0 was published in 2005, 
so it could be useful to note your comment then; my draft is just  
formal registration of the scheme which is declared to be in use.

Mykyta Yevstifeyev
>> (http://www.oasis-open.org/committees/tc_home.php?wg_abbrev=xri) 
>> review; however I'd like to ask whether anybody has concerns with 
>> regard to it.
>>
>> Thanks,
>> Mykyta Yevstifeyev