Subject: [Uri-review] dvb: URI scheme

From: Mo McRoberts <[email-masked]>
Date: Sun, 28 Oct 2012 23:30:21 +0000

Dear uri-review,

Some time ago, I published a rather 'light' I-D which documents the dvb: URI scheme, as used by cable, satellite and terrestrial TVs, PVRs and set-top boxes which adhere to the DVB[1][2] standard (and some more besides).

Since then, I've collaborated with Alexander Adolf, who chairs the Generic Data Broadcasting & Service Information Protocols working group[3] of the DVB Project, to flesh out the draft into something which is a little more useful without referring back to the canonical reference for the scheme, ETSI TS 102 851.

As we are both relatively satisfied that the draft can be considered stable, we are looking to move from provisional to permanent registration of the scheme at IANA, and publication of the draft as an RFC.

As a step towards that, we're putting out this call for comments here.

It's probably worth stressing that the intent of the I-D is to document (and codify within the Internet, rather than broadcasting, community) the existing behaviour and design of the scheme; as retrospective documentation goes, this one's covering a scheme which is pretty well-baked. That said, I'm sure Alexander will be more than happy to feed back any constructive criticism of the scheme itself via the DVB TM-GBS group to help shape future editions of the standards.

Please do CC: Alexander and me in any replies as we're not subscribed to the list.

Many thanks,

Mo.

[1] http://www.dvb.org
[2] http://en.wikipedia.org/wiki/Digital_Video_Broadcasting
[3] http://www.dvb.org/groups_modules/technical_module/tmgbs/index.xml?groupID=5

--
Mo McRoberts - Technical Lead - The Space
0141 422 6036 (Internal: 01-26036) - PGP key CEBCF03E,
Zone 1.08, BBC Scotland, Pacific Quay, Glasgow, G51 1DA
Project Office: Room 7083, BBC Television Centre, London W12 7RJ

-----------------------------
http://www.bbc.co.uk
This e-mail (and any attachments) is confidential and
may contain personal views which are not the views of the BBC unless specifically stated.
If you have received it in
error, please delete it from your system.
Do not use, copy or disclose the
information in any way nor act in reliance on it and notify the sender
immediately.
Please note that the BBC monitors e-mails
sent or received.
Further communication will signify your consent to
this.
-----------------------------

---

From: Mo McRoberts <[email-masked]>
Date: Sun, 28 Oct 2012 23:32:16 +0000

It probably helps if I include a link to the draft:

http://tools.ietf.org/html/draft-mcroberts-uri-dvb-09

M.

---

From: Ted Hardie <[email-masked]>
Date: Mon, 29 Oct 2012 10:48:09 -0700

Howdy,

I'm assuming that this is
https://datatracker.ietf.org/doc/draft-mcroberts-uri-dvb/ ; the
datatracker shows that as being in the independent submission queue at
the RFC Editor.  Have you already gotten feedback from Graham Klyne
(the IANA expert for this registry)?

regards,

Ted Hardie

On Sun, Oct 28, 2012 at 4:30 PM, Mo McRoberts <[email-masked]> wrote:
> _______________________________________________
> Uri-review mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/uri-review

---

From: Mo McRoberts <[email-masked]>
Date: Mon, 29 Oct 2012 17:51:42 +0000

> (the IANA expert for this registry)?

We've had some earlier discussions with Graham, but as there have been significant changes (partly in response to Graham’s suggestions), we're looping back around again — the doc entered the ISR queue at -05, and we're now up to -09 (I suspect there'll be a -10 before it goes further along the RFC process).

M.

---

From: Alexander Adolf <[email-masked]>
Date: Mon, 29 Oct 2012 18:59:25 +0100

Dear uri-review,

On 2012-10-29, at 00:30 , Mo McRoberts <[email-masked]> wrote:

> [...]
> That said, I'm sure Alexander will be more than happy to feed back any constructive criticism of the scheme itself via the DVB TM-GBS group to help shape future editions of the standards.
> [...]

Absolutely. The grammar representing the scheme in this ID has e.g. already been simplified wrt. the original one in the ETSI doc, as an outcome of our work. So I am looking forward to any suggestions for improvements, ease of use, etc. that might arise. I will be happy to feed these back into the DVB process.

Thanks a lot and cheers,

  --alexander adolf

---

From: Graham Klyne <[email-masked]>
Date: Mon, 29 Oct 2012 20:09:19 +0000

Hi Ted,

TL;DR: Yes, but this seems like a reasonable step forward from our earlier 
discussions, and IMO more detailed review is appropriate at this juncture.

Mo and I had some moderately extensive discussion of this about the time of the 
provisional registration.

I haven't yet had a look at the latest draft, but in the circumstances it seems 
to me to be a reasonable step forward.  If I recall correctly, I was previously 
a bit concerned about permanent registration of a scheme for which there was no 
freely available specification, so at the time we settled for provisional.  Or 
something like that.

Since then I've got a better sense of the scope of use of this scheme, and Mo 
has made a fair case for "promotion" to permanent status, *provided* there are 
no problems raised by community review (and in the face of problems, permanent 
registration with caveats might yet be an appropriate course).

#g
--

---

From: Alexander Adolf <[email-masked]>
Date: Wed, 31 Oct 2012 17:35:49 +0100

Dear Graham, uri-reviewers,

On 2012-10-29, at 21:09 , Graham Klyne <[email-masked]> wrote:

> [...]
> TL;DR: Yes, but this seems like a reasonable step forward from our earlier discussions, and IMO more detailed review is appropriate at this juncture.
> [...]

Thanks a lot for picking this up. Looking forward to your comments.

> I haven't yet had a look at the latest draft, but in the circumstances it seems to me to be a reasonable step forward.  If I recall correctly, I was previously a bit concerned about permanent registration of a scheme for which there was no freely available specification, so at the time we settled for provisional.  Or something like that.

The ETSI specification in question (as are all ETSI specifications) has always been, and will remain to be freely available (including free of charge) to everyone. Sometimes there are concerns about IPR; esp. when W3C is involved. In order to remove the need for every implementor or user of the draft to ask ETSI about the IPR status (to which their answer is "no IPR here"), we (DVB) have agreed to putting the whole syntax and grammar in the ID, effectively re-publishing it under the IETF Trust's terms. That way, the IPR situation is implicitly clarified for every reader of the document.

> Since then I've got a better sense of the scope of use of this scheme, and Mo has made a fair case for "promotion" to permanent status, *provided* there are no problems raised by community review (and in the face of problems, permanent registration with caveats might yet be an appropriate course).
> [...]

Of course Mo and I will be happy to explain and answer to all questions raised; and we are also looking forward to improving the draft based on comments and suggestions.

As the DVB Project, we would highly welcome if a permanent status of the registration could be achieved, since it apparently is part of our brand.

Thanks a lot and cheers,

  --alexander