Subject: Re: [Uri-review] Registration request for smtp:// and submit:// URI schemes (draft-melnikov-smime-msa-to-mda-04)

From: Alexey Melnikov <[email-masked]>
Date: Tue, 1 Apr 2014 09:44:23 +0100

Hi Dave,

> On 31 Mar 2014, at 20:12, Dave Thaler <[email-masked]> wrote:
> 
> Alexey Melnikov wrote:
>> I am also registering submit:// URI
>> scheme, which is a similar URI schemes, but for designating Mail Submission
>> Agents.
> 
> My understanding from your email and from a glance at
> draft-melnikov-smime-msa-to-mda is that the proposed "submit" scheme is
> not currently widely deployed, and hence the actual name is flexible.

Yes, ...
> My feedback is that the name "submit" is not a good name for the proposed use.
> Specifically, RFC 4395 states:
>> Avoid using names that are either very general purpose or associated
>> in the community with some other application or protocol.
> 
> There are many types of things you can "submit" (HTTP forms, etc.)
> and since the proposed use here is specific to specific to SMTP, it should
> not use a general purpose word like "submit" along.
> 
> "smtpsubmit" or similar would be much more appropriate.

I would rather use the same label as used by DNS SRV for the same service: "submission". (I think keeping them different would be a bad thing.). Thoughts?

Best Regards,
Alexey

---

From: Alexey Melnikov <[email-masked]>
Date: Tue, 1 Apr 2014 09:49:28 +0100

> On 1 Apr 2014, at 04:59, "Robert A. Rosenberg" <[email-masked]> wrote:
> 
> At 15:33 -0700 on 03/31/2014, Bill McQuillan wrote about Re: [ietf-smtp] [Uri-review] Registration request for smtp::
> 
>>>> On Mon, 2014-03-31, Dave Thaler wrote:
>>>> Alexey Melnikov wrote:
>> I hope that whichever keyword is used, it is clearly
>> distinguished from "mailto".
> 
> Mailto invokes a MUA and supplies the To data and optionally other headers such as subject, message body, cc, bcc, etc for a created message.

Right.
>> I know I'm a bit confused about this proposal. Is "submit"
>> intended to be a lower abstraction level? Or a replacement?
> 
> From reading the proposal, Submit seems to be a way of supplying the SMTP server to be used to inject email into the system (ie: What you would enter into a MUA "SMTP Server" Parm). It is a SMTP Server dedicated as the Mail Submission Agent role as opposed to the more generic MTA role (which is listed in a MX record) which can not only the target of a MUA injection connection but also a SMTP Server to SMTP Server message forwarding connection. The SMTP type seems to be a generic Server of the latter type/function.

Almost. I think of MTAs as being a different type of service from the one provided by MSAs, although they speak almost the same protocol.
So the intent was to use "smtp" only for server to server transfers. But I am open to suggestions on whether this is reasonable or not.

---

From: "Robert A. Rosenberg" <[email-masked]>
Date: Mon, 31 Mar 2014 23:59:57 -0400

At 15:33 -0700 on 03/31/2014, Bill McQuillan wrote about Re: 

>distinguished from "mailto".

Mailto invokes a MUA and supplies the To data and optionally other 
headers such as subject, message body, cc, bcc, etc for a created 
message.

>intended to be a lower abstraction level? Or a replacement?

 From reading the proposal, Submit seems to be a way of supplying the 
SMTP server to be used to inject email into the system (ie: What you 
would enter into a MUA "SMTP Server" Parm). It is a SMTP Server 
dedicated as the Mail Submission Agent role as opposed to the more 
generic MTA role (which is listed in a MX record) which can not only 
the target of a MUA injection connection but also a SMTP Server to 
SMTP Server message forwarding connection. The SMTP type seems to be 
a generic Server of the latter type/function.

>
>--
>Bill McQuillan <[email-masked]>
>
>_______________________________________________
>ietf-smtp mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/ietf-smtp

---

From: Dave Thaler <[email-masked]>
Date: Tue, 1 Apr 2014 17:33:11 +0000

Alexey Melnikov wrote:
> > There are many types of things you can "submit" (HTTP forms, etc.) and
> > since the proposed use here is specific to specific to SMTP, it should
> I would rather use the same label as used by DNS SRV for the same service:
> "submission". (I think keeping them different would be a bad thing.). Thoughts?

I didn't know about the SRV service type before this, but yes that sounds like a
reasonable goal.  

I'm thinking it would be good to add a sentence about this case
(service names and URI scheme names SHOULD be the same, when there exists
a 1:1 correspondence) to draft-ietf-appsawg-uri-scheme-reg.  Does that
sound reasonable?

-Dave

---

From: Alexey Melnikov <[email-masked]>
Date: Tue, 1 Apr 2014 19:57:37 +0100

> On 1 Apr 2014, at 18:33, Dave Thaler <[email-masked]> wrote:
> 

It sounds reasonable to me.

---

From: "Martin J. Dürst" <[email-masked]>
Date: Wed, 02 Apr 2014 10:14:47 +0900

On 2014/04/02 02:33, Dave Thaler wrote:
> Alexey Melnikov wrote:
>>> My feedback is that the name "submit" is not a good name for the proposed

>> "submission". (I think keeping them different would be a bad thing.). Thoughts?

If the SRV service name is "submission", and the proposed scheme name is 
"submit", aren't these two *different* labels?

> a 1:1 correspondence) to draft-ietf-appsawg-uri-scheme-reg.  Does that

Yes. I'm not sure it needs to be a SHOULD, something like "consider to 
make this the same as...".

Regards,   Martin.

---

From: Alexey Melnikov <[email-masked]>
Date: Wed, 2 Apr 2014 07:10:10 +0100

Hi Martin,

> On 2 Apr 2014, at 02:14, "Martin J. Dürst" <[email-masked]> wrote:
> 
> If the SRV service name is "submission", and the proposed scheme name is "submit", aren't these two *different* labels?

I am suggesting of making them the same. I thought they were...
> Yes. I'm not sure it needs to be a SHOULD, something like "consider to make this the same as...".