Subject: Re: [Uri-review] Registration request for math: URI scheme

From: Graham Klyne <[email-masked]>
Date: Sun, 04 May 2014 08:19:55 +0100

Gerardo,

I come late to this discussion, and I don't have all the intervening messages as 
my email was completely broken for a period when this discussion started.

I suspect my comment will have been made by others, but just in case...

Unless I'm missing something, this looks to me like an abuse of the URI scheme 
mechanism.  The Web architecture is built on the principle that URIs are 
orthogonal to content, yet this scheme proposal appears to be entirely 
content-related.  I find it hard to believe there aren't other ways to achieve 
your goals without the somewhat nuclear option of introducing a new URI scheme - 
the Web handles dispatching for all kinds of diverse content without new schemes 
(but it may be that I'm unaware of some key element of what you propose).

Lacking a clear semantics for the proposed scheme (your template has that "TBD") 
it's hard to be more constructive at this stage.  If there is a requirement to 
launch alternative applications to process some resource, then I think, to make 
sense as a new URI scheme, such a feature should not be couched in 
format-dependent requirements of math expressions, but be potentially generic to 
launching a viewer/editor for *any* format.

#g
--

On 29/04/2014 18:55, Gerardo Capiel wrote:
> On Sat, Apr 26, 2014 at 11:35 PM, Gerardo Capiel <[email-masked]<mailto:[email-masked]>> wrote:
>
> Hi,
>
> I'm requesting a provisional 'math' URI scheme name. The 'math' URI scheme and protocol handler can be used by Web browsers and other applications to transport mathematical expressions to other applications, such as Assistive Technologies or graphing calculators.  Below is the provisional URI Scheme Registration Template:
>
>     URI scheme name
>        math - The math: URI scheme can be used by Web browsers and other applications to transport mathematical expressions to other applications, such as Assistive Technologies or graphing calculators.
>
>     Status
>        Provisional
> x
>     URI scheme syntax
> ​​
>
>        Applications launched via the math protocol take as a parameter either a URL to a resource containing a mathematical expression in MathML or other formats or the actual math expression in uncompressed or compressed form. For example:
>        math://mathmlcloud.org/m/uniqueexpressionid
>        math:<math><mi>x</mi><mo>+</mo><mn>2</mn></math>
>        math:<math-compressed>someexpressionincompressedformat</math-compressed>
>
>     URI scheme semantics
>        TBD
>
>     Encoding considerations
>        TBD
>
>     Applications/protocols that use this URI scheme name
>        Applications should register the math: protocol handler with this scheme.
>
>     Interoperability considerations
>        TBD
>
>     Security considerations
>        None known.
>
>     Contact
>        Gerardo Capiel,[email-masked]<mailto:[email-masked]>
>
>     Author/Change controller
>        Gerardo Capiel,[email-masked]<mailto:[email-masked]>
>
>     References
>        [1]http://www.w3.org/community/groups/proposed/#mathprotocol
>        [2]https://wiki.benetech.org/display/MATH/Protocol+Handlers+for+External+Applications+to+Process+MathML
>

---

From: "Van De Sompel, Herbert" <[email-masked]>
Date: Mon, 5 May 2014 14:39:08 +0000

Gerardo,

It might be of interest to looks at OpenURL as a way to transport such information:

http://www.niso.org/standards/z39-88-2004

OpenURL is mainly used for access to scholarly articles. A typical OpenURL transports information from publisher's sites to linking servers operated by libraries. But the standard was written in such a way that it allows for other applications by defining other profiles. I could imagine defining an OpenURL profile for what you want to achieve.

Greetings

Herbert Van de Sompel

On May 4, 2014, at 1:19 AM, Graham Klyne <[email-masked]>
 wrote:

> Gerardo,
> 
> I come late to this discussion, and I don't have all the intervening messages as my email was completely broken for a period when this discussion started.
> 
> Unless I'm missing something, this looks to me like an abuse of the URI scheme mechanism.  The Web architecture is built on the principle that URIs are orthogonal to content, yet this scheme proposal appears to be entirely content-related.  I find it hard to believe there aren't other ways to achieve your goals without the somewhat nuclear option of introducing a new URI scheme - the Web handles dispatching for all kinds of diverse content without new schemes (but it may be that I'm unaware of some key element of what you propose).
> 
> Lacking a clear semantics for the proposed scheme (your template has that "TBD") it's hard to be more constructive at this stage.  If there is a requirement to launch alternative applications to process some resource, then I think, to make sense as a new URI scheme, such a feature should not be couched in format-dependent requirements of math expressions, but be potentially generic to launching a viewer/editor for *any* format.
> 
> #g
> --
> 
> 
> 
> _______________________________________________
> Uri-review mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/uri-review

---

From: Gerardo Capiel <[email-masked]>
Date: Mon, 5 May 2014 16:51:04 +0000

Graham,

Comments below:

Gerardo,

I suspect my comment will have been made by others, but just in case…

You can read all the good discussion at:
http://www.ietf.org/mail-archive/web/uri-review/current/maillist.html
and
http://lists.w3.org/Archives/Public/uri/2014Apr/

Unless I'm missing something, this looks to me like an abuse of the URI scheme mechanism.  The Web architecture is built on the principle that URIs are orthogonal to content, yet this scheme proposal appears to be entirely content-related.

Perhaps, but let me state a couple of use cases:
1) I want to be able to easily open a mathematical formula in a native application, such as Mathematica, a graphing calculator, Excel or any other application that can process mathematical functions.  I would like this to be as easy as opening a mail client via a mailto: link or iTunes via itms: links.
https://reference.wolfram.com/mathematica/XML/tutorial/MathML.html#23340

2) Similarly, I want to open a formula in MathML on the Web in a formula editor:
http://en.wikipedia.org/wiki/Formula_editor

3) I want to open a MathML formula on the Web in an Assistive Technology that allows me to convert the formula into Nemeth Braille or I want to be able to granularly step through the formula with a screen reader application.  This functionality should be built into all modern browsers and HTML5 based eBook readers, but unfortunately as is often the case with accessibility, it has not happened despite numerous pleas through all the proper channels.  Using plugins has proven highly problematic for the only player who has tried to tackle this for IE:
http://news.dessci.com/2013/10/microsoft-cripples-display-math-ie10-11.html

I find it hard to believe there aren't other ways to achieve your goals without the somewhat nuclear option of introducing a new URI scheme - the Web handles dispatching for all kinds of diverse content without new schemes (but it may be that I'm unaware of some key element of what you propose).

See #3 above.  A solution is needed now.

In the last week, we have moved towards using supporting only MathML within a page referenced by a URL with optional an optional anchor (e.g. #formula1) for the case where multiple formulas exist on the referenced page.  Also we plan to use mathproc: instead of the very generic math:.

#g
--

On 29/04/2014 18:55, Gerardo Capiel wrote:
On Sat, Apr 26, 2014 at 11:35 PM, Gerardo Capiel <[email-masked]<mailto:[email-masked]><mailto:[email-masked]>> wrote:

Hi,

   URI scheme name

   Status
      Provisional
x
   URI scheme syntax
​​

   URI scheme semantics
      TBD

   Encoding considerations
      TBD

   Security considerations
      None known.

   Contact
      Gerardo Capiel,[email-masked]<mailto:[email-masked]><mailto:[email-masked]>

   Author/Change controller
      Gerardo Capiel,[email-masked]<mailto:[email-masked]><mailto:[email-masked]>

   References

---

From: Ted Hardie <[email-masked]>
Date: Mon, 5 May 2014 11:26:01 -0700

On Mon, May 5, 2014 at 9:51 AM, Gerardo Capiel <[email-masked]>wrote:

>  Graham,
>
>  Comments below:
>
>   Gerardo,
>
> I come late to this discussion, and I don't have all the intervening
> messages as my email was completely broken for a period when this
> discussion started.
>
> Unless I'm missing something, this looks to me like an abuse of the URI
> scheme mechanism.  The Web architecture is built on the principle that URIs
> are orthogonal to content, yet this scheme proposal appears to be entirely
> content-related.
>
>
> 1) I want to be able to easily open a mathematical formula in a native
> application, such as Mathematica, a graphing calculator, Excel or any other
> application that can process mathematical functions.  I would like this to
> be as easy as opening a mail client via a mailto: link or iTunes via
> itms: links.
>  3) I want to open a MathML formula on the Web in an Assistive Technology
> that allows me to convert the formula into Nemeth Braille or I want to be
> able to granularly step through the formula with a screen reader
> application.  This functionality should be built into all modern browsers
> and HTML5 based eBook readers, but unfortunately as is often the case with
> accessibility, it has not happened despite numerous pleas through all the
> proper channels.  Using plugins has proven highly problematic for the only
> player who has tried to tackle this for IE:
​Perhaps another way of expressing Graham's point is that you can invoke
handlers either via specifying their type (e.g. MIME-type) or by specifying
their protocol treatment (what transport, semantics, discovery, etc. you
use).  Your use cases (especially in combination) seem to point to
invocation of handling by type, rather than protocol.

regards,

Ted Hardie

> I find it hard to believe there aren't other ways to achieve your goals
> without the somewhat nuclear option of introducing a new URI scheme - the
> Web handles dispatching for all kinds of diverse content without new
> schemes (but it may be that I'm unaware of some key element of what you
> propose).
>
>
> Lacking a clear semantics for the proposed scheme (your template has that
> "TBD") it's hard to be more constructive at this stage.  If there is a
> requirement to launch alternative applications to process some resource,
> then I think, to make sense as a new URI scheme, such a feature should not
> be couched in format-dependent requirements of math expressions, but be
> potentially generic to launching a viewer/editor for *any* format.
>
>
>  In the last week, we have moved towards using supporting only MathML
> within a page referenced by a URL with optional an optional anchor (e.g.
> #formula1) for the case where multiple formulas exist on the referenced
> page.  Also we plan to use mathproc: instead of the very generic math:.
>
>
> #g
> --
>
>
>
> On Sat, Apr 26, 2014 at 11:35 PM, Gerardo Capiel <[email-masked]<
> mailto:[email-masked] <[email-masked]>>> wrote:
>
> Hi,
>
> I'm requesting a provisional 'math' URI scheme name. The 'math' URI scheme
> and protocol handler can be used by Web browsers and other applications to
> transport mathematical expressions to other applications, such as Assistive
> Technologies or graphing calculators.  Below is the provisional URI Scheme
> Registration Template:
>
>    URI scheme name
>       math - The math: URI scheme can be used by Web browsers and other
> applications to transport mathematical expressions to other applications,
> such as Assistive Technologies or graphing calculators.
>
>    Status
>       Provisional
> x
>    URI scheme syntax
> ​​
>
>       Applications launched via the math protocol take as a parameter
> either a URL to a resource containing a mathematical expression in MathML
> or other formats or the actual math expression in uncompressed or
> compressed form. For example:
>       Gerardo Capiel,[email-masked]<mailto:[email-masked]<[email-masked]>
> >
>
>    Author/Change controller
>       Gerardo Capiel,[email-masked]<mailto:[email-masked]<[email-masked]>
> >
>
>    References
>       [2]
> https://wiki.benetech.org/display/MATH/Protocol+Handlers+for+External+Applications+to+Process+MathML
>
>
>

---

From: Gerardo Capiel <[email-masked]>
Date: Tue, 6 May 2014 01:04:11 +0000

Ted,

Comments below:

Gerardo

On May 5, 2014, at 11:26 AM, Ted Hardie <[email-masked]<mailto:[email-masked]>>
 wrote:

On Mon, May 5, 2014 at 9:51 AM, Gerardo Capiel <[email-masked]<mailto:[email-masked]>> wrote:
Graham,

Comments below:

Gerardo,

​Perhaps another way of expressing Graham's point is that you can invoke handlers either via specifying their type (e.g. MIME-type) or by specifying their protocol treatment (what transport, semantics, discovery, etc. you use).  Your use cases (especially in combination) seem to point to invocation of handling by type, rather than protocol.

The issue that has come up in other threads is that the MIME-types approach tends to result in the content being downloaded to local storage and some browsers don't automatically launch the appropriate application.  I'm shooting for a user experience that is as seamless as what you see in this video of a prototype:

https://www.youtube.com/watch?v=jajYsEikdI4

One downside I have found is that only Firefox provides a choice about which application to launch when you have multiple applications that can handle the protocol request.

Thoughts?

regards,

Ted Hardie

#g
--

Hi,

   URI scheme name

   Status
      Provisional
x
   URI scheme syntax
​​

   URI scheme semantics
      TBD

   Encoding considerations
      TBD

   Security considerations
      None known.

   Contact

   Author/Change controller

   References

_______________________________________________
Uri-review mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/uri-review