Subject: [Uri-review] provisional URI scheme 'ln' registration

From: Rolf-Jürgen Moll <[email-masked]>
Date: Fri, 12 Dec 2014 11:35:34 +0000

Please review and register this provisional URI scheme template:

URI scheme name
===============
ln

Status
======
provisional

URI scheme syntax
=================
ln:[//<protocol>:<server>[:<port>]/]<type>/<resource>

URI scheme semantics
====================
The scheme is used to identify resources provided by the LucaNet.Server.

<protocol>
----------
Allowed values are "http" and "https".

<server>
--------
DNS or IP address of the LucaNet.Server.

<port>
------
Port of the LucaNet.Server. If port is omitted, the value "80" will be
assumed for the protocol "http" and the value "443" for the protocol "https".

<type>
------

Type                             Description
-----------------------------------------------------------------------------------
imdb                             The URI identifies a resource in an IMDB module
                                 (IMDB: LucaNet In Memory Database).

imdb:<module_id>                 The URI identifies a resource in the IMDB module
                                 <module_id>.

imdb:<database_id>:<module_id>   The URI identifies a resource in the IMDB module
                                 <module_id> of the database <database_id>.

dt                               The URI identifies a data type resource.

icon                             The URI identifies an icon resource.

rf                               The URI identifies a row format resource.

Samples
-------
ln://http:192.168.0.1:81/imdb:x_adam:0/pEDskFm10tKkQOyQWbXS0g
ln://https:localhost/imdb:x_adam:0/pEDskFm10tKkQOyQWbXS0g

ln:imdb:x_adam:0/pEDskFm10tKkQOyQWbXS0g
ln:imdb:0/pEDskFm10tKkQOyQWbXS0g
ln:imdb:pEDskFm10tKkQOyQWbXS0g

ln:dt:12
ln:icon:8
ln:rf:1

Encoding considerations
=======================
Use URL encoding

Applications/protocols that use this URI scheme name
====================================================
LucaNet.Server

Interoperability considerations
===============================
If <protocol> and <server> are not specified, these information must be provided by the
context, e.g. the URI points to a resource on the current LucaNet.Server.

If <module_id> and/or <databse_Id> is not specified, these information must be provided
by the context, e.g. the URI points to a resource in the current IMDB module of the
current database of the current LucaNet.Server.

Security considerations
=======================
-

Contact
=======
Rolf-Juergen Moll
mailto:info(at)lucanet.com
http://www.lucanet.com

Author/Change controller
========================
Rolf-Juergen Moll
mailto:info(at)lucanet.com
http://www.lucanet.com

References
==========
http://www.lucanet.com

Mit freundlichen Grüßen

ROLF-JÜRGEN MOLL
-------------------------------------------------------------------------------------------------
LucaNet AG
Alexanderplatz 1
10178 Berlin
Germany
Phone: +49 30 4699100
Fax: +49 30 46991029

www.lucanet.com
-------------------------------------------------------------------------------------------------
Executive Board: Rolf-Jürgen Moll, Oliver Schmitz, Dominik Duchon
Chairman of the Supervisory Board: David Worthmann
Company headquarters: Berlin
Register court: Berlin, Amtsgericht Berlin, HRB 97214
-------------------------------------------------------------------------------------------------

LucaNet – 15 years of expertise in financial consolidation, planning and controlling

Follow us on XING, Twitter, Google+, Facebook, YouTube and LinkedIn

---

From: Bjoern Hoehrmann <[email-masked]>
Date: Sat, 13 Dec 2014 13:44:18 +0100

>Please review and register this provisional URI scheme template:

Considering the seemingly proprietary nature of the scheme, I think a
longer name would be more appropriate, like `lucanet` for instance.

>ln://https:localhost/imdb:x_adam:0/pEDskFm10tKkQOyQWbXS0g

This syntax is not possible under the constraints of RFC 3986, the two
strings do not match the `URI` grammar.

>Encoding considerations

It is obvious that you use URL encoding for URLs; instead, the section
should say something about, for example, using non-ASCII characters.
-- 
Björn Höhrmann · mailto:[email-masked] · http://bjoern.hoehrmann.de
D-10243 Berlin · PGP Pub. KeyID: 0xA4357E78 · http://www.bjoernsworld.de
 Available for hire in Berlin (early 2015)  · http://www.websitedev.de/

---

From: Graham Klyne <[email-masked]>
Date: Mon, 15 Dec 2014 11:48:57 +0000

> longer name would be more appropriate, like `lucanet` for instance.

I was going to make similar comment.

Note from RFC4395:
[[
URI scheme names should be short, but also sufficiently descriptive
and distinguished to avoid problems.
]]
-- https://tools.ietf.org/html/rfc4395#section-2

In this case, I think "lucanet" would be better choice.

Also:
[[
   o  If no permanent, citable specification for the URI scheme
       definition is included, credible reasons for not providing it
       should be given.
]]
-- https://tools.ietf.org/html/rfc4395#section-3

I'm not seeing any usable specification - the "reference" appears to be a 
corporate web page, not a specification.

And:
[[
    o  A valid Security Considerations section, as required by Section 6
       of [3].
]]
-- https://tools.ietf.org/html/rfc4395#section-3

A blank section doesn't constitute a "valid Security Considerations section". 
Since the application concerned appears to be accounting, I'd expect security to 
be a real concern here.  (Note: it's not expected that the security 
considerations will solve any security concerns, just raise awareness of what 
they may be so that developers don't walk blindly into security bear-traps.)

...

More generally, I'm not seeing any reason why a new URI scheme is used here: 
why can't HTTP be used to retrieve resources from a Lucanet server?  Your 
description looks rather like an attempt to tunnel HTTP URIs  through a new 
scheme, which seems really at odds with the idea of using a URI.

...

And, as a procedural matter, your email asks "Please review and register this 
provisional URI scheme" ... to register a scheme you need to send a request to 
IANA as described in RFC4395

#g
--