Subject: Re: [Uri-review] Fwd: [saag] pkcs#11 URI scheme

From: Stephen Farrell <[email-masked]>
Date: Mon, 01 Dec 2014 22:13:16 +0000

On 26/11/14 16:07, Bjoern Hoehrmann wrote:
> * Stephen Farrell wrote:
>> [1] https://datatracker.ietf.org/doc/draft-pechanec-pkcs11uri/
> 
> One thing I noticed is that it uses "x-" prefixed vendor extensions;
> given BCP 178 there should probably be a rationale included in the
> document (the first draft predates the BCP by some years, so perhaps
> this is just documenting existing usage).

Thanks Bjoern - that's a good comment to make during IETF
LC (which I've just requested). If you have a chance I'd
appreciate you asking. If not, (and if I remember:-), I'll
ask 'em myself.

Cheers,
S.

---

From: "Martin J. Dürst" <[email-masked]>
Date: Tue, 02 Dec 2014 18:05:44 +0900

On 2014/11/26 23:32, Stephen Farrell wrote:
>
> Hiya,
>
> Please see below. Similar question for this group.

My understanding is that the registration template should be in the 
document itself, even if it's mostly the same as a previous one.

Regards,    Martin.

> Thanks,
> S.
>
> PS: I'm not subscribed to uri-review so please do
> cc me on any on-list responses.
>
>
> -------- Forwarded Message --------
> Subject: [saag] pkcs#11 URI scheme
> Date: Wed, 26 Nov 2014 14:30:22 +0000
> From: Stephen Farrell <[email-masked]>
> To: [email-masked] <[email-masked]>
>
>
> Hiya,
>
> I've been asked if I'd AD sponsor this [1] draft that
> defines a URI scheme for pkcs#11. Feedback is welcome
> before I decide. (On/off list, whatever is ok for now.)
>
> Thanks,
> S.
>
> _______________________________________________
> saag mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/saag
>
>
>
>
> _______________________________________________
> Uri-review mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/uri-review
>

---

From: Stephen Farrell <[email-masked]>
Date: Tue, 02 Dec 2014 13:31:43 +0000

> document itself, even if it's mostly the same as a previous one.

Thanks Martin, I'll check that out and we can get it fixed at
the end of IETF LC (that being ok as I think it is the same as
before). If you don't mind we may run that by this list just
to check it's correct at that point.

Cheers,
S.

---

From: Shawn M Emery <[email-masked]>
Date: Wed, 03 Dec 2014 16:51:38 -0700

> document itself, even if it's mostly the same as a previous one.

Yes.  The authors will include the template here:

     http://www.iana.org/assignments/uri-schemes/prov/pkcs11

after removing the list of implementations.

Thanks,

Shawn.
--

---

From: Shawn M Emery <[email-masked]>
Date: Wed, 03 Dec 2014 16:55:51 -0700

> this is just documenting existing usage).

We agree that this should be done.  The authors will make this update 
with the next revision.

Thanks,

Shawn.
--