Subject: [Uri-review] Review request for "filesystem" historical URI scheme

From: Chris Rebert <[email-masked]>
Date: Mon, 13 Jul 2015 16:44:18 -0700

Hello,

Per the advice of RFC 7595, I hereby present the following proposed
registration of the "filesystem" historical URI scheme for review. Any
feedback is greatly appreciated. Thanks.

Cheers,
Chris

********

Scheme name:  filesystem

Status:  Historical

Applications/protocols that use this scheme name:
  This scheme was part of the "File API: Directories and System"
  W3C Working Draft.  It was intended to be implemented by web user
  agents
  such as web browsers.  The specification did not gain traction and was
  abandoned.  At the time of writing this registration, the
  specification is
  only known to be implemented in the Google Chrome family of web
  browsers,
  under a "webkit" vendor prefix.

Contact:
  Registering party:  Chris Rebert <[email-masked]>
  Scheme creator:  W3C WebApps Working Group

Change controller:
  W3C

References:
  Uhrhane, E., "File API: Directories and System", W3C Working Group
  Note,
      April 2014, <http://www.w3.org/TR/file-system-api/>.
  Bidelman, E., "Exploring the FileSystem APIs", April 2014,
      <http://www.html5rocks.com/en/tutorials/file/filesystem/>.

---

From: Dave Thaler <[email-masked]>
Date: Tue, 14 Jul 2015 00:26:01 +0000

Sounds like a good thing to mark as historical.
I do see references in various places like
http://www.html5rocks.com/en/tutorials/file/filesystem/ 
https://bugbase.adobe.com/index.cfm?event=bug&id=3688345
etc.

Dave

> -----Original Message-----
> From: Uri-review [mailto:[email-masked]] On Behalf Of Chris
> Rebert
> Sent: Monday, July 13, 2015 4:44 PM
> To: [email-masked]
> Subject: [Uri-review] Review request for "filesystem" historical URI scheme
> 
> Hello,
> 
> registration of the "filesystem" historical URI scheme for review. Any feedback
> is greatly appreciated. Thanks.
> 
> Cheers,
> Chris
> 
> ********
> 
> Scheme name:  filesystem
> 
> Status:  Historical
> 
> _______________________________________________
> Uri-review mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/uri-review