Subject: [Uri-review] Request for URI schemes assigned to OPC UA

From: Randy Armstrong <[email-masked]>
Date: Mon, 22 May 2017 21:04:15 +0000

Scheme name: 

opc.tcp       :  OPC UA Connection Protocol over TCP/IP
opc.amqp  :  OPC UA Connection Protocol over AMQP
opc.wss      :  OPC UA Connection Protocol over WebSockets

We expect to add new schemes as time goes on.

Status:  permanent

Applications/protocols that use this scheme name:  

Applications which implement the OPC UA Connection Protocol defined by the OPC Unified Architecture specification:
https://opcfoundation.org/developer-tools/specifications-unified-architecture

The opc.tcp scheme has been in use in the field for about 10 years (we were unaware of the registration process).
Note that the OPC Foundation has a trademark on the term "OPC" (see US Trademark #78732560)

Contact: 
Randy Armstrong 
[email-masked]

Change controller: 
OPC Foundation 
https://opcfoundation.org/

References:  
The protocols and schemes are defined in Part 6: Mappings:
http://www.opcfoundation.org/UA/Part6/

---

From: Graham Klyne <[email-masked]>
Date: Tue, 23 May 2017 10:07:11 +0100

I have two objections here to permanent registration:

1. The specifications appear to be non-open "Note: Access to specifications and 
developer resources are available to OPC Foundation members only."

2. The use of multiple URI schemes to access the same resource goes against 
principles of web architecture [http://www.w3.org/TR/webarch/#uri-aliases].

This topic has been discussed previously on this list: see thread at [1].

[1] 
https://mailarchive.ietf.org/arch/search/?email_list=uri-review&gbt=1&index=ze2I30iloSGZxlP2vAeCWcPOWus

#g
--

On 22/05/2017 22:04, Randy Armstrong wrote:
> _______________________________________________
> Uri-review mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/uri-review
>

---

From: Randy Armstrong <[email-masked]>
Date: Tue, 23 May 2017 12:30:18 +0000

1) We use the schemes for URLs that identify multiple network paths to a single resource which is identified with a URI that uses the 'urn' scheme. It is not clear to me that registration is required for this usage. Please advise.

2) The specs is an IEC specification as well (see https://webstore.iec.ch/publication/21993 ). In addition, the text quoted is old. Anyone can download the specifications from the OPC Foundation website today.

________________________________
From: Graham Klyne <[email-masked]>
Sent: Tuesday, May 23, 2017 2:07:11 AM
To: Randy Armstrong; [email-masked]
Cc: TCB
Subject: Re: [Uri-review] Request for URI schemes assigned to OPC UA

[1]

#g
--

---

From: Ted Hardie <[email-masked]>
Date: Tue, 23 May 2017 08:34:50 -0700

On Tue, May 23, 2017 at 5:30 AM, Randy Armstrong <
[email-masked]> wrote:

> 1) We use the schemes for URLs that identify multiple network paths to a
> single resource which is identified with a URI that uses the 'urn' scheme.
> It is not clear to me that registration is required for this usage. Please
> advise.
>
>
> Would you mind identify which URN nid you are using?  I did not see one
listed here:

https://www.iana.org/assignments/urn-namespaces/urn-namespaces.xhtml#urn-namespaces-1

that was obvious.

regards,

Ted

> 2) The specs is an IEC specification as well (see https://webstore.iec.ch/
> publication/21993 ). In addition, the text quoted is old. Anyone can
> download the specifications from the OPC Foundation website today.
>
>
>
>
>
>
>
>
>
>
>
>
>
> ------------------------------
> *From:* Graham Klyne <[email-masked]>
> *Sent:* Tuesday, May 23, 2017 2:07:11 AM
> *To:* Randy Armstrong; [email-masked]
> *Cc:* TCB
> *Subject:* Re: [Uri-review] Request for URI schemes assigned to OPC UA
>
> https://mailarchive.ietf.org/arch/search/?email_list=uri-
> review&gbt=1&index=ze2I30iloSGZxlP2vAeCWcPOWus
>
> #g
> --
>
>
>
> > Applications which implement the OPC UA Connection Protocol defined by
> the OPC Unified Architecture specification:
> > The opc.tcp scheme has been in use in the field for about 10 years (we
> were unaware of the registration process).

---

From: Randy Armstrong <[email-masked]>
Date: Tue, 23 May 2017 16:03:09 +0000

The URN conforms  to:

https://tools.ietf.org/html/rfc2141

Other than that the specification leaves it up to the implementer to choose something globally unique.

Implementers also have the option of using the http scheme as the application URI.

Is there a reason to register a URN scheme when we don't care about the content of the URN?

________________________________
From: Ted Hardie <[email-masked]>
Sent: Tuesday, May 23, 2017 8:34:50 AM
To: Randy Armstrong
Cc: Graham Klyne; [email-masked]; TCB
Subject: Re: [Uri-review] Request for URI schemes assigned to OPC UA

On Tue, May 23, 2017 at 5:30 AM, Randy Armstrong <[email-masked]<mailto:[email-masked]>> wrote:

Would you mind identify which URN nid you are using?  I did not see one listed here:

that was obvious.

regards,

Ted

________________________________
From: Graham Klyne <[email-masked]<mailto:[email-masked]>>
Sent: Tuesday, May 23, 2017 2:07:11 AM
To: Randy Armstrong; [email-masked]<mailto:[email-masked]>
Cc: TCB
Subject: Re: [Uri-review] Request for URI schemes assigned to OPC UA

[1]

#g
--

On 22/05/2017 22:04, Randy Armstrong wrote:
> [email-masked]<mailto:[email-masked]>
>
> Change controller:
> OPC Foundation
> [email-masked]<mailto:[email-masked]>

_______________________________________________
Uri-review mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/uri-review

---

From: Ted Hardie <[email-masked]>
Date: Tue, 23 May 2017 09:20:57 -0700

> choose something globally unique.
RFC 3406, recently replaced by RFC 8141 go into the mechanics of URN
registration.  Briefly, global uniqueness of the NID is maintained by a
global registry or URN namespace identifiers.

> Implementers also have the option of using the http scheme as the
Is there a reason to register a URN scheme when we don't care about the
> content of the URN?

I understood your message below indicated that the URN was the canonical
name for the resources, with the individual network paths being linked to
that URN.  Did I get that wrong?

regards,

Ted

> *From:* Ted Hardie <[email-masked]>
> *Sent:* Tuesday, May 23, 2017 8:34:50 AM
> *To:* Randy Armstrong
> *Cc:* Graham Klyne; [email-masked]; TCB
>
> On Tue, May 23, 2017 at 5:30 AM, Randy Armstrong <randy.armstrong@
> opcfoundation.org> wrote:
>
>> 2) The specs is an IEC specification as well (see
>> https://webstore.iec.ch/publication/21993 ). In addition, the text
>> quoted is old. Anyone can download the specifications from the OPC
>> Foundation website today.
>>
>>
>>
>>
>>
>>
>>
>>
>>
>>
>>
>>
>>
>> https://mailarchive.ietf.org/arch/search/?email_list=uri-rev
>> iew&gbt=1&index=ze2I30iloSGZxlP2vAeCWcPOWus
>>
>> #g
>> --
>>
>>
>>

---

From: Randy Armstrong <[email-masked]>
Date: Tue, 23 May 2017 17:14:39 +0000

The Application URI is the canonical identifier, however, it is simply an opaque string. There is nothing in OPC UA depends on the content of the value.  We simply use URI syntax because is a requirement for including the identifier in the subjectAltName of an x509 v3 certificate.

At this point I would like to know what is the benefit of registering anything? It seems like the main risk is the potential for accidental conflict with other uses of the same scheme. However, we would run into the same issue if our application was turned down and we used any existing scheme such as 'http' (which is the recommendation).

Sent: Tuesday, May 23, 2017 9:20:57 AM

On Tue, May 23, 2017 at 9:03 AM, Randy Armstrong <[email-masked]<mailto:[email-masked]>> wrote:

The URN conforms  to:

RFC 3406, recently replaced by RFC 8141 go into the mechanics of URN registration.  Briefly, global uniqueness of the NID is maintained by a  global registry or URN namespace identifiers.

I understood your message below indicated that the URN was the canonical name for the resources, with the individual network paths being linked to that URN.  Did I get that wrong?

regards,

Ted

From: Ted Hardie <[email-masked]<mailto:[email-masked]>>
Sent: Tuesday, May 23, 2017 8:34:50 AM
To: Randy Armstrong
Cc: Graham Klyne; [email-masked]<mailto:[email-masked]>; TCB

that was obvious.

regards,

Ted

[1]

#g
--

---

From: Graham Klyne <[email-masked]>
Date: Wed, 24 May 2017 11:20:51 +0100

> At this point I would like to know what is the benefit of registering anything? It seems like the main risk is the potential for accidental conflict with other uses of the same scheme. However, we…

Provisional registration, for which the bar is deliberately set much lower, 
would achieve this (avoiding accidental conflict).

#g
--

---

From: Graham Klyne <[email-masked]>
Date: Fri, 26 May 2017 05:22:55 +0100

> 1) We use the schemes for URLs that identify multiple network paths to a single resource which is identified with a URI that uses the 'urn' scheme. It is not clear to me that registration is requir…

The URN as identifier seems reasonable enough.  I would suggest provisional 
registration for the "network path" schemes, which seems more appropriate for these.

As far as I can tell from the registration template, your URI "network path" 
schemes would not be used in the open Web, and as such would not be used 
publicly in the Web as identifiers.

> 2) The specs is an IEC specification as well (see https://webstore.iec.ch/publication/21993 ). In addition, the text quoted is old. Anyone can download the specifications from the OPC Foundation we…

It would help, then, to include a direct link to the publicly downloadable 
specification in the registration template.

#g
--