Subject: [Uri-review] pssession scheme registration

From: Nick van Ast <[email-masked]>
Date: Wed, 10 Jan 2018 13:42:49 +0000

LS,

Please review the following scheme registration request.

Scheme name:

pssession

Status:

Permanent

Applications/protocols that use this scheme name:

Process Studio, by Protomation BV. See: www.protomation.com.

Contact:

Name: Nick van Ast

Title: Manager Software Development & IT

Email: [email-masked]<mailto:[email-masked]>

Phone: +31 46 202 14 65

Change controller:

See Contact

References:

Attached document: 171060-M-180110-NVA-1 pssession scheme.pdf

Kind regards,
Protomation bv
In Control by Simulation
Nick van Ast
Manager Software Development & IT

Nusterweg 80
6136 KV  Sittard
The Netherlands

T +31 46 458 47 48
D +31 46 202 14 65
F +31 46 458 63 83
I www.protomation.com<http://www.protomation.com/>
E [email-masked]<mailto:[email-masked]>

The information in this message and its attachments is confidential and may be legally privileged. The message is intended solely for the addressee(s). If you are not the intended recipient, you are hereby notified that any use or reproduction in part or as a whole is strictly prohibited and may be unlawful. If you are not the intended recipient, please contact the sender by return e-mail and destroy all copies of the message

---

From: Ted Hardie <[email-masked]>
Date: Wed, 10 Jan 2018 09:03:01 -0800

Hi Nick,

Your attachment notes "Since we are experimentally rolling out the protocol
handler in our software for this scheme, the syntax is subject to change,
without backwards compatibility. "  That seems to indicate that a
provisional registration is appropriate for now, with a final, permanent
registration completed when the syntax has been determined.

Note that provisional registration will have the same general effect in
avoiding collisions by anyone who consults the list.  So I think it meets
your needs while you are finalizing the protocol.

regards,

Ted Hardie

On Wed, Jan 10, 2018 at 5:42 AM, Nick van Ast <[email-masked]>
wrote:

> *Scheme name:*
> *Status:*
> *Applications/protocols that use this scheme name:*
>
>
>
> *Contact:*
> Email: [email-masked]
>
> Phone: +31 46 202 14 65
>
>
>
> *Change controller:*
>
>
>
> See Contact
>
>
>
> *References:*
>
>
>
> *Protomation bv **In Control by Simulation*
>
> Nick van Ast
> I www.protomation.com
> E [email-masked]
>
> The information in this message and its attachments is confidential and
> may be legally privileged. The message is intended solely for the
> addressee(s). If you are not the intended recipient, you are hereby
> notified that any use or reproduction in part or as a whole is strictly
> prohibited and may be unlawful. If you are not the intended recipient,
> please contact the sender by return e-mail and destroy all copies of the
> message
>
>
>
> _______________________________________________
> Uri-review mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/uri-review
>
>

---

From: Nick van Ast <[email-masked]>
Date: Wed, 10 Jan 2018 19:52:02 +0000

Hi Ted,

Indeed, that makes sense. I wasn’t quite sure how big the difference between provisional and permanent was.

I will resubmit it with the provisional status.

Kind regards,

Nick

Sent from my Windows 10 phone

From: Ted Hardie<mailto:[email-masked]>
Sent: Wednesday, January 10, 2018 6:03 PM
To: Nick van Ast<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>; Floris Janssen<mailto:[email-masked]>
Subject: Re: [Uri-review] pssession scheme registration

Hi Nick,

Your attachment notes "Since we are experimentally rolling out the protocol handler in our software for this scheme, the syntax is subject to change, without backwards compatibility. "  That seems to indicate that a provisional registration is appropriate for now, with a final, permanent registration completed when the syntax has been determined.

Note that provisional registration will have the same general effect in avoiding collisions by anyone who consults the list.  So I think it meets your needs while you are finalizing the protocol.

regards,

Ted Hardie

On Wed, Jan 10, 2018 at 5:42 AM, Nick van Ast <[email-masked]<mailto:[email-masked]>> wrote:

LS,

Scheme name:

pssession

Status:

Permanent

Process Studio, by Protomation BV. See: www.protomation.com<http://www.protomation.com>.

Contact:

Name: Nick van Ast

Phone: +31 46 202 14 65

Change controller:

See Contact

References:

Kind regards,
Protomation bv
In Control by Simulation
Nick van Ast

Nusterweg 80
6136 KV  Sittard
The Netherlands

T +31 46 458 47 48
D +31 46 202 14 65
F +31 46 458 63 83

_______________________________________________
Uri-review mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/uri-review

---

From: Dave Thaler <[email-masked]>
Date: Wed, 10 Jan 2018 20:24:42 +0000

Agree with Ted.

Also, the registration shows a session (file/http/http) URI embedded in a possession URI.
That's fine but the current session URI text in the registration memo PDF has two issues, hopefully easy to address:

  1.  "file:///C:\ProgramData\Process Studio\Session\StartScript.pssession" is used as an example, but that is not a legal URI, as the "\" character cannot appear literally in a URI (it can be pct-encoded), but RFC 8089 specifies the file: scheme and neither RFC 8089 nor its predecessor (RFC 1738) permit "\" to appear literally in a file: path.  They instead use "/", as is used in the examples in RFC 8089 such as "file:c:/path/to/file" and "file:///c:/path/to/file". Similarly, since you mention Windows in the registration memo, Dave Risney's blog at https://blogs.msdn.microsoft.com/ie/2006/12/06/file-uris-in-windows/ says the same thing.   So to resolve this issue, the example should use a legal file: URI instead of the string shown in the registration memo now.
  2.  Some characters in a URI are not legal to appear in the path segment, and so when one URI is embedded in the path component of another URI, such characters must be either pct-encoded or disallowed.   These include "[", "]", "?", and "#".   You should state whether these are pct-encoded (meaning that you support session URIs with IPv6 literal addresses, query components, and/or fragment components), or you should state that they're disallowed.

Dave

From: Uri-review [mailto:[email-masked]] On Behalf Of Nick van Ast
Sent: Wednesday, January 10, 2018 11:52 AM
To: Ted Hardie <[email-masked]>
Cc: [email-masked]; Floris Janssen <[email-masked]>
Subject: Re: [Uri-review] pssession scheme registration

Hi Ted,

Indeed, that makes sense. I wasn't quite sure how big the difference between provisional and permanent was.

Kind regards,

Nick

Hi Nick,

LS,

Scheme name:

pssession

Status:

Permanent

Process Studio, by Protomation BV. See: www.protomation.com<https://na01.safelinks.protection.outlook.com/?url=http%3A%2F%2Fwww.protomation.com&data=02%7C01%7Cdthaler%40microsoft.com%7C9f8d72027fc74f1a0e9508d55863a949%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C636512107438380123&sdata=oyK52cKjUWwyIM1Rydoi2UmuqbsW9nbaK98vMje8%2Fy8%3D&reserved=0>.

Contact:

Name: Nick van Ast

Phone: +31 46 202 14 65

Change controller:

See Contact

References:

Kind regards,
Protomation bv
In Control by Simulation
Nick van Ast

Nusterweg 80
6136 KV  Sittard
The Netherlands

T +31 46 458 47 48
D +31 46 202 14 65
F +31 46 458 63 83
I www.protomation.com<https://na01.safelinks.protection.outlook.com/?url=http%3A%2F%2Fwww.protomation.com%2F&data=02%7C01%7Cdthaler%40microsoft.com%7C9f8d72027fc74f1a0e9508d55863a949%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C636512107438380123&sdata=Dtcgc0LCwxnM2JzbufsNRm1mbe9leBHBPQv8YoNkZfo%3D&reserved=0>
E [email-masked]<mailto:[email-masked]>

_______________________________________________
Uri-review mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/uri-review<https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Furi-review&data=02%7C01%7Cdthaler%40microsoft.com%7C9f8d72027fc74f1a0e9508d55863a949%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C636512107438380123&sdata=4v1HgaQVZm0X4ydYO9DEqBDL49mCMWf09VqwldZi6I8%3D&reserved=0>