Subject: [Uri-review] Wi-Fi Alliance permanent scheme registration - review request

From: Gaurav Jain <[email-masked]>
Date: Mon, 17 Sep 2018 20:14:19 +0000

Dear IETF URI review committee,

Wi-Fi Alliance would like to submit a scheme registration request for your review and consideration. Attached with this email you should find the following:

  1.  Scheme registration request standalone document
  2.  Latest published Wi-Fi Alliance technical specification for Device Provisioning Protocol (https://www.wi-fi.org/file/device-provisioning-protocol-specification-v10) covering the details of the protocol, URI definition, syntax, URI format and associated information

Since the registration request is for a 'permanent' registration, Wi-Fi Alliance has reviewed the requirements listed in section 3 (Requirements for Permanent Scheme Definitions) of RFC 7595 and have found that this registration request satisfies the listed requirements. As a next step, we request you to review this scheme registration request and provide your comments to us by Oct-15 2018.

Thanks and regards,

Gaurav Jain
Senior Manager, Program Technology
+1-408-400-7158 Office
+1-408-674-1441 Mobile

Wi-Fi Alliance
www.wi-fi.org<http://www.wi-fi.org/>
http://twitter.com/wifialliance
www.facebook.com/wificertified<http://www.facebook.com/wificertified>

Visit our blog, The Beacon<http://www.wi-fi.org/beacon>, for Wi-Fi industry topics and trends

---

From: Ted Hardie <[email-masked]>
Date: Tue, 18 Sep 2018 07:45:23 -0700

Hi Guarav,

Thanks for your message. Poking at the spec, the syntax of the dpp scheme
appears to be given as:
"
dpp-qr = “DPP:” [channel-list “;”] [mac “;”] [information “;”] public-key
“;;”
pkex-bootstrap-info = [information]
channel-list = “C:” class-and-channels *(“,” class-and-channels)
class-and-channels = class “/” channel *(“,” channel)
class = 1*3DIGIT
channel = 1*3DIGIT
mac = “M:” 6hex-octet ; MAC address
hex-octet = 2HEXDIG
information = “I:” *(%x20-3A / %x3C-7E) ; semicolon not allowed
public-key = “K:” *PKCHAR ; DER of ASN.1 SubjectPublicKeyInfo encoded in
“base64” as per [14]
PKCHAR = ALPHA / DIGIT / %x2b / %x2f / %x3d

The channel-list ABNF rule allows a list of IEEE 802.11 global operating
class and channel (Annex E of [2]) value pairs to
be specified. The MAC ABNF rule expresses the MAC address as a string of
six hex-octets. The information ABNF rule
allows freeform information to accompany the public key.
The bootstrapping information may be extended in future updates of the
technical specification. Devices parsing this
information should ignore unknown semicolon separated components in the
dpp-qr and pkex-bootstrap-info instantiations
to be forward compatible with such extensions."

The last paragraph indicates that this is subject to later extension, but
the syntax does not appear to be versioned and there does not appear to be
any requirement for the placement of future extensions.  My experience is
that this could well result in later interoperability problems.

There seem to be a couple of ways to make that work, if you do not
anticipate registering dpp2 and so on.  One would be to include later
extensions within the current free-form Information field, declaring a new
delimiter,which would be understood by the later version.  Reserving the
delimiter now would be useful, if that is your choice.  Another would be to
generalize this slightly so that the syntax of the scheme is simply (scheme
name) ":" followed by a series of token:*PKCHAR pairs.  You can then have a
separately updated registry of the tokens, which would have C, M, I, K,
present and which would be matched in your spec to the limitations.  As you
introduce new tokens, you can update the registry.  If you go that path, I
would suggest splitting class and channel so that they are independent
tokens, but this is a stylistic suggestion only.

My personal views only,

regards,

Ted Hardie

On Mon, Sep 17, 2018 at 1:14 PM, Gaurav Jain <[email-masked]> wrote:

> Wi-Fi Alliance would like to submit a scheme registration request for your
> review and consideration. Attached with this email you should find the
> following:
>
>    2. Latest published Wi-Fi Alliance technical specification for Device Provisioning
>    Protocol (https://www.wi-fi.org/file/device-provisioning-protocol-
>    specification-v10) covering the details of the protocol, URI
>    definition, syntax, URI format and associated information
>
>
>
> Since the registration request is for a ‘permanent’ registration, Wi-Fi
> Alliance has reviewed the requirements listed in section 3 (Requirements
> for Permanent Scheme Definitions) of RFC 7595 and have found that this
> registration request satisfies the listed requirements. As a next step, we
> request you to review this scheme registration request and provide your
> comments to us by Oct-15 2018.
>
>
>
> Thanks and regards,
>
>
>
> Gaurav Jain
> www.wi-fi.org
> www.facebook.com/wificertified
>
>
>
> Visit our blog, The Beacon <http://www.wi-fi.org/beacon>, for Wi-Fi
> industry topics and trends
>
>
>
> _______________________________________________
> Uri-review mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/uri-review
>
>

---

From: Gaurav Jain <[email-masked]>
Date: Mon, 24 Sep 2018 17:36:04 +0000

Thanks Ted for your comments and feedback.
We are discussing this within Wi-Fi Alliance and will get back to you with a response to the suggestions made.

Thanks again,

Gaurav Jain

Wi-Fi Alliance

From: Ted Hardie <[email-masked]>
Sent: Tuesday, September 18, 2018 7:45 AM
To: Gaurav Jain <[email-masked]>
Cc: [email-masked]
Subject: Re: [Uri-review] Wi-Fi Alliance permanent scheme registration - review request

Hi Guarav,

Thanks for your message. Poking at the spec, the syntax of the dpp scheme appears to be given as:
"
dpp-qr = “DPP:” [channel-list “;”] [mac “;”] [information “;”] public-key “;;”
pkex-bootstrap-info = [information]
channel-list = “C:” class-and-channels *(“,” class-and-channels)
class-and-channels = class “/” channel *(“,” channel)
class = 1*3DIGIT
channel = 1*3DIGIT
mac = “M:” 6hex-octet ; MAC address
hex-octet = 2HEXDIG
information = “I:” *(%x20-3A / %x3C-7E) ; semicolon not allowed
public-key = “K:” *PKCHAR ; DER of ASN.1 SubjectPublicKeyInfo encoded in “base64” as per [14]
PKCHAR = ALPHA / DIGIT / %x2b / %x2f / %x3d

The channel-list ABNF rule allows a list of IEEE 802.11 global operating class and channel (Annex E of [2]) value pairs to
be specified. The MAC ABNF rule expresses the MAC address as a string of six hex-octets. The information ABNF rule
allows freeform information to accompany the public key.
The bootstrapping information may be extended in future updates of the technical specification. Devices parsing this
information should ignore unknown semicolon separated components in the dpp-qr and pkex-bootstrap-info instantiations
to be forward compatible with such extensions."

The last paragraph indicates that this is subject to later extension, but the syntax does not appear to be versioned and there does not appear to be any requirement for the placement of future extensions.  My experience is that this could well result in later interoperability problems.

There seem to be a couple of ways to make that work, if you do not anticipate registering dpp2 and so on.  One would be to include later extensions within the current free-form Information field, declaring a new delimiter,which would be understood by the later version.  Reserving the delimiter now would be useful, if that is your choice.  Another would be to generalize this slightly so that the syntax of the scheme is simply (scheme name) ":" followed by a series of token:*PKCHAR pairs.  You can then have a separately updated registry of the tokens, which would have C, M, I, K,  present and which would be matched in your spec to the limitations.  As you introduce new tokens, you can update the registry.  If you go that path, I would suggest splitting class and channel so that they are independent tokens, but this is a stylistic suggestion only.

My personal views only,

regards,

Ted Hardie

On Mon, Sep 17, 2018 at 1:14 PM, Gaurav Jain <[email-masked]<mailto:[email-masked]>> wrote:
Dear IETF URI review committee,

Since the registration request is for a ‘permanent’ registration, Wi-Fi Alliance has reviewed the requirements listed in section 3 (Requirements for Permanent Scheme Definitions) of RFC 7595 and have found that this registration request satisfies the listed requirements. As a next step, we request you to review this scheme registration request and provide your comments to us by Oct-15 2018.

Thanks and regards,

Gaurav Jain

Wi-Fi Alliance

_______________________________________________
Uri-review mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/uri-review