Subject: Re: [Uri-review] AD sponsorship

From: Timothy Mcsweeney <[email-masked]>
Date: Thu, 15 Oct 2020 12:36:43 -0400 (EDT)

Barry,

>Sometimes are specs are not clear on some points; we know that. This

>isn't one of those cases: the syntax of a URI is very clearly

>specified.

Why don't you do a tiny update for RFC3986 like Ted did for RFC3405 and make it abundantly clear that only the colon can be used for any URI?  Or better yet, I will and you can sponsor it.  That be ok with you?

Tim

I cc'd the people that I think would be agreeable to the idea to get some early traction.

---

From: "Henry S. Thompson" <[email-masked]>
Date: Thu, 15 Oct 2020 18:21:46 +0100

Timothy Mcsweeney writes:

> Barry [wrote:]

> Why don't you do a tiny update for RFC3986 like Ted did for RFC3405 and
> make it abundantly clear that only the colon can be used for any URI?
> Or better yet, I will and you can sponsor it.  That be ok with you?
> Tim

Count me out.  3986 as published leaves no room for doubt that the ABNF
is normative, and the ABNF requires what is elsewhere called the "scheme
delimiter", that is, ":".

Two quotes from 3986 may help reinforce this point:

  "The URI syntax defines a grammar that is a superset of all
   valid URIs"

  "The complete URI syntax is collected in Appendix A."

ht
-- 
       Henry S. Thompson, School of Informatics, University of Edinburgh
      10 Crichton Street, Edinburgh EH8 9AB, SCOTLAND -- (44) 131 650-4440
                Fax: (44) 131 650-4587, e-mail: [email-masked]
                       URL: http://www.ltg.ed.ac.uk/~ht/
 [mail from me _always_ has a .sig like this -- mail without it is forged spam]

The University of Edinburgh is a charitable body, registered in
Scotland, with registration number SC005336.

---

From: Peter Saint-Andre <[email-masked]>
Date: Thu, 15 Oct 2020 11:45:09 -0600

>   "The complete URI syntax is collected in Appendix A."

Agreed, I see no reason to update RFC 3986 on this point.

Peter