Subject: Re: [Uri-review] URI Scheme "ves:"

From: Jim Zubov <[email-masked]>
Date: Tue, 21 Dec 2021 08:40:29 -0500

On December 21, 2021 8:27:57 AM EST, Wade Benford <[email-masked]> wrote:
> In your pdf, I see where you say: 
>
> Unescaped “?” and “#” should be treated as URI part separators, for 
>compatibility with any possible future revisions. 
>
>
> AFAIK RFC 3986 is not going to have revisions, or where you speaking of 
>future revisions of your "ves" specification? 

Yes I'm taking about future revisions of VES uri specs.

---

From: Jim Zubov <[email-masked]>
Date: Tue, 21 Dec 2021 09:12:42 -0500

Between the scheme and the path... Well I think it's equivalent to a null path. Which is illegal in the VES scheme, at least in the present version of it.

On December 21, 2021 9:05:42 AM EST, Wade Benford <[email-masked]> wrote:
>
>> On 12/21/2021 8:40 AM Jim Zubov <[email-masked]> wrote:
>> 
>> 
>Will that include using those separators between the scheme and path?
>(Which btw, I don't nessecarily have a problem with but there was another guy on here that was met with substantial resistance.)

---

From: Wade Benford <[email-masked]>
Date: Tue, 21 Dec 2021 09:45:11 -0500 (EST)

I was asking about the future versions you mentioned in the pdf.   It sounds like you have given it some forethought and I was hoping you could elaborate on your future use of the separators incase your next version comes out immediately after you receive scheme assignment from IANA.

> On 12/21/2021 9:12 AM Jim Zubov <[email-masked]> wrote:
> 
>

---

From: Jim Zubov <[email-masked]>
Date: Tue, 21 Dec 2021 10:04:44 -0500

I envision future possible use consistent with the common url semantics - '?' is a query separator followed by name=value&..., and '#' is followed by a strictly local fragment string. I just wanted to explicitly state that the separator characters, when unescaped, should never be treated as a part of improperly encoded path.

---

From: Wade Benford <[email-masked]>
Date: Tue, 21 Dec 2021 10:11:37 -0500 (EST)

> On 12/21/2021 10:04 AM Jim Zubov <[email-masked]> wrote:
> I just wanted to explicitly state that the separator characters, when unescaped, should never be treated as a part of improperly encoded path.
> 

So you won't ever use "ves#" instead of "ves:" right?

---

From: Jim Zubov <[email-masked]>
Date: Tue, 21 Dec 2021 10:15:06 -0500

No, I believe it's a gross violation of the RFC to use the scheme name without ':'

---

From: Wade Benford <[email-masked]>
Date: Tue, 21 Dec 2021 10:32:56 -0500 (EST)

Ata boy Jim! Thats what I wanted to here. "A gross violation."
Although it strange to hear it coming from the guy who's specification explicitly states

"I purposely specified some permitted violations of URI syntax" 

But whatever.  Make it up as you go along, right Jim!  

> On 12/21/2021 10:15 AM Jim Zubov <[email-masked]> wrote:
> 
>

---

From: Jim Zubov <[email-masked]>
Date: Tue, 21 Dec 2021 10:45:55 -0500

There are violations like stripped percent encoding while the uri is still unambiguously interpretable, and then there are violations of the uri concept altogether.
And, I removed any allowances for stripped percent encoding in the later revision.