Subject: RE: Proposed amendment to language of draft-ietf-url-procedures

From: Ian King <[email-masked]>
Date: Sun, 12 Sep 1999 22:36:48 -0700

Then what do you suggest to provide collision management, identification and
interoperability in URL schemes?  I'd be thrilled if you have a viable
alternative to offer.  But a lot of very intelligent folks have discussed
this matter for a long time, and this is what they came up with.  I'd be
delighted if we did not need process around this, and these matters could
somehow "just work out".  But the consensus is that this just is not the
case, at least not today.  

If you feel you have a viable alternative, that would prevent namespace
collision, encourage development of interoperable standards, and provide
sensible management of this highly visible namespace -- I'm all ears.  

Ian King <[email-masked]>
Speech Product Group/Intelligent Interface Technologies
MICROSOFT CORPORATION

-----Original Message-----
From: Masataka Ohta [mailto:[email-masked]]
Sent: Sunday, September 12, 1999 2:26 AM
To: [email-masked]
Cc: [email-masked]; [email-masked]; Ian King;
[email-masked]; [email-masked]; [email-masked];
[email-masked]
Subject: Re: Proposed amendment to language of draft-ietf-url-procedures

Keith;

> > Are you saying that IETF is infallible and has never published
> > any bad ideas of its own?
> 
> of course not.  but just because IETF can make its own mistakes, 
> doesn't mean it should lend its credibility to others' mistakes.

OK. So, it's better if IETF is involved in less technical judgements.

No informational nor standard track RFCs should be required for
mere URL names.

					'¾"c�@�¹�F
					[email-masked]

---

From: Masataka Ohta <[email-masked]>
Date: Mon, 13 Sep 99 16:21:24 JST

Ian;

> interoperability in URL schemes?

Huh?

How, do you think, IANA is managing collisons, identifications
and interoperability of TCP port numbers?

> sensible management of this highly visible namespace

DNS has a purely technical mechanism to enforce unique assignment
through well known single set of root servers, even which can be
ignored by local conventions.

URL does not.

> -- I'm all ears.  

You only have to see the real world.

> But a lot of very intelligent folks have discussed
> this matter for a long time, and this is what they came up with.

You seems to have a very strange definition of intelligence.

							Masataka Ohta

---

From: Masataka Ohta <[email-masked]>
Date: Mon, 13 Sep 99 21:02:26 JST

Ian;

> case, at least not today.  

The bottomline is that it is really difficult to solve a problem
when the problem does not exist.

							Masataka Ohta