Subject: Re: Application for formal URN NID

From: "Hideki Ohtaka" <[email-masked]>
Date: Tue, 23 Aug 2005 19:48:45 +0900

Dear Mr. Daigle,

Thank you very much for your suggestions.
I have added the explanation about "Namespace Considerations" and "Community Considerations".
Please confirm if further modifications are necessary. 
I will update the document accordingly.

Best regards,
Hideki Ohtaka 

----- Original Message ----- 
From: "Leslie Daigle" <[email-masked]>
To: "Hideki Ohtaka" <[email-masked]>
Cc: <[email-masked]>
Sent: Thursday, June 30, 2005 1:08 AM
Subject: Re: Application for formal URN NID

> Howdy,
> 
> The "Namespace Considerations" and "Community Considerations" sections
> still miss the mark, unfortunately.
> 
> "Namespace Considerations" should include a discussion of why there
> is no other existing namespace that can be applied to the purpose,
> and therefore a new one must be created.
> 
> "Community consideratios" should include a discussion of what *global*
> Internet community members get from the registration of this
> namespace.  As written here, it is not clear whether (for example)
> any developers can create URNs in this namespace, or write
> software that will use and resolve them, etc.
> 
> Best regards,
> Leslie.
> P.S.:  I am about to unplug for a 2 week vacation, so I will be
> unavailable to respond (if applicable) for some time...
> 
> Hideki Ohtaka wrote:
>> Attached is an Internet draft of the URN Namespace request for “Professional-Plug-in”.
>> Could you please review it ? If  there are something I should modify, please let me know. 
>> 
>> Best regards,
>> Hideki Ohtaka
>> 
>> 
>> ------------------------------------------------------------------------
>> 
>> Internet-draft
>> draft-ohtaka-urn-P2-00.txt
>>                                                                 H.Ohtaka
>>                                                             27 June 2005
>> 
>>             A Uniform Resource Name (URN) Namespace for
>>                        Professional-Plug-in
>> 
>> 
>> Status of this Memo
>> 
>>    By submitting this Internet-Draft, each author represents that any    
>>    applicable patent or other IPR claims of which he or she is aware have 
>>    been or will be disclosed, and any of which he or she becomes aware will 
>>    be disclosed, in accordance with Section 6 of BCP 79.
>> 
>> Copyright Notice
>> 
>>    Copyright (C) The Internet Society (2005).  All Rights Reserved.
>> 
>> Abstract
>> 
>>    This document describes a Uniform Resource Name (URN) namespace for
>>    naming persistent resources as eXtensible Markup Language (XML) 
>>    Schemas in Professional-Plug-in system.
>> 
>> Table of Contents 
>> 
>>    1. Introduction...................................................2 
>>    2. Namespace Definition Template..................................2 
>>       2.1. Namespace ID:.............................................2 
>>       2.2. Registration Information:.................................2 
>>       2.3. Declared registrant of the namespace:.....................2 
>>       2.4. Declaration of structure:.................................3 
>>       2.5. Relevant ancillary documentation:.........................3 
>>       2.6. Identifier uniqueness considerations:.....................3 
>>       2.7. Identifier persistence considerations:....................3 
>>       2.8. Process of identifier assignment:.........................3 
>>       2.9. Process for identifier resolution:........................3 
>>       2.10. Rules for Lexical Equivalence:...........................3 
>>       2.11. Conformance with URN Syntax:.............................4 
>>       2.12. Validation mechanism:....................................4 
>>       2.13. Scope....................................................4 
>>    3.Formal Syntax...................................................4 
>>    4.Security Considerations.........................................4 
>>    5.Namespace Considerations........................................4 
>>    6.Community Considerations........................................5 
>>    7 IANA Considerations.............................................5 
>>    8 Normative References............................................5 
>>    9. Author's Addresses.............................................5 
>>   10.Copyright Statement.............................................5 
>>   11.Acknowledgment..................................................5 
>>    
>> 1.  Introduction
>> 
>>    Professional-Plug-in is a system which defines a solid-state storage 
>>    media and a variety of multimedia content stored on the media. 
>>    The Professional-Plug-in is applicable for content acquisition systems, 
>>    editing systems and servers as well as for the transfer of content files. 
>>    In order to assure interoperability among different vendors, 
>>    specifications which define a video, audio essence and associated 
>>    metadata have been established. The metadata contains information about 
>>    the structure or parameters of the video, audio essences and also contains 
>>    additional information describing the essences. The  metadata is 
>>    expressed with an XML specified by an XML schema. Therefore, 
>>    a Uniform Resource Name (URN) specified in this draft is applied to assign 
>>    a persistent resource for namespace to identify each XML schema. 
>> 
>> 2.  Specification Template
>> 
>>    This namespace specification is for a formal namespace.
>> 
>> 2.1 Namespace ID:
>> 
>>    "Professional-Plug-in"
>> 
>> 2.2 Registration Information:
>> 
>>    Version: 1
>>    Date: 2005-6-27
>> 
>> 2.3 Declared registrant of the namespace:
>> 
>>    Name:           Hideki Ohtaka
>>    Organization    Matsushiota Electcic Industrial Co., Ltd.
>>    Address:        2-15 Matsuba-cho, Kadoma City, Osaka 571-8503, Japan            
>>    Phone:          +81-6-6905-4666
>>    Email:          [email-masked]
>> 
>> 2.4 Declaration of structure:
>> 
>>    URN assigned for Professional-Plug-in has the following structure.
>> 
>>    URN:schemas-Professional-Plug-in:<system name>:<assigned string>
>> 
>>    <system name>     : Name of the system which this URN is applied to.
>>                        where <system name> is compliant to the URN 
>>                        Syntax requirements ([RFC2141]).
>> 
>>    <assigned string> : Defined by system name holders  
>>                        where <system name> is compliant to the URN 
>>                        Syntax requirements ([RFC2141]).
>> 
>> 2.5 Relevant ancillary documentation:
>> 
>>    Proposed SMPTE RP gContent Specification on a Solid-State Media 
>>    card - for DV/DV-based Essencehdefines the XML schema specified 
>>    by the namespace using the requested NID. 
>> 
>> 2.6 Identifier uniqueness considerations:
>> 
>>    Uniqueness is guaranteed as long as the system name is never
>>    reassigned and the assigned string is never reassigned for a given system  
>>    name.
>> 
>> 2.7 Identifier persistence considerations:
>> 
>>    Persistence of identifiers is dependent upon the persistence of the system 
>>    name assignment by system name holders.
>> 
>> 2.8 Process of identifier assignment:
>> 
>>    Assignment of these URNs is delegated to individual system name holders. 
>>    The holder of the system name registration is required to maintain an 
>>    entry. 
>> 
>> 2.9 Process of identifier resolution:
>> 
>>    Holders of system names are responsible for operating or delegating 
>>    resolution servers for the system in which they have assigned URNs.
>> 
>> 2.10 Rules for Lexical Equivalence:
>> 
>>    The entire URN is case-insensitive.
>> 
>> 2.11 Conformance with URN Syntax:
>> 
>>    No special considerations. 
>>    URNs in this namespace conform to RFC 2141.
>> 
>> 2.12 Validation mechanism:
>> 
>>    None specified.
>> 
>> 2.13 Scope:
>> 
>>    Global
>> 
>>    The following is an example of the URN.
>> 
>> 3.  Examples
>> 
>>    URN:schemas-Professional-Plug-in:P2:ClipMetadata:v2.0
>> 
>>    <system name> P2: Specifies the system 
>>    <assigned string> ClipMetadata: Specifies the type of metadata
>>    <assigned string> v2.0: Specifies the version of this schema 
>> 
>> 4.  Namespace Considerations
>> 
>> 4.1 URN assignment procedures:
>> 
>>    The individual URNs shall be assigned through the process of
>>    development of XML schema for metadata.
>> 
>> 4.2 URN resolution/delegation:
>> 
>>    The resolution and delegation shall be determined through the
>>    process of development of XML schema for metadata.
>> 
>> 4.3 Type of resources to be identified:
>> 
>>    Types of resources to be identified include XML schema for metadata
>> 
>> 5.  Community Considerations
>> 
>> 5.1 Open assignment and use of identifiers within the namespace:
>> 
>>    In the development of Professional-Plug-in systems, an XML schema for 
>>    metadata can be defined depending on applications and an identifier can 
>>    be assigned under the Professional-Plug-in namespace.
>>       
>> 6.  Security Considerations
>> 
>>    There are no additional security considerations other than those
>>    normally associated with the use and resolution of URNs in general.
>> 
>> 7.  IANA Considerations
>> 
>>    The IANA has registered formal URN namespace XXXX, to 
>>    Professional-Plug-in within the IANA registry of URN NIDs.
>> 
>> 8.  Normative References
>> 
>>    [RFC2141] Moats, R., "URN Syntax", RFC 2141, May 1997.
>> 
>> 9.  Author's Address
>> 
>>    Hideki Ohtaka
>>    Matsushita Electcic Industrial Co., Ltd.
>>    2-15 Matsuba-cho, Kadoma City, Osaka 571-8503, Japan
>>    Phone:  +81-6-6905-4666
>>    Email:  [email-masked]
>> 
>> 10.  Copyright Statement
>> 
>>    Copyright (C) The Internet Society (2005). 
>> 
>>    This document is subject to the rights, licenses and restrictions 
>>    contained in BCP 78, and except as set forth therein, the authors
>>    retain all their rights.
>> 
>>    This document and the information contained herein are provided on an
>>    "AS IS" basis and THE CONTRIBUTOR, THE ORGANIZATION HE/SHE REPRESENTS
>>    OR IS SPONSORED BY (IF ANY), THE INTERNET SOCIETY AND THE INTERNET
>>    ENGINEERING TASK FORCE DISCLAIM ALL WARRANTIES, EXPRESS OR IMPLIED,
>>    INCLUDING BUT NOT LIMITED TO ANY WARRANTY THAT THE USE OF THE
>>    INFORMATION HEREIN WILL NOT INFRINGE ANY RIGHTS OR ANY IMPLIED
>>    WARRANTIES OF MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE.
>> 
>> 11. Acknowledgment 
>> 
>>    Funding for the RFC Editor function is currently provided by the 
>>    Internet Society.

---

From: "Dave Tessman" <[email-masked]>
Date: Mon, 29 Aug 2005 11:11:53 -0700

Suggestions and comments

>1. Therefore,
>   a Uniform Resource Name (URN) specified in this document is applied to
> assign
     a persistent resource for the namespace to identify each XML schema.
     a persistent resource within the namespace to identify each XML schema.
     a persistent resource to identify each XML schema within the namespace.

2.1 While "Professional-Plug-in" is nicely descriptive, it may be better to
use an abbreviation ('ppi' comes to mind). However, to each his own.

2.4 It would be nice to see the structure declared in ABNF.

>   reassigned and the assigned string is never reassigned for a given
How are system name holders assigned?
I am unclear on the chain of authority to ensure URN uniqueness.

>4.1 ...so the metadata specified with an XML schema is closely assoicated
>with.. .

           so the metadata specified with an XML schema is closely
associated with.. .

2.9 It would not be helpful if each system name holder winds up assigning a
unique method of URN resolution.

Please take a look at the "fdc" URN specification (status is "approved" and
is awaiting an RFC number assignment).

http://www.ietf.org/internet-drafts/draft-dtessman-urn-namespace-federated-content-03.txt

It uses the resolution mechanism defined within RFC 2169.  Perhaps something
like that would be helpful.

Best regards,
Dave