Subject: Application for formal URN NID

From: "Hideki Ohtaka" <[email-masked]>
Date: Mon, 20 Nov 2006 19:13:23 +0900

Attached is an application for a formal URN NID.
I would like to request URN Namespace for“Professional-Plug-in”.
Could you please review the internet draft ?  
I look forward to hearing feedback from the URN mail-list members.

Best regards,
Hideki Ohtaka

---

From: Leslie Daigle <[email-masked]>
Date: Mon, 27 Nov 2006 14:55:38 -0500

Hi,

I'm not finding evidence of this document in the Internet-Drafts
repository.

Before we can review it, would you please be sure to submit
it there (as an -00 version, btw).  See

http://www.ietf.org/ietf/1id-guidelines.html

Thanks!

Leslie.

Hideki Ohtaka wrote:
> ------------------------------------------------------------------------
> 
> Internet-draft
> draft-ohtaka-urn-P2-03.txt
>                                                                 H.Ohtaka
>                                                             8 November 2006
> 
>             A Uniform Resource Name (URN) Namespace for
>                        Professional-Plug-in
> 
> 
> Status of this Memo
> 
>    By submitting this Internet-Draft, each author represents that any    
>    applicable patent or other IPR claims of which he or she is aware have 
>    been or will be disclosed, and any of which he or she becomes aware will 
>    be disclosed, in accordance with Section 6 of BCP 79.
> 
> Copyright Notice
> 
>    Copyright (C) The Internet Society (2005).  All Rights Reserved.
> 
> Abstract
> 
>    This document describes a Uniform Resource Name (URN) namespace for
>    naming persistent resources as eXtensible Markup Language (XML) 
>    Schemas in Professional-Plug-in system.
> 
> Table of Contents 
> 
>    1. Introduction...................................................2 
>    2. Namespace Definition Template..................................2 
>       2.1. Namespace ID:.............................................2 
>       2.2. Registration Information:.................................2 
>       2.3. Declared registrant of the namespace:.....................2 
>       2.4. Declaration of structure:.................................3 
>       2.5. Relevant ancillary documentation:.........................3 
>       2.6. Identifier uniqueness considerations:.....................3 
>       2.7. Identifier persistence considerations:....................3 
>       2.8. Process of identifier assignment:.........................3 
>       2.9. Process for identifier resolution:........................3 
>       2.10. Rules for Lexical Equivalence:...........................3 
>       2.11. Conformance with URN Syntax:.............................4 
>       2.12. Validation mechanism:....................................4 
>       2.13. Scope....................................................4 
>    3.Formal Syntax...................................................4 
>    4.Security Considerations.........................................4 
>    5.Namespace Considerations........................................4 
>    6.Community Considerations........................................5 
>    7 IANA Considerations.............................................5 
>    8 Normative References............................................5 
>    9. Author's Addresses.............................................5 
>   10.Copyright Statement.............................................5 
>   11.Acknowledgment..................................................5 
>    
> 1.  Introduction
> 
>    Professional-Plug-in is a system which defines a solid-state storage 
>    media and a variety of multimedia contents stored on this storage media. 
>    The Professional-Plug-in is applicable for content acquisition systems, 
>    editing systems and servers as well as for transfer of content files. 
>    In order to assure interoperability among different vendors, 
>    specifications that define a video, audio essence and associated 
>    metadata have been established. The metadata contains information about 
>    the structure or parameters of the video, audio essences and also contains 
>    additional information describing the essences. The metadata is 
>    expressed with an XML specified by an XML schema. Therefore, 
>    a Uniform Resource Name (URN) specified in this document is applied to assign 
>    a persistent resource for the namespace to identify each XML schema. 
> 
> 2.  Specification Template
> 
>    This namespace specification is for a formal namespace.
> 
> 2.1 Namespace ID:
> 
>    "Professional-Plug-in"
> 
> 2.2 Registration Information:
> 
>    Version: 1.3
>    Date: 2006-11-8
> 
> 2.3 Declared registrant of the namespace:
> 
>    Name:           Hideki Ohtaka
>    Organization    Matsushita Electric Industrial Co., Ltd.
>    Address:        2-15 Matsuba-cho, Kadoma City, Osaka 571-8503, Japan            
>    Phone:          +81-6-6905-4666
>    Email:          [email-masked]
> 
> 2.4 Declaration of structure:
> 
>    URN assigned for Professional-Plug-in has the following structure.
> 
>    URN:schemas-Professional-Plug-in:NSS
> 
>    The NSS shall comply with the following ABNF specification.
> 
>    NSS             = SystemName ":" AssignedString ":" AssignedString ":" ----
>    SystemName      = ALPHA / DIGIT / other
>    AssignedString  = ALPHA / DIGIT / other
>    other           = "-" / "_" / "."
>    Note: Another character may not be the first character.
>   
> 2.5 Relevant ancillary documentation:
> 
>    Extensible Markup Language (XML) 1.0 (Third Edition), W3C Recommendation 04 
>    February 2004
> 
>    Namespaces in XML, W3C Recommendation, 14,January 1999
> 
>    SMPTE RP 2002 Content Specification on Solid-State Media Card 
>    - for DV/DV-based Essence : This document defines the XML schema specified by
>    the namespace using the requested NID. 
> 
> 2.6 Identifier uniqueness considerations:
> 
>    Developers who wish to define a new system name under this proposed NID 
>    for their applications must ask the URN administrator (Matsushita Electric) to 
>    assign a system name as NSS. The URN administrator confirms that the new system name is unique 
>    against existing system names, and then assigns and registers the new system name as 
>    NSS.
> 
> 2.7 Identifier persistence considerations:
> 
>    Persistence of identifiers is dependent upon the persistence of the system 
>    name assignment by the URN administrator.
> 
> 2.8 Process of identifier assignment:
> 
>    Request for the assignment of a new system name including objectives of the request 
>    must be sent to the URN administrator and the URN administrator assigns the new system name as 
>    NSS.
> 
> 2.9 Process of identifier resolution:
>    
>    The URN administrator will maintain an index of assigned URNs
>    That index will map URNs to XML schema specifications in the Web page.
>   
> 2.10 Rules for Lexical Equivalence:
>  
>    The entire URN is case-insensitive.
> 
> 2.11 Conformance with URN Syntax:
> 
>    No special considerations. 
>    URNs in this namespace conform to RFC 2141.
> 
> 2.12 Validation mechanism:
> 
>    None specified.
> 
> 2.13 Scope:
> 
>    Global
> 
>    The following is an example of the URN.
> 
> 3.  Examples
> 
>    URN:schemas-Professional-Plug-in:P2:ClipMetadata:v2.0
> 
>    System name     = P2: Specifies the system 
>    Assigned string = ClipMetadata: Specifies the type of metadata
>                                    ClipMetadata means the Metadata schema related to a Clip  
>    Assigned string = v2.0:Specifies the version of this schema 
> 
> 4.  Namespace Considerations
> 
> 4.1 URN assignment procedures:
> 
>    Existing URNs are intended to be assigned as identifiers for particular 
>    applications or particular systems. The purpose of these URNs and its assignment 
>    procedure is clearly defined in each RFC document. Meanwhile, this requested URN 
>    is intended to be used for a namespace to identify an XML schema in Professional-Plug-in 
>    system so the metadata specified with an XML schema is closely associated with 
>    its individual system and applications. 
>    The existing URNs, however, do not provide any alternative namespaces which 
>    represent the metadata in the Professional-Plug-in system. 
>    Therefore, a new URN assignment is required and individual URNs shall be assigned
>    through the process of development of each XML schema.  
> 
> 4.2 URN resolution/delegation:
> 
>    The resolution and delegation shall be determined through the process of 
>    development of an XML schema for metadata.
> 
> 4.3 Type of resources to be identified:
> 
>    Types of resources to be identified include an XML schema for metadata
> 
> 5.  Community Considerations
> 
> 5.1 Open assignment and use of identifiers within the namespace:
> 
>   Professional-Plug-in system can be applicable for content acquisition 
>   systems, editing systems and so on. Therefore, any developers who wish to 
>   define an XML schema depending on each application can apply for a URN 
>   under the Professional-Plug-in namespace. The proposed URN shall be reviewed 
>   among developers of the Professional-Plug-in system, and shall be assigned and 
>   presented as a new URN under this namespace. 
>       
> 6.  Security Considerations
> 
>    There are no additional security considerations other than those
>    normally associated with the use and resolution of URNs in general.
> 
> 7.  IANA Considerations
> 
>    The IANA has registered formal URN namespace XXXX, to 
>    Professional-Plug-in within the IANA registry of URN NIDs.
> 
> 8.  Normative References
> 
>    [RFC2141] Moats, R., "URN Syntax", RFC 2141, May 1997.
> 
> 9.  Author's Address
> 
>    Hideki Ohtaka
>    Matsushita Electcic Industrial Co., Ltd.
>    2-15 Matsuba-cho, Kadoma City, Osaka 571-8503, Japan
>    Phone:  +81-6-6905-4666
>    Email:  [email-masked]
> 
> 10.  Copyright Statement
> 
>    Copyright (C) The Internet Society (2005). 
> 
>    This document is subject to the rights, licenses and restrictions 
>    contained in BCP 78, and except as set forth therein, the authors
>    retain all their rights.
> 
>    This document and the information contained herein are provided on an
>    "AS IS" basis and THE CONTRIBUTOR, THE ORGANIZATION HE/SHE REPRESENTS
>    OR IS SPONSORED BY (IF ANY), THE INTERNET SOCIETY AND THE INTERNET
>    ENGINEERING TASK FORCE DISCLAIM ALL WARRANTIES, EXPRESS OR IMPLIED,
>    INCLUDING BUT NOT LIMITED TO ANY WARRANTY THAT THE USE OF THE
>    INFORMATION HEREIN WILL NOT INFRINGE ANY RIGHTS OR ANY IMPLIED
>    WARRANTIES OF MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE.
> 
> 11. Acknowledgment 
> 
>    Funding for the RFC Editor function is currently provided by the 
>    Internet Society.