Subject: Re: "Status of I-D Submission: draft-evain-ebu-urn-01.txt" - Request for publication as 'informational'

From: Leslie Daigle <[email-masked]>
Date: Wed, 09 Jan 2008 13:23:16 -0500

Hi,

Sorry, I thought I had sent this some time ago, but it seems
not to have gone out.   Looking back in my archive, I think
I confused myself because of structural similarities
to the DVB document (which had the same issue, noted
below).   Consider these now comments on the
-02 document.

The Namespace Considerations should have sentences that explain
why no existing URN namespace is adequate, and a new
formal NID should be assigned.  Per RFC3406, the specific
requirement of this section is:

"  [...] a "Namespace Considerations" section, which
    outlines the perceived need for a new namespace (i.e., where existing
    namespaces fall short of the proposer's requirements).
"

The current document does not make a clear statement as
to why a new namespace is needed.

Check out the first para in that section of the updated
DVB document draft-adolf-dvb-urn (-03 as of this moment).

Also, this document shares an issue that was flagged in
the DVB document in last call.  Your document says:

"   Identifier uniqueness considerations:

       The EBU will establish unique identifiers as appropriate.

       Uniqueness is guaranteed as long as the assigned string is never
       reassigned.
"

The second sentence is tautologically true.  If what you
mean is that you will ensure an assignment process such
that they don't get reassigned, you must say that.

Similarly,

"   Identifier persistence considerations:

       The European Broadcasting Union (EBU) is committed to maintaining
       the accessibility and persistence of all resources that are
       officially assigned URNs by the organization.  Persistence of
       identifiers is dependent upon suitable delegation at the level of
       "{category}"s, and persistence of category assignment."

If the intention is to ensure that {category}s are suitably
delegated and persistent, through EBU control of assignment,
you should say that.

Thanks,
Leslie.

Evain, Jean-Pierre wrote:
> Dear urn-nid editor,
>  
> please find attached the draft-evain-ebu-urn-01.txt  for which I have 
> requested publication as 'informational.
>  
> Draft ID 
> reference: http://www.ietf.org/internet-drafts/draft-evain-ebu-urn-01.txt.
>  
> Thanks in advance,
>  
> Best regards,
>  
> Jean-Pierre Evain
> 
> ------------------------------------------------------------------------
> 
> * ************************************************** This email and any 
> files transmitted with it are confidential and intended solely for the 
> use of the individual or entity to whom they are addressed. If you have 
> received this email in error, please notify the system manager. This 
> footnote also confirms that this email message has been swept by the 
> mailgateway ************************************************** *
> 

-- 

-------------------------------------------------------------------
"Reality:
      Yours to discover."
                                 -- ThinkingCat
Leslie Daigle
[email-masked]
-------------------------------------------------------------------

---

From: "Evain, Jean-Pierre" <[email-masked]>
Date: Thu, 10 Jan 2008 10:07:25 +0100

Hello Leslie,

Thanks for the suggestions.

I'll look at it a.s.a.p.  I am very busy right now and flying to Seattle on
Saturday.

Regards,

jean-Pierre

-----Original Message-----
From: Leslie Daigle [mailto:[email-masked]] 
Sent: mercredi, 9. janvier 2008 19:23
To: Evain, Jean-Pierre
Cc: [email-masked]; Lisa Dusseault
Subject: Re: "Status of I-D Submission: draft-evain-ebu-urn-01.txt" -
Request for publication as 'informational'

Hi,

The Namespace Considerations should have sentences that explain why no
existing URN namespace is adequate, and a new formal NID should be assigned.
Per RFC3406, the specific requirement of this section is:

Similarly,

If the intention is to ensure that {category}s are suitably delegated and
persistent, through EBU control of assignment, you should say that.

Thanks,
Leslie.

--

---

From: "Evain, Jean-Pierre" <[email-masked]>
Date: Fri, 18 Jan 2008 11:54:42 +0100

Dear Leslie,

Thanks for the comments.  Does the attached document address your concerns?
If not, please do not hesitate to let me know.

Best regards,

Jean-Pierre

-----Original Message-----
From: Leslie Daigle [mailto:[email-masked]] 
Sent: mercredi, 9. janvier 2008 19:23
To: Evain, Jean-Pierre
Cc: [email-masked]; Lisa Dusseault
Subject: Re: "Status of I-D Submission: draft-evain-ebu-urn-01.txt" -

Hi,

Similarly,

Thanks,
Leslie.

--