Subject: RE: Submission of URN registration request template (cablelabs)

From: Sumanth Channabasappa <[email-masked]>
Date: Tue, 8 Feb 2011 14:44:52 -0700

Ted,

Sorry about the tardy response. The CANN specification is publicly available for viewing, and we can document this information. 

Here's the proposed new text:

---
5. Community Considerations

   The CableLabs specifications are publicly available or licensed to
   manufacturers on a nondiscriminatory basis.  CableLabs will maintain
   the allocation of resources for the "cablelabs" NID within the following
   specification: [CANN], which will be publicly available for viewing. 
   CableLabs will also maintain the corresponding specifications 
   where the registered resources are referenced or used. 
---

Ted, All,
Please let us know if there are any other comments or suggestions.

Thanks!
- S 

-----Original Message-----
From: Ted Hardie [mailto:[email-masked]] 
Sent: Thursday, January 20, 2011 9:55 AM
To: Sumanth Channabasappa
Cc: [email-masked]; Eduardo Cardona; Jean-Francois Mule
Subject: Re: Submission of URN registration request template (cablelabs)

Howdy,

The extracted registration below doesn't reflect a community considerations sections.  It is in the draft, with the following text:

5. Community Considerations

   The CableLabs specifications are publicly available or licensed to
   manufacturers on a nondiscriminatory basis.  CableLabs will maintain
   the allocation of resources for the "cablelabs" NID and maintain
   updated the corresponding specifications where those resources are
   referenced or used.

It might be useful to document whether the CANN specification itself will be publicly available or whether it will under license, if that data is known.

regards,

Ted Hardie

On Sun, Jan 16, 2011 at 1:45 PM, Sumanth Channabasappa <[email-masked]> wrote:
> Folks,
>
> This email is regarding the URN request documented in draft-cardona-cablelabs-urn-05, which describes a Namespace Identifier (NID) -- 'cablelabs' -- for URNs used to identify resources published by Cable Television Laboratories, Inc. (CableLabs).
>
> See: http://tools.ietf.org/html/draft-cardona-cablelabs-urn-05
>
> While we received some early review comments (see: http://www.ietf.org/mail-archive/web/urn-nid/current/msg01056.html) and incorporated them, we failed to send this formal request as pointed out by Leslie (see: http://www.ietf.org/mail-archive/web/urn-nid/current/msg01064.html) and more recently by Peter. We apologize for this oversight. Please consider this request and provide any further comments or suggestions.
>
> Thanks!
> - S (on behalf of the authors)
>
>
> Here's the completed template, as documented in the I-D:
>
>
>   Namespace ID:
>        cablelabs
>
>   Registration Information:
>        registration version number: 1
>        registration date: YYYY-MM-DD [RFC Editor: Please replace YYYY-
>        MM-DD with the date of approval of this document for 
> publication
>        as an RFC.]
>
>   Declared registrant of the namespace:
>        Registering organization
>           Name: Cable Television Laboratories, Inc.
>           Address: 858 Coal Creek Circle, Louisville, CO 80027, USA
>        Designated contact
>           Role: Manager, Standards
>           Email: [email-masked]
>
>   Declaration of syntactic structure:
>        The Namespace Specific String (NSS) of all URNs that use the
>        "cablelabs" NID will have the following structure:
>
>        {CLclass}:{CLClassSpecificString}
>
>        The "CLclass" is a US-ASCII string that conforms to the URN
>        syntax requirements specified in [RFC2141] and defines a
>        specific class of resource type.  Each class will have a
>        specific labeling scheme that is covered by
>        "CLClassSpecificString", which also conforms to the naming
>        requirements of [RFC2141].
>        CableLabs maintains the CableLabs Assigned Names and Numbers
>        [CANN] specification that will contain the assignment of
>        CableLabs resource classes, and the specific registration 
> values
>        assigned for each resource class.
>
>   Relevant ancillary documentation:
>        CableLabs publishes information regarding the registered
>        resources in the CableLabs' Assigned Names and Numbers
>        specification ([CANN]).
>
>   Identifier uniqueness considerations:
>        CableLabs will manage resource classes using the "cablelabs" 
> NID
>        and will be the authority for managing resources and subsequent
>        strings associated.  CableLabs is expected to guarantee the
>        uniqueness of the strings themselves or it may permit secondary
>        responsibility for certain defined resources.
>        CableLabs could allow the use of experimental type values for
>        testing purposes only.  Note that using experimental types may
>        create collisions as multiple users may use the same values for
>        resources and specific strings.
>
>   Identifier persistence considerations:
>        CableLabs will update the CableLabs' Assigned Names and Numbers
>        specification (ref: [CANN]) to document the registered 
> resources
>        that use the "cablelabs" NID.
>
>   Process of identifier assignment:
>        CableLabs will provide procedures for registration of each type
>        of resource that it maintains.  Each such resource may have
>        three types of registration activities:
>           1.  Registered values associated with CableLabs documents or
>           services
>           2.  Registration of values or sub-trees to other entities
>           3.  Name models for use in experimental purposes
>
>   Process for identifier resolution:
>        The namespace is not listed with a resolution discovery system;
>        this is not applicable for this URN registration.
>
>   Rules for Lexical Equivalence:
>        No special considerations; the rules for lexical equivalence of
>        [RFC2141] apply.
>
>   Conformance with URN Syntax:
>        No special considerations.
>
>   Validation mechanism:
>        None specified.  URN assignment will be handled by procedures
>        implemented in support of CableLabs activities.
>
>   Scope:
>        Global
>

---

From: Peter Saint-Andre <[email-masked]>
Date: Fri, 18 Feb 2011 16:50:44 -0700

>    where the registered resources are referenced or used. 

That seems fine to me. In the Community Considerations section, I think
it is also good to include information about how the relevant community
will benefit from having stable references.

Peter

-- 
Peter Saint-Andre
https://stpeter.im/