Subject: informal URN namespace identifiers

From: Peter Saint-Andre <[email-masked]>
Date: Tue, 19 Jul 2011 15:16:27 -0600

The URN namespaces registry contains seven informal identifiers:

http://www.iana.org/assignments/urn-informal/urn-1
http://www.iana.org/assignments/urn-informal/urn-2
http://www.iana.org/assignments/urn-informal/urn-3
http://www.iana.org/assignments/urn-informal/urn-4
http://www.iana.org/assignments/urn-informal/urn-5
http://www.iana.org/assignments/urn-informal/urn-6
http://www.iana.org/assignments/urn-informal/urn-7

As far as I can see, these informal identifiers were mostly intended for 
experimental use. In several cases, the registrations were incomplete, 
see for instance:

"Registration date: TBD"
"Declared registrant of the namespace:  TBD"
"Note to RFC editor: replace xxx with the assigned 3 numeric digit 
identifier."

Do we know if these identifiers are in use? Is it worth the effort to 
clean up this part of the registry?

Peter

-- 
Peter Saint-Andre
https://stpeter.im/

---

From: Ted Hardie <[email-masked]>
Date: Tue, 19 Jul 2011 14:31:40 -0700

On Tue, Jul 19, 2011 at 2:16 PM, Peter Saint-Andre <[email-masked]>wrote:

> http://www.iana.org/**assignments/urn-informal/urn-1<http://www.iana.org/assignments/urn-informal/urn-1>
> http://www.iana.org/**assignments/urn-informal/urn-2<http://www.iana.org/assignments/urn-informal/urn-2>
> http://www.iana.org/**assignments/urn-informal/urn-3<http://www.iana.org/assignments/urn-informal/urn-3>
> http://www.iana.org/**assignments/urn-informal/urn-4<http://www.iana.org/assignments/urn-informal/urn-4>
> http://www.iana.org/**assignments/urn-informal/urn-5<http://www.iana.org/assignments/urn-informal/urn-5>
> http://www.iana.org/**assignments/urn-informal/urn-6<http://www.iana.org/assignments/urn-informal/urn-6>
> http://www.iana.org/**assignments/urn-informal/urn-7<http://www.iana.org/assignments/urn-informal/urn-7>
>
> experimental use. In several cases, the registrations were incomplete, see
> for instance:
>
> "Registration date: TBD"
> Do we know if these identifiers are in use? Is it worth the effort to clean
> up this part of the registry?
>
>
Looking at the registrations, it seems that there were folks actually
asserting their desire to use them at one time (1 might have been meant as
an example, since Michael was heavily involved in the creation of the
system; I can't tell there).

But I'm not sure what you mean by "clean up" the registry.  These numbers
can't be re-used without breaking a fairly basic assumption of the URN
system.  Leaving the registrations there, even if incomplete, seems better
to me than removing them and leaving unaccounted holes in the registry.

regards,

Ted

---

From: Leslie Daigle <[email-masked]>
Date: Tue, 19 Jul 2011 17:34:56 -0400

+1

Leslie.

On 7/19/11 5:31 PM, Ted Hardie wrote:
> On Tue, Jul 19, 2011 at 2:16 PM, Peter Saint-Andre <[email-masked]
> <mailto:[email-masked]>> wrote:
>
>     http://www.iana.org/__assignments/urn-informal/urn-1
>     <http://www.iana.org/assignments/urn-informal/urn-1>
>     http://www.iana.org/__assignments/urn-informal/urn-2
>     <http://www.iana.org/assignments/urn-informal/urn-2>
>     http://www.iana.org/__assignments/urn-informal/urn-3
>     <http://www.iana.org/assignments/urn-informal/urn-3>
>     http://www.iana.org/__assignments/urn-informal/urn-4
>     <http://www.iana.org/assignments/urn-informal/urn-4>
>     http://www.iana.org/__assignments/urn-informal/urn-5
>     <http://www.iana.org/assignments/urn-informal/urn-5>
>     http://www.iana.org/__assignments/urn-informal/urn-6
>     <http://www.iana.org/assignments/urn-informal/urn-6>
>     http://www.iana.org/__assignments/urn-informal/urn-7
>     <http://www.iana.org/assignments/urn-informal/urn-7>
>
>     As far as I can see, these informal identifiers were mostly intended
>     for experimental use. In several cases, the registrations were
>     incomplete, see for instance:
>
>     "Registration date: TBD"
>     Do we know if these identifiers are in use? Is it worth the effort
>     to clean up this part of the registry?
>
>
> asserting their desire to use them at one time (1 might have been meant
> as an example, since Michael was heavily involved in the creation of the
> But I'm not sure what you mean by "clean up" the registry.  These
> numbers can't be re-used without breaking a fairly basic assumption of
> the URN system.  Leaving the registrations there, even if incomplete,
> seems better to me than removing them and leaving unaccounted holes in
> the registry.
>
> regards,
>
> Ted
>
>
>     Peter
>
>     --
>     Peter Saint-Andre
>     https://stpeter.im/
>
>
>

-- 

-------------------------------------------------------------------
"Reality:
      Yours to discover."
                                 -- ThinkingCat
Leslie Daigle
[email-masked]
-------------------------------------------------------------------

---

From: Michael Mealling <[email-masked]>
Date: Tue, 19 Jul 2011 16:41:29 -0500 (CDT)

+1 as well...

If none are being requested I can't see it hurts that much to leave the file there...

-MM

P.S.  Hi everyone! Yea, I'm still alive. Finishing up an MBA in December. Putting together a new space startup if all goes well...

----- Original Message -----
From: "Leslie Daigle" <[email-masked]>
To: "Ted Hardie" <[email-masked]>
Cc: [email-masked], "Michelle Cotton" <[email-masked]>
Sent: Tuesday, July 19, 2011 5:34:56 PM
Subject: Re: informal URN namespace identifiers

+1

Leslie.

--

---

From: Peter Saint-Andre <[email-masked]>
Date: Tue, 19 Jul 2011 15:44:16 -0600

OK, just asking. :)

On 7/19/11 3:41 PM, Michael Mealling wrote:
> From: "Leslie Daigle"<[email-masked]>
> To: "Ted Hardie"<[email-masked]>
> Cc: [email-masked], "Michelle Cotton"<[email-masked]>
>> On Tue, Jul 19, 2011 at 2:16 PM, Peter Saint-Andre<[email-masked]

---

From: Benja Fallenstein <[email-masked]>
Date: Wed, 20 Jul 2011 00:21:45 +0200

Hi Peter,

urn-5 was intended for actual use, and there's software by our group
publicly available that generates them internally and there are a few
files on the web containing them. I don't know if anyone's using the
software at the moment, quite possibly not, but I have in the past and
may again -- not that I'd really expect noticeable breakage, but I
think it would be quite a strange thing to do to un-assign an assigned
URN namespace of all things!

That said, if by "clean up" you mean inserting the parts IANA was
supposed to insert, that could make sense (such as, according to the
process as it was when urn-5 was registered, the registration date,
and arguably the "replace xxx" part in the urn-7 registration, though
IIRC when I last looked the process was to use a placeholder and tell
the reader that. The urn-5 registration is actually still an example
of that, which is probably an oversight on my part, since the
registration was updated once and I could have inserted the actual
identifier then.)

All the best,
- Benja

---

From: Peter Saint-Andre <[email-masked]>
Date: Tue, 19 Jul 2011 17:12:49 -0600

> registration was updated once and I could have inserted the actual

Right, that's what I had in mind.

Peter

-- 
Peter Saint-Andre
https://stpeter.im/