Subject: Request for a formal URN Namespace ID for "globus"

From: Stuart Martin <[email-masked]>
Date: Mon, 4 Jan 2016 18:36:52 -0600

Dear IESG,

Please find attached a draft request for a formal URN Namespace ID for “globus”.

Regards,
Stu Martin

---------------------------------------
Software Development Manager
University of Chicago / Globus
401 N. Michigan Ave., Suite 900
Chicago, IL 60611
Office: 630-677-6892

---

From: Stuart Martin <[email-masked]>
Date: Fri, 8 Jan 2016 14:57:35 -0600

There is now a copy of the globus doc uploaded in datatracker here:
	https://datatracker.ietf.org/doc/draft-martin-urn-globus/ <https://datatracker.ietf.org/doc/draft-martin-urn-globus/>

It has the same “00” version, but the one in datatracker has a few updates.
	- Fixed double spacing throughout doc.
	- Fixed some wrongs dates/years.

Looking forward to your input.

-Stu

> On Jan 4, 2016, at 6:36 PM, Stuart Martin <[email-masked]> wrote:
> 
> Dear IESG,
> 
> <draft-martin-urn-globus-00.txt>

---

From: [email-masked] (Dale R. Worley)
Date: Mon, 11 Jan 2016 15:19:39 -0500

I have some nits:

   2.4. Declaration of the Syntactic Structure

   <URN> ::= "urn: " "globus" ":" <NSS>
------------------^

Remove this space.

   <NSS> ::= <SNID> | <SNID> ":" <SUBNAMESPACE-SPECIFIC-STRING>

You might want to change "SUBNAMESPACE-SPECIFIC-STRING" to
"subnamespace-specific-string" or "SNSS".

   <SNID> ::= 1*<non-colon chars>

   <SUBNAMESPACE-SPECIFIC-STRING> ::= 1*<URN chars>

   <non-colon chars> ::= <non-colon trans> | "%" <hex> <hex>

   <non-colon trans> ::= <upper> | <lower> | <number> | <non-colon
   other>

   <non-colon other> ::= "(" | ")" | "+" | "," | "-" | "." | "=" |
                         "@" | ";" | "$" | "_" | "!" | "*" | "'"

IMO, "<non-colon chars>" should be "<non-colon-chars>", etc.  (Though I
admit that RFC 2141 uses "<URN chars>".)

Dale

---

From: Stuart Martin <[email-masked]>
Date: Mon, 11 Jan 2016 16:03:34 -0600

Hi Dale,

In the new “01” version (https://www.ietf.org/id/draft-martin-urn-globus-01.txt <https://www.ietf.org/id/draft-martin-urn-globus-01.txt>), I changed the following based on your input:

1) Remove the space from “urn: “ to be “urn:"
2) "SUBNAMESPACE-SPECIFIC-STRING” to "subnamespace-specific-string
3)
    a. <non-colon char> to <non-colon-char>
    b. <non-colon trans> and <non-colon other> to be <non-colon-trans> and <non-colon-other>

Thanks for the feedback.  Let me know if any other changes are needed.

-Stu

> On Jan 11, 2016, at 2:19 PM, Dale R. Worley <[email-masked]> wrote:
> 
> I have some nits:
>

---

From: Stuart Martin <[email-masked]>
Date: Tue, 19 Jan 2016 08:50:22 -0600

Hi Dale and all,

Are there any more reviews coming?  We (Globus) would like to start using these Globus URNs in an upcoming software release and would like to prevent a future change to them if possible.

Thanks,
Stu

> On Jan 11, 2016, at 4:03 PM, Stuart Martin <[email-masked]> wrote:
> 
> Hi Dale,
> 
>> On Jan 11, 2016, at 2:19 PM, Dale R. Worley <[email-masked] <mailto:[email-masked]>> wrote:
>> 
>> I have some nits:
>>